summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-23 23:59:11 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-23 23:59:11 +0000
commit203c98b1647b9ed1bb7240abdb83ef85ddad0596 (patch)
tree9f275dc670b0dcb38f7819fda93f83151c674e10 /media-libs
parentQA - fix use invocation (Manifest recommit) (diff)
downloadgentoo-2-203c98b1647b9ed1bb7240abdb83ef85ddad0596.tar.gz
gentoo-2-203c98b1647b9ed1bb7240abdb83ef85ddad0596.tar.bz2
gentoo-2-203c98b1647b9ed1bb7240abdb83ef85ddad0596.zip
compile fix for hppa + gcc-3.4
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/xine-lib/xine-lib-1_rc4-r1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/media-libs/xine-lib/xine-lib-1_rc4-r1.ebuild b/media-libs/xine-lib/xine-lib-1_rc4-r1.ebuild
index a04382e9c751..756e8d918f04 100644
--- a/media-libs/xine-lib/xine-lib-1_rc4-r1.ebuild
+++ b/media-libs/xine-lib/xine-lib-1_rc4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc4-r1.ebuild,v 1.11 2004/06/23 14:48:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc4-r1.ebuild,v 1.12 2004/06/23 23:59:11 vapier Exp $
inherit eutils flag-o-matic gcc libtool
@@ -105,8 +105,11 @@ src_compile() {
&& myconf="${myconf} --with-xv-path=/usr/X11R6/lib"
# The default CFLAGS (-O) is the only thing working on hppa.
- use hppa \
- && unset CFLAGS
+ if use hppa && [ "`gcc-version`" != "3.4" ] ; then
+ unset CFLAGS
+ else
+ append-flags -ffunction-sections
+ fi
econf \
`use_enable X x11` `use_with X x` `use_enable X shm` `use_enable X xft` \