summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-03-08 21:28:41 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-03-08 21:28:41 +0000
commit2b3d64120a5b4d3039e348a84b7f814bf292c98e (patch)
tree0309f0c612a9fab791e34db01a5ddaaa78497df4 /media-libs/xine-lib
parentFix files (diff)
downloadgentoo-2-2b3d64120a5b4d3039e348a84b7f814bf292c98e.tar.gz
gentoo-2-2b3d64120a5b4d3039e348a84b7f814bf292c98e.tar.bz2
gentoo-2-2b3d64120a5b4d3039e348a84b7f814bf292c98e.zip
Add a patch from upstream to fix build with latest libavutil
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/xine-lib')
-rw-r--r--media-libs/xine-lib/ChangeLog6
-rw-r--r--media-libs/xine-lib/files/xine-lib-1.1.16.2-avutil.patch30
-rw-r--r--media-libs/xine-lib/xine-lib-1.1.16.2.ebuild8
3 files changed, 42 insertions, 2 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index fa73953e4b2a..b8c87fb165b5 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/xine-lib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.585 2009/02/28 10:56:27 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.586 2009/03/08 21:28:40 aballier Exp $
+
+ 08 Mar 2009; Alexis Ballier <aballier@gentoo.org>
+ +files/xine-lib-1.1.16.2-avutil.patch, xine-lib-1.1.16.2.ebuild:
+ Add a patch from upstream to fix build with latest libavutil
28 Feb 2009; Raúl Porcel <armin76@gentoo.org> xine-lib-1.1.16.2.ebuild:
alpha/arm/ia64 stable wrt #260069
diff --git a/media-libs/xine-lib/files/xine-lib-1.1.16.2-avutil.patch b/media-libs/xine-lib/files/xine-lib-1.1.16.2-avutil.patch
new file mode 100644
index 000000000000..3e92db9136b8
--- /dev/null
+++ b/media-libs/xine-lib/files/xine-lib-1.1.16.2-avutil.patch
@@ -0,0 +1,30 @@
+# HG changeset patch
+# User Alexis Ballier <aballier@gentoo.org>
+# Date 1236540650 -3600
+# Node ID 044a503f894304328c991f6495f9e14c4c4e5ecb
+# Parent ba642133c0c8b4ece4cb4d2a98355afde7264900
+Fix build with libavutil >= 50.0.0
+
+PIX_FMT_RGBA32 was #defined to PIX_FMT_RGB32 since 2006.
+
+diff -r ba642133c0c8 -r 044a503f8943 src/combined/ffmpeg/ff_video_decoder.c
+--- a/src/combined/ffmpeg/ff_video_decoder.c Sun Mar 08 16:33:02 2009 +0000
++++ b/src/combined/ffmpeg/ff_video_decoder.c Sun Mar 08 20:30:50 2009 +0100
+@@ -588,7 +588,7 @@
+ img->width,
+ this->bih.biHeight);
+
+- } else if (this->context->pix_fmt == PIX_FMT_RGBA32) {
++ } else if (this->context->pix_fmt == PIX_FMT_RGB32) {
+
+ int x, plane_ptr = 0;
+ uint32_t *argb_pixels;
+@@ -1304,7 +1304,7 @@
+
+ /* initialize the colorspace converter */
+ if (!this->cs_convert_init) {
+- if ((this->context->pix_fmt == PIX_FMT_RGBA32) ||
++ if ((this->context->pix_fmt == PIX_FMT_RGB32) ||
+ (this->context->pix_fmt == PIX_FMT_RGB565) ||
+ (this->context->pix_fmt == PIX_FMT_RGB555) ||
+ (this->context->pix_fmt == PIX_FMT_BGR24) ||
diff --git a/media-libs/xine-lib/xine-lib-1.1.16.2.ebuild b/media-libs/xine-lib/xine-lib-1.1.16.2.ebuild
index ad37301aff47..150d1736d2f5 100644
--- a/media-libs/xine-lib/xine-lib-1.1.16.2.ebuild
+++ b/media-libs/xine-lib/xine-lib-1.1.16.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.1.16.2.ebuild,v 1.5 2009/02/28 10:56:27 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.1.16.2.ebuild,v 1.6 2009/03/08 21:28:41 aballier Exp $
EAPI=1
@@ -85,6 +85,12 @@ DEPEND="${RDEPEND}
sys-devel/libtool
nls? ( sys-devel/gettext )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-avutil.patch"
+}
+
src_compile() {
#prevent quicktime crashing
append-flags -frename-registers -ffunction-sections