summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2011-02-24 13:45:35 +0000
committerTony Vroon <chainsaw@gentoo.org>2011-02-24 13:45:35 +0000
commit6f1576651f50ca8d65a44822d87b2bf184a3a11d (patch)
treed1738d981b5706b8a1a5ee3c735900d358c46a60 /media-libs/spandsp
parentbump a new snapshot (diff)
downloadgentoo-2-6f1576651f50ca8d65a44822d87b2bf184a3a11d.tar.gz
gentoo-2-6f1576651f50ca8d65a44822d87b2bf184a3a11d.tar.bz2
gentoo-2-6f1576651f50ca8d65a44822d87b2bf184a3a11d.zip
Drop problematic sse4 & sse5 USE-flags, in GCC 4.5 no such options exist. Closes bug #356299 by Agostino "ago" Sarubbo and hopefully provides a viable stabilisation target for security bug #352059.
(Portage version: 2.1.9.40/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/spandsp')
-rw-r--r--media-libs/spandsp/ChangeLog11
-rw-r--r--media-libs/spandsp/spandsp-0.0.6_pre12-r1.ebuild54
2 files changed, 63 insertions, 2 deletions
diff --git a/media-libs/spandsp/ChangeLog b/media-libs/spandsp/ChangeLog
index 9c7fcd23da3d..5b67508861ab 100644
--- a/media-libs/spandsp/ChangeLog
+++ b/media-libs/spandsp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/spandsp
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/spandsp/ChangeLog,v 1.19 2009/10/17 07:57:03 maekke Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/spandsp/ChangeLog,v 1.20 2011/02/24 13:45:35 chainsaw Exp $
+
+*spandsp-0.0.6_pre12-r1 (24 Feb 2011)
+
+ 24 Feb 2011; Tony Vroon <chainsaw@gentoo.org> +spandsp-0.0.6_pre12-r1.ebuild:
+ Drop problematic sse4 & sse5 USE-flags, in GCC 4.5 no such options exist.
+ Closes bug #356299 by Agostino "ago" Sarubbo and hopefully provides a viable
+ stabilisation target for security bug #352059.
17 Oct 2009; Markus Meier <maekke@gentoo.org> metadata.xml:
remove static-libs description as it is global now
diff --git a/media-libs/spandsp/spandsp-0.0.6_pre12-r1.ebuild b/media-libs/spandsp/spandsp-0.0.6_pre12-r1.ebuild
new file mode 100644
index 000000000000..a96ae43b01b6
--- /dev/null
+++ b/media-libs/spandsp/spandsp-0.0.6_pre12-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/spandsp/spandsp-0.0.6_pre12-r1.ebuild,v 1.1 2011/02/24 13:45:35 chainsaw Exp $
+
+EAPI="2"
+
+inherit multilib versionator
+
+DESCRIPTION="SpanDSP is a library of DSP functions for telephony."
+HOMEPAGE="http://www.soft-switch.org/"
+SRC_URI="http://www.soft-switch.org/downloads/spandsp/${P/_}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc fixed-point mmx sse sse2 sse3 static-libs"
+
+RDEPEND="media-libs/tiff"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen
+ dev-libs/libxslt )"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
+
+# TODO:
+# there are two tests options: tests and test-data
+# they need audiofile, fftw, libxml and probably more
+# configure script is auto-enabling some sse* options sometimes
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable doc) \
+ $(use_enable fixed-point) \
+ $(use_enable mmx) \
+ $(use_enable sse) \
+ $(use_enable sse2) \
+ $(use_enable sse3) \
+ $(use_enable static-libs static)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog DueDiligence NEWS README || die "dodoc failed"
+
+ if ! use static-libs; then
+ # remove useless la file when not installing static lib
+ rm "${D}"/usr/$(get_libdir)/lib${PN}.la || die "rm failed"
+ fi
+
+ if use doc; then
+ dohtml -r doc/{api/html/*,t38_manual} || die "dohtml failed"
+ fi
+}