summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-23 00:49:50 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-23 00:49:50 +0000
commit04350be86408534f5a86963f7ebc778b503243c0 (patch)
treee785df12b920643e4fab40721cae566d41d49f02 /media-libs/sdl-image/sdl-image-1.2.2.ebuild
parentadded SGI's free software B license (diff)
downloadgentoo-2-04350be86408534f5a86963f7ebc778b503243c0.tar.gz
gentoo-2-04350be86408534f5a86963f7ebc778b503243c0.tar.bz2
gentoo-2-04350be86408534f5a86963f7ebc778b503243c0.zip
repoman'd
Diffstat (limited to 'media-libs/sdl-image/sdl-image-1.2.2.ebuild')
-rw-r--r--media-libs/sdl-image/sdl-image-1.2.2.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/media-libs/sdl-image/sdl-image-1.2.2.ebuild b/media-libs/sdl-image/sdl-image-1.2.2.ebuild
index 4aa86817a04c..215b44cfe4c7 100644
--- a/media-libs/sdl-image/sdl-image-1.2.2.ebuild
+++ b/media-libs/sdl-image/sdl-image-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-image/sdl-image-1.2.2.ebuild,v 1.2 2002/07/11 06:30:39 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-image/sdl-image-1.2.2.ebuild,v 1.3 2002/07/23 00:49:50 seemant Exp $
MY_P="${P/sdl-/SDL_}"
S=${WORKDIR}/${MY_P}
@@ -8,25 +8,22 @@ DESCRIPTION="SDL-image is an image file loading library"
SRC_URI="http://www.libsdl.org/projects/SDL_image/release/${MY_P}.tar.gz"
HOMEPAGE="http://www.libsdl.org/projects/SDL_image/index.html"
-DEPEND="virtual/glibc
- >=media-libs/libpng-1.2.1
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="x86"
+
+DEPEND=">=media-libs/libpng-1.2.1
>=media-libs/jpeg-6b
- >=media-libs/libsdl-1.2"
+ >=media-libs/libsdl-1.2"
src_compile() {
- ./configure --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --prefix=/usr \
- --host=${CHOST} || die
-
+ econf || die
emake || die
}
src_install() {
- # emake prefix=${D}/usr install
make DESTDIR=${D} install
}
-