summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-09-17 06:40:25 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-09-17 06:40:25 +0000
commit0ee4b5cb849700af1f1f11919349713eed085030 (patch)
tree42caa4d91bbf3947c76bc2d7e3a2abd00e32e706 /media-libs/raul
parentVersion bump (diff)
downloadgentoo-2-0ee4b5cb849700af1f1f11919349713eed085030.tar.gz
gentoo-2-0ee4b5cb849700af1f1f11919349713eed085030.tar.bz2
gentoo-2-0ee4b5cb849700af1f1f11919349713eed085030.zip
version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.3 x86_64)
Diffstat (limited to 'media-libs/raul')
-rw-r--r--media-libs/raul/ChangeLog7
-rw-r--r--media-libs/raul/raul-0.5.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/media-libs/raul/ChangeLog b/media-libs/raul/ChangeLog
index 4835c210846c..4b69f9b5431e 100644
--- a/media-libs/raul/ChangeLog
+++ b/media-libs/raul/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/raul
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/raul/ChangeLog,v 1.3 2008/07/24 18:56:57 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raul/ChangeLog,v 1.4 2008/09/17 06:40:25 aballier Exp $
+
+*raul-0.5.1 (17 Sep 2008)
+
+ 17 Sep 2008; Alexis Ballier <aballier@gentoo.org> +raul-0.5.1.ebuild:
+ version bump
24 Jul 2008; Raúl Porcel <armin76@gentoo.org> raul-0.5.0.ebuild:
Add ~x86 wrt #232862
diff --git a/media-libs/raul/raul-0.5.1.ebuild b/media-libs/raul/raul-0.5.1.ebuild
new file mode 100644
index 000000000000..eeea7d91fb21
--- /dev/null
+++ b/media-libs/raul/raul-0.5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raul/raul-0.5.1.ebuild,v 1.1 2008/09/17 06:40:25 aballier Exp $
+
+DESCRIPTION="C++ utility library primarily aimed at audio/musical applications."
+HOMEPAGE="http://wiki.drobilla.net/Raul"
+SRC_URI="http://download.drobilla.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc jack test"
+
+RDEPEND=">=dev-cpp/glibmm-2.4
+ >=dev-libs/glib-2.0
+ dev-libs/boost
+ jack? ( >=media-sound/jack-audio-connection-kit-0.107 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ econf $(use_enable debug) \
+ $(use_enable debug pointer-debug) \
+ $(use_enable jack) \
+ $(use_enable test unit-tests) \
+ $(use_enable doc documentation)
+ emake || die "make failed"
+ if use doc; then
+ emake docs || die "failed to create the documentation"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README
+ use doc && dohtml -r doc/html/*
+}