summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-10-21 03:25:11 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-10-21 03:25:11 +0000
commit6389bd3862050672a896e575ab305bbb69231324 (patch)
tree2ab1f57e0f4ebb7d0658b5ebef80b610385ae01d /media-libs/libvisual/libvisual-0.1.7.ebuild
parentUses gnome2.eclass. (Manifest recommit) (diff)
downloadgentoo-2-6389bd3862050672a896e575ab305bbb69231324.tar.gz
gentoo-2-6389bd3862050672a896e575ab305bbb69231324.tar.bz2
gentoo-2-6389bd3862050672a896e575ab305bbb69231324.zip
Version bump.
Diffstat (limited to 'media-libs/libvisual/libvisual-0.1.7.ebuild')
-rw-r--r--media-libs/libvisual/libvisual-0.1.7.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-libs/libvisual/libvisual-0.1.7.ebuild b/media-libs/libvisual/libvisual-0.1.7.ebuild
new file mode 100644
index 000000000000..8b77a65f6200
--- /dev/null
+++ b/media-libs/libvisual/libvisual-0.1.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvisual/libvisual-0.1.7.ebuild,v 1.1 2004/10/21 03:25:11 eradicator Exp $
+
+IUSE="static"
+
+inherit eutils
+
+DESCRIPTION="Libvisual is an abstraction library that comes between applications and audio visualisation plugins."
+HOMEPAGE="http://libvisual.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libvisual/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=""
+
+src_compile() {
+ local myconf=""
+
+ econf $(use_enable static) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}