summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-03-26 00:53:36 +0000
committerTim Harder <radhermit@gentoo.org>2012-03-26 00:53:36 +0000
commitd4bd0841f1998e563570add2b0661b8acda91958 (patch)
tree6ee2000e0f232e006baee9e05186fd495dab21cc /media-libs/libquvi
parentVersion bump. (diff)
downloadgentoo-2-d4bd0841f1998e563570add2b0661b8acda91958.tar.gz
gentoo-2-d4bd0841f1998e563570add2b0661b8acda91958.tar.bz2
gentoo-2-d4bd0841f1998e563570add2b0661b8acda91958.zip
Version bump.
(Portage version: 2.2.0_alpha92/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libquvi')
-rw-r--r--media-libs/libquvi/ChangeLog9
-rw-r--r--media-libs/libquvi/libquvi-0.4.1.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/media-libs/libquvi/ChangeLog b/media-libs/libquvi/ChangeLog
index 4803c8488a02..503cb58889de 100644
--- a/media-libs/libquvi/ChangeLog
+++ b/media-libs/libquvi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libquvi
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libquvi/ChangeLog,v 1.6 2011/12/14 18:11:13 ago Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libquvi/ChangeLog,v 1.7 2012/03/26 00:53:36 radhermit Exp $
+
+*libquvi-0.4.1 (26 Mar 2012)
+
+ 26 Mar 2012; Tim Harder <radhermit@gentoo.org> +libquvi-0.4.1.ebuild:
+ Version bump.
14 Dec 2011; Agostino Sarubbo <ago@gentoo.org> libquvi-0.4.0.ebuild:
Stable for AMD64, wrt bug #393409
diff --git a/media-libs/libquvi/libquvi-0.4.1.ebuild b/media-libs/libquvi/libquvi-0.4.1.ebuild
new file mode 100644
index 000000000000..2425314b58ed
--- /dev/null
+++ b/media-libs/libquvi/libquvi-0.4.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libquvi/libquvi-0.4.1.ebuild,v 1.1 2012/03/26 00:53:36 radhermit Exp $
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="Library for parsing video download links"
+HOMEPAGE="http://quvi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/quvi/${PV:0:3}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples static-libs"
+
+RDEPEND=">=net-misc/curl-7.18.2
+ !<media-libs/quvi-0.4.0
+ >=media-libs/libquvi-scripts-0.4.0
+ >=dev-lang/lua-5.1[deprecated]"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ dev-util/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
+ local myeconfargs=(
+ --with-manual
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/*.{c,h}
+ fi
+}