summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2010-09-05 12:06:06 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2010-09-05 12:06:06 +0000
commit0f3545b3e65c0e5c05876db420a046342d92cc1b (patch)
tree6e89f9a7f45a32163072ebeecca465c162a8e1b9 /media-libs/libgpod
parentVersion bump wrt bug 322991. Fix building with --as-needed wrt bug 334861, fi... (diff)
downloadgentoo-2-0f3545b3e65c0e5c05876db420a046342d92cc1b.tar.gz
gentoo-2-0f3545b3e65c0e5c05876db420a046342d92cc1b.tar.bz2
gentoo-2-0f3545b3e65c0e5c05876db420a046342d92cc1b.zip
Bump to 0.7.94. Lots of fixes, and adds C# bindings (enabled with USE=mono).
(Portage version: 2.2_rc74/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libgpod')
-rw-r--r--media-libs/libgpod/ChangeLog9
-rw-r--r--media-libs/libgpod/libgpod-0.7.94.ebuild48
2 files changed, 56 insertions, 1 deletions
diff --git a/media-libs/libgpod/ChangeLog b/media-libs/libgpod/ChangeLog
index 2619c21cb296..827685c7e0a9 100644
--- a/media-libs/libgpod/ChangeLog
+++ b/media-libs/libgpod/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/libgpod
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/ChangeLog,v 1.74 2010/08/30 15:11:40 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/ChangeLog,v 1.75 2010/09/05 12:06:06 ford_prefect Exp $
+
+*libgpod-0.7.94 (05 Sep 2010)
+
+ 05 Sep 2010; Arun Raghavan <ford_prefect@gentoo.org>
+ +libgpod-0.7.94.ebuild:
+ Bump to 0.7.94. Lots of fixes, and adds C# bindings (enabled with
+ USE=mono).
30 Aug 2010; Fabio Erculiani <lxnay@gentoo.org> libgpod-0.7.93.ebuild:
fix libimobiledevice dependency, it's also a RDEPEND
diff --git a/media-libs/libgpod/libgpod-0.7.94.ebuild b/media-libs/libgpod/libgpod-0.7.94.ebuild
new file mode 100644
index 000000000000..6467f8078c92
--- /dev/null
+++ b/media-libs/libgpod/libgpod-0.7.94.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.7.94.ebuild,v 1.1 2010/09/05 12:06:06 ford_prefect Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Shared library to access the contents of an iPod"
+HOMEPAGE="http://www.gtkpod.org/libgpod/"
+SRC_URI="mirror://sourceforge/gtkpod/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk python +udev iphone mono"
+
+RDEPEND=">=dev-libs/glib-2.16
+ sys-apps/sg3_utils
+ dev-libs/libxml2
+ >=app-pda/libplist-1.0
+ gtk? ( >=x11-libs/gtk+-2.6 )
+ iphone? ( app-pda/libimobiledevice )
+ python? ( >=dev-lang/python-2.3
+ >=media-libs/mutagen-1.8
+ >=dev-python/pygobject-2.8 )
+ udev? ( sys-fs/udev )
+ mono? ( >=dev-lang/mono-1.9.1
+ >=dev-dotnet/gtk-sharp-2.12 )"
+DEPEND="${RDEPEND}
+ python? ( >=dev-lang/swig-1.3.24 )
+ dev-util/pkgconfig
+ dev-libs/libxslt"
+
+src_configure() {
+ econf \
+ --without-hal \
+ $(use_enable udev) \
+ $(use_enable gtk gdk-pixbuf) \
+ $(use_enable python pygobject) \
+ $(use_with python) \
+ $(use_with mono) \
+ $(use_with iphone libimobiledevice)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README TROUBLESHOOTING AUTHORS NEWS README.SysInfo
+}