summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-11 11:33:23 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-11 11:33:23 +0000
commit9df6ae18d102604a09aadd6c52e3f880dd42da46 (patch)
tree3d639cd4651d6816c85fe8d02018cd9d36f4f9b4 /media-libs/libfishsound
parentremove old (diff)
downloadgentoo-2-9df6ae18d102604a09aadd6c52e3f880dd42da46.tar.gz
gentoo-2-9df6ae18d102604a09aadd6c52e3f880dd42da46.tar.bz2
gentoo-2-9df6ae18d102604a09aadd6c52e3f880dd42da46.zip
Remove "Requires" from fishsound.pc to avoid including -I/usr/include/FLAC in cflags (FLAC/assert.h will collide with system assert.h).
(Portage version: 2.2_rc66/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libfishsound')
-rw-r--r--media-libs/libfishsound/ChangeLog7
-rw-r--r--media-libs/libfishsound/files/libfishsound-1.0.0-pc.patch13
-rw-r--r--media-libs/libfishsound/libfishsound-1.0.0.ebuild14
3 files changed, 25 insertions, 9 deletions
diff --git a/media-libs/libfishsound/ChangeLog b/media-libs/libfishsound/ChangeLog
index 5dba9026a555..2da7b82cc23c 100644
--- a/media-libs/libfishsound/ChangeLog
+++ b/media-libs/libfishsound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libfishsound
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libfishsound/ChangeLog,v 1.9 2010/03/11 10:56:57 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfishsound/ChangeLog,v 1.10 2010/03/11 11:33:22 ssuominen Exp $
+
+ 11 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ libfishsound-1.0.0.ebuild, +files/libfishsound-1.0.0-pc.patch:
+ Remove "Requires" from fishsound.pc to avoid including -I/usr/include/FLAC
+ in cflags (FLAC/assert.h will collide with system assert.h).
*libfishsound-1.0.0 (11 Mar 2010)
diff --git a/media-libs/libfishsound/files/libfishsound-1.0.0-pc.patch b/media-libs/libfishsound/files/libfishsound-1.0.0-pc.patch
new file mode 100644
index 000000000000..fa417bb98ef8
--- /dev/null
+++ b/media-libs/libfishsound/files/libfishsound-1.0.0-pc.patch
@@ -0,0 +1,13 @@
+This will avoid including -I/usr/include/FLAC in `pkg-config --cflags fishsound` since
+FLAC/assert.h will collide with system assert.h.
+
+--- fishsound.pc.in
++++ fishsound.pc.in
+@@ -5,7 +5,6 @@
+
+ Name: fishsound
+ Description: Encode and decode Vorbis, Speex, FLAC audio
+-Requires: @fishsound_pkgdeps@
+ Version: @VERSION@
+ Libs: -L${libdir} -lfishsound
+ Libs.private: @VORBIS_LIBS@ @SPEEX_LIBS@ @FLAC_LIBS@
diff --git a/media-libs/libfishsound/libfishsound-1.0.0.ebuild b/media-libs/libfishsound/libfishsound-1.0.0.ebuild
index 223fad5a196c..0efd4a2a65da 100644
--- a/media-libs/libfishsound/libfishsound-1.0.0.ebuild
+++ b/media-libs/libfishsound/libfishsound-1.0.0.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libfishsound/libfishsound-1.0.0.ebuild,v 1.2 2010/03/11 11:18:37 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfishsound/libfishsound-1.0.0.ebuild,v 1.3 2010/03/11 11:33:22 ssuominen Exp $
EAPI=2
+inherit eutils
DESCRIPTION="Simple programming interface for decoding and encoding audio data using vorbis or speex"
HOMEPAGE="http://www.xiph.org/fishsound/"
@@ -11,17 +12,17 @@ SRC_URI="http://downloads.xiph.org/releases/libfishsound/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="speex"
-# flac
+IUSE="flac speex"
RDEPEND="media-libs/libvorbis
media-libs/libogg
+ flac? ( media-libs/flac )
speex? ( media-libs/speex )"
-# flac? ( media-libs/flac )
DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-pc.patch
sed -i \
-e 's:doxygen:doxygen-dummy:' \
configure || die
@@ -29,10 +30,7 @@ src_prepare() {
src_configure() {
local myconf=""
- # FLAC pkg-config file is broken and shouldn't append -I/usr/include/FLAC
- # because of e.g. assert.h
- # use flac ||
- myconf="${myconf} --disable-flac"
+ use flac || myconf="${myconf} --disable-flac"
use speex || myconf="${myconf} --disable-speex"
econf \