summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2007-02-03 21:06:16 +0000
committerSteve Arnold <nerdboy@gentoo.org>2007-02-03 21:06:16 +0000
commit866f6fabf6b0810cb0631f3b731afb8c221fb895 (patch)
treec440ddffd4bfe470bb83fb6fb2d95ba01cff442c /media-libs/libexif
parentMask ks3switch for removal. (diff)
downloadgentoo-2-866f6fabf6b0810cb0631f3b731afb8c221fb895.tar.gz
gentoo-2-866f6fabf6b0810cb0631f3b731afb8c221fb895.tar.bz2
gentoo-2-866f6fabf6b0810cb0631f3b731afb8c221fb895.zip
fixed annoying bugs 150152 and 160973
(Portage version: 2.1.2-r4)
Diffstat (limited to 'media-libs/libexif')
-rw-r--r--media-libs/libexif/ChangeLog8
-rw-r--r--media-libs/libexif/files/libexif-0.6.13-doxy-stamp-make.patch11
-rw-r--r--media-libs/libexif/libexif-0.6.13-r1.ebuild20
3 files changed, 31 insertions, 8 deletions
diff --git a/media-libs/libexif/ChangeLog b/media-libs/libexif/ChangeLog
index fd278457e9d2..e05cee25f91f 100644
--- a/media-libs/libexif/ChangeLog
+++ b/media-libs/libexif/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libexif
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/ChangeLog,v 1.61 2007/01/05 20:01:58 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/ChangeLog,v 1.62 2007/02/03 21:06:16 nerdboy Exp $
+
+ 03 Feb 2007; Steve Arnold <nerdboy@gentoo.org>
+ +files/libexif-0.6.13-doxy-stamp-make.patch, libexif-0.6.13-r1.ebuild:
+ Fixed annoying bugs 150152 and 160973 (thanks to Ed Catmur and Jozsef Daniel
+ for diagnosing and posting the patch, as well as the people on the other bug).
+ Tested with all USE flags disabled and no doxygen present.
05 Jan 2007; Robin H. Johnson <robbat2@gentoo.org>
+files/libexif-0.6.13-parallel-build.patch, libexif-0.6.13-r1.ebuild:
diff --git a/media-libs/libexif/files/libexif-0.6.13-doxy-stamp-make.patch b/media-libs/libexif/files/libexif-0.6.13-doxy-stamp-make.patch
new file mode 100644
index 000000000000..bd45dd1f5f12
--- /dev/null
+++ b/media-libs/libexif/files/libexif-0.6.13-doxy-stamp-make.patch
@@ -0,0 +1,11 @@
+--- doc/Makefile.am 2007/01/08 20:02:30 1.1
++++ doc/Makefile.am 2007/01/08 20:05:54
+@@ -16,7 +16,7 @@ $(HTML_APIDOC_INTERNALS_DIR).stamp: Doxy
+
+ # FIXME: Depending on the source files would be sufficient...
+ # This generates HTML_APIDOC_DIR as well as DOXYGEN_OUTPUT_DIR
+-$(DOXYGEN_OUTPUT_DIR).stamp: Doxyfile $(top_builddir)/libexif/libexif.la
++$(DOXYGEN_OUTPUT_DIR).stamp $(HTML_APIDOC_DIR).stamp: Doxyfile $(top_builddir)/libexif/libexif.la
+ doxygen $<
+ echo > $@
+
diff --git a/media-libs/libexif/libexif-0.6.13-r1.ebuild b/media-libs/libexif/libexif-0.6.13-r1.ebuild
index 5322424c2e19..15ed301b78f2 100644
--- a/media-libs/libexif/libexif-0.6.13-r1.ebuild
+++ b/media-libs/libexif/libexif-0.6.13-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/libexif-0.6.13-r1.ebuild,v 1.8 2007/01/05 20:01:58 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/libexif-0.6.13-r1.ebuild,v 1.9 2007/02/03 21:06:16 nerdboy Exp $
inherit eutils libtool
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ~ppc-macos ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="nls doc"
+IUSE="doc nls static"
DEPEND="dev-util/pkgconfig
doc? ( app-doc/doxygen )
@@ -22,9 +22,10 @@ src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/libexif-0.6.13-doxygen.patch
- epatch ${FILESDIR}/libexif-0.6.13-parallel-build.patch
- epatch "${FILESDIR}/${P}-pkgconfig.patch"
+ epatch ${FILESDIR}/${P}-doxygen.patch
+ epatch ${FILESDIR}/${P}-parallel-build.patch
+ epatch ${FILESDIR}/${P}-doxy-stamp-make.patch
+ epatch ${FILESDIR}/${P}-pkgconfig.patch
# The libexif hackers made a goof on the soname versioning.
sed -i 's/^LIBEXIF_AGE=0$/LIBEXIF_AGE=2/' ${S}/configure
@@ -36,7 +37,11 @@ src_unpack() {
}
src_compile() {
- econf $(use_enable nls) $(use_enable doc) || die
+ local my_conf
+ use doc && my_conf="--with-doc-dir=/usr/share/doc/${PF}"
+ use nls || my_conf="${my_conf} --without-libintl-prefix"
+ econf $(use_enable nls) $(use_enable doc) $(use_enable static) \
+ --with-pic --disable-rpath ${my_conf} || die
emake || die
}
@@ -44,6 +49,7 @@ src_install() {
dodir /usr/$(get_libdir)
dodir /usr/include/libexif
use nls && dodir /usr/share/locale
+ use doc && dodir /usr/share/doc/${PF}
dodir /usr/$(get_libdir)/pkgconfig
make DESTDIR="${D}" install || die
@@ -51,7 +57,7 @@ src_install() {
dodoc ChangeLog README
# installs a blank directory for whatever broken reason
- use nls || rm -rf ${D}/usr/share/locale
+ use nls || rm -rf ${D}usr/share/locale
# Keep around old lib
preserve_old_lib /usr/$(get_libdir)/libexif.so.9