summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-11-07 09:41:22 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-11-07 09:41:22 +0000
commit6b6b1218b4a78e864feaf1c4e8321145b9953958 (patch)
tree9b6e0363acbdf2b0b41d404c7561d7c949e7d593 /media-libs/libdecodeqr
parentAdd as-is and X11 to LICENSE for oldXMenu und etc/rgb.txt, respectively. (diff)
downloadgentoo-2-6b6b1218b4a78e864feaf1c4e8321145b9953958.tar.gz
gentoo-2-6b6b1218b4a78e864feaf1c4e8321145b9953958.tar.bz2
gentoo-2-6b6b1218b4a78e864feaf1c4e8321145b9953958.zip
Initial commit.
(Portage version: 2.2_rc13/cvs/Linux 2.6.28-rc3-00054-g75fa677 x86_64)
Diffstat (limited to 'media-libs/libdecodeqr')
-rw-r--r--media-libs/libdecodeqr/ChangeLog11
-rw-r--r--media-libs/libdecodeqr/files/libdecodeqr-0.9.3-makefile.patch31
-rw-r--r--media-libs/libdecodeqr/libdecodeqr-0.9.3.ebuild36
-rw-r--r--media-libs/libdecodeqr/metadata.xml8
4 files changed, 86 insertions, 0 deletions
diff --git a/media-libs/libdecodeqr/ChangeLog b/media-libs/libdecodeqr/ChangeLog
new file mode 100644
index 000000000000..460adb4c255b
--- /dev/null
+++ b/media-libs/libdecodeqr/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-libs/libdecodeqr
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdecodeqr/ChangeLog,v 1.1 2008/11/07 09:41:22 robbat2 Exp $
+
+*libdecodeqr-0.9.3 (07 Nov 2008)
+
+ 07 Nov 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/libdecodeqr-0.9.3-makefile.patch, +metadata.xml,
+ +libdecodeqr-0.9.3.ebuild:
+ Initial commit.
+
diff --git a/media-libs/libdecodeqr/files/libdecodeqr-0.9.3-makefile.patch b/media-libs/libdecodeqr/files/libdecodeqr-0.9.3-makefile.patch
new file mode 100644
index 000000000000..a2fc53c3ff44
--- /dev/null
+++ b/media-libs/libdecodeqr/files/libdecodeqr-0.9.3-makefile.patch
@@ -0,0 +1,31 @@
+diff -Nuar libdecodeqr-0.9.3.orig/src/libdecodeqr/Makefile.in libdecodeqr-0.9.3/src/libdecodeqr/Makefile.in
+--- libdecodeqr-0.9.3.orig/src/libdecodeqr/Makefile.in 2008-11-07 01:26:19.463859379 -0800
++++ libdecodeqr-0.9.3/src/libdecodeqr/Makefile.in 2008-11-07 01:27:55.190972807 -0800
+@@ -31,7 +31,7 @@
+ ARFLAGS=rcs
+
+ LD=@LD@
+-LDFLAGS=@LDFLAGS@ -shared -soname $(SONAME)
++LDFLAGS=@LDFLAGS@
+ LIBCV=@LIBCV@
+ LIBS=$(LIBCV)
+
+@@ -53,13 +53,13 @@
+ $(AR) $(ARFLAGS) $@ $(objs)
+
+ $(LIBNAME_SO): $(objs)
+- $(LD) -o $@ $(objs) $(LDFLAGS) $(LIBS)
++ $(LD) $(LDFLAGS) -o $@ $(objs) -shared -soname $(SONAME) $(LIBS)
+
+ install: $(dsts)
+- $(INSTALL) -m 0755 $(LIBNAME_A) $(LIBNAME_SO) $(libdir)
+- $(LDCONFIG) -n $(libdir)
+- $(LN) -sf $(libdir)/$(LIBNAME_SO) $(libdir)/$(BASENAME).so
+- $(INSTALL) -m 0644 decodeqr.h qrerror.h qrtypes.h $(includedir)
++ $(INSTALL) -m 0755 $(LIBNAME_A) $(LIBNAME_SO) $(DESTDIR)$(libdir)
++ #$(LDCONFIG) -n $(libdir)
++ $(LN) -sf $(libdir)/$(LIBNAME_SO) $(DESTDIR)$(libdir)/$(BASENAME).so
++ $(INSTALL) -m 0644 decodeqr.h qrerror.h qrtypes.h $(DESTDIR)$(includedir)
+
+ clean:
+ -rm *.a *.o *.so.*
diff --git a/media-libs/libdecodeqr/libdecodeqr-0.9.3.ebuild b/media-libs/libdecodeqr/libdecodeqr-0.9.3.ebuild
new file mode 100644
index 000000000000..a78ddfbe5c29
--- /dev/null
+++ b/media-libs/libdecodeqr/libdecodeqr-0.9.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdecodeqr/libdecodeqr-0.9.3.ebuild,v 1.1 2008/11/07 09:41:22 robbat2 Exp $
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="libdecodeqr is a C/C++ library for decoding QR code based on JIS X 0510 and ISO/IEC18004."
+HOMEPAGE="http://trac.koka-in.org/libdecodeqr"
+# Upstream uses Trac, which causes FUN.
+# http://trac.koka-in.org/libdecodeqr/attachment/wiki/WikiStart/libdecodeqr-0.9.3.tar.bz2?format=raw
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="media-libs/opencv"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}/src"
+
+src_unpack() {
+ unpack "${A}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ append-flags -I/usr/include/opencv
+ econf LDFLAGS="${LDFLAGS//-Wl,/ }" || die
+ emake libdecodeqr || die
+ emake || die
+}
+
+src_install() {
+ mkdir -pv "${D}"/usr/$(get_libdir) "${D}"/usr/include
+ emake install DESTDIR="${D}" || die
+}
diff --git a/media-libs/libdecodeqr/metadata.xml b/media-libs/libdecodeqr/metadata.xml
new file mode 100644
index 000000000000..5d9f5be9d49d
--- /dev/null
+++ b/media-libs/libdecodeqr/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>