summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrank van de Pol <fvdpol@gentoo.org>2004-11-27 18:21:14 +0000
committerFrank van de Pol <fvdpol@gentoo.org>2004-11-27 18:21:14 +0000
commit6a8b43bf7cfdc6fad1401bf4f673e67af2867941 (patch)
tree4685e777e3ebd7ba836e3f76ec8fa6dd4a3d909d /media-libs/libclthreads/libclthreads-1.0.2.ebuild
parentNew version. Changes include more make.conf error highlighting (CFLAGS="-s -... (diff)
downloadgentoo-2-6a8b43bf7cfdc6fad1401bf4f673e67af2867941.tar.gz
gentoo-2-6a8b43bf7cfdc6fad1401bf4f673e67af2867941.tar.bz2
gentoo-2-6a8b43bf7cfdc6fad1401bf4f673e67af2867941.zip
Version bump.
Diffstat (limited to 'media-libs/libclthreads/libclthreads-1.0.2.ebuild')
-rw-r--r--media-libs/libclthreads/libclthreads-1.0.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/libclthreads/libclthreads-1.0.2.ebuild b/media-libs/libclthreads/libclthreads-1.0.2.ebuild
new file mode 100644
index 000000000000..666edfb1394f
--- /dev/null
+++ b/media-libs/libclthreads/libclthreads-1.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libclthreads/libclthreads-1.0.2.ebuild,v 1.1 2004/11/27 18:21:14 fvdpol Exp $
+
+IUSE=""
+
+inherit eutils
+
+S="${WORKDIR}/clthreads-${PV}"
+
+DESCRIPTION="An audio library by Fons Adriaensen <fons.adriaensen@skynet.be>"
+HOMEPAGE="http://users.skynet.be/solaris/linuxaudio"
+SRC_URI="http://users.skynet.be/solaris/linuxaudio/downloads/clthreads-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+DEPEND="virtual/libc"
+
+src_compile() {
+ epatch "${FILESDIR}/${P}-makefile.patch"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+}