summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-05-29 18:42:42 +0000
committerMichał Górny <mgorny@gentoo.org>2014-05-29 18:42:42 +0000
commit97b34c69a80e981ca89e341efcb5fcded6209901 (patch)
tree9d1621ffd303e44315e12744ba2bb5afc468bb4d /media-libs/libart_lgpl
parentEnable multilib support, as a dependency of PAM. (diff)
downloadgentoo-2-97b34c69a80e981ca89e341efcb5fcded6209901.tar.gz
gentoo-2-97b34c69a80e981ca89e341efcb5fcded6209901.tar.bz2
gentoo-2-97b34c69a80e981ca89e341efcb5fcded6209901.zip
Enable multilib support.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-libs/libart_lgpl')
-rw-r--r--media-libs/libart_lgpl/ChangeLog9
-rw-r--r--media-libs/libart_lgpl/libart_lgpl-2.3.21-r2.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/media-libs/libart_lgpl/ChangeLog b/media-libs/libart_lgpl/ChangeLog
index fce0ff069a79..a65db278da03 100644
--- a/media-libs/libart_lgpl/ChangeLog
+++ b/media-libs/libart_lgpl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libart_lgpl
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libart_lgpl/ChangeLog,v 1.78 2013/07/06 16:35:16 ottxor Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libart_lgpl/ChangeLog,v 1.79 2014/05/29 18:42:42 mgorny Exp $
+
+*libart_lgpl-2.3.21-r2 (29 May 2014)
+
+ 29 May 2014; Michał Górny <mgorny@gentoo.org> +libart_lgpl-2.3.21-r2.ebuild:
+ Enable multilib support.
06 Jul 2013; Christoph Junghans <ottxor@gentoo.org>
libart_lgpl-2.3.21-r1.ebuild:
diff --git a/media-libs/libart_lgpl/libart_lgpl-2.3.21-r2.ebuild b/media-libs/libart_lgpl/libart_lgpl-2.3.21-r2.ebuild
new file mode 100644
index 000000000000..5c90ac9ec064
--- /dev/null
+++ b/media-libs/libart_lgpl/libart_lgpl-2.3.21-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libart_lgpl/libart_lgpl-2.3.21-r2.ebuild,v 1.1 2014/05/29 18:42:42 mgorny Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit autotools eutils gnome2 multilib-minimal
+
+DESCRIPTION="a LGPL version of libart"
+HOMEPAGE="http://www.levien.com/libart"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140508-r6
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+DEPEND="virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+# The provided tests are interactive only
+RESTRICT="test"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/libart2-config
+)
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix crosscompiling, bug #185684
+ rm "${S}"/art_config.h
+ epatch "${FILESDIR}"/${PN}-2.3.21-crosscompile.patch
+
+ # Do not build tests if not required
+ epatch "${FILESDIR}"/${PN}-2.3.21-no-test-build.patch
+
+ AT_NOELIBTOOLIZE=yes eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ --disable-static
+}