summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-29 01:15:45 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-29 01:15:45 +0000
commit8aef15eb4cd371381535275501ec221f8c0b412c (patch)
treeb09d2247614f6eff41d35dca6af1e4f462933634 /media-libs/gdk-pixbuf
parentamd64 love for digitalfallout (diff)
downloadgentoo-2-8aef15eb4cd371381535275501ec221f8c0b412c.tar.gz
gentoo-2-8aef15eb4cd371381535275501ec221f8c0b412c.tar.bz2
gentoo-2-8aef15eb4cd371381535275501ec221f8c0b412c.zip
fix aclocal warnings
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'media-libs/gdk-pixbuf')
-rw-r--r--media-libs/gdk-pixbuf/files/gdk-pixbuf-0.22.0-m4.patch9
-rw-r--r--media-libs/gdk-pixbuf/gdk-pixbuf-0.22.0-r4.ebuild37
2 files changed, 26 insertions, 20 deletions
diff --git a/media-libs/gdk-pixbuf/files/gdk-pixbuf-0.22.0-m4.patch b/media-libs/gdk-pixbuf/files/gdk-pixbuf-0.22.0-m4.patch
new file mode 100644
index 000000000000..032976db931e
--- /dev/null
+++ b/media-libs/gdk-pixbuf/files/gdk-pixbuf-0.22.0-m4.patch
@@ -0,0 +1,9 @@
+Fix aclocal warning:
+/usr/share/aclocal/gdk-pixbuf.m4:12: warning: underquoted definition of AM_PATH_GDK_PIXBUF
+--- gdk-pixbuf-0.22.0/gdk-pixbuf.m4
++++ gdk-pixbuf-0.22.0/gdk-pixbuf.m4
+@@ -11,3 +11,3 @@
+ dnl
+-AC_DEFUN(AM_PATH_GDK_PIXBUF,
++AC_DEFUN([AM_PATH_GDK_PIXBUF],
+ [dnl
diff --git a/media-libs/gdk-pixbuf/gdk-pixbuf-0.22.0-r4.ebuild b/media-libs/gdk-pixbuf/gdk-pixbuf-0.22.0-r4.ebuild
index 735a316a0bf6..3d036b87486d 100644
--- a/media-libs/gdk-pixbuf/gdk-pixbuf-0.22.0-r4.ebuild
+++ b/media-libs/gdk-pixbuf/gdk-pixbuf-0.22.0-r4.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gdk-pixbuf/gdk-pixbuf-0.22.0-r4.ebuild,v 1.1 2005/03/30 09:51:37 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gdk-pixbuf/gdk-pixbuf-0.22.0-r4.ebuild,v 1.2 2005/04/29 01:13:48 vapier Exp $
-inherit virtualx libtool gnome.org gnuconfig eutils
+inherit virtualx libtool gnome.org eutils
DESCRIPTION="GNOME Image Library"
HOMEPAGE="http://www.gtk.org/"
LICENSE="GPL-2 LGPL-2"
SLOT="0"
-KEYWORDS="~x86 ~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc mmx"
RDEPEND="media-libs/jpeg
@@ -25,30 +25,27 @@ DEPEND="${RDEPEND}
doc? ( dev-util/gtk-doc )"
src_unpack() {
-
unpack ${A}
-
- cd ${S}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-m4.patch
# security fix (#64230)
- epatch ${FILESDIR}/${P}-bmp_secure.patch
- epatch ${FILESDIR}/${P}-loaders.patch
+ epatch "${FILESDIR}"/${P}-bmp_secure.patch
+ epatch "${FILESDIR}"/${P}-loaders.patch
# reject corrupt bmps (#64230)
- epatch ${FILESDIR}/${P}-bmp_reject_corrupt.patch
-
-}
+ epatch "${FILESDIR}"/${P}-bmp_reject_corrupt.patch
-src_compile() {
- #allow to build on mipslinux systems
- gnuconfig_update
-
- local myconf
#update libtool, else we get the "relink bug"
elibtoolize
+}
- use doc && myconf="--enable-gtk-doc" \
- || myconf="--disable-gtk-doc"
+src_compile() {
+ local myconf=""
use mmx || myconf="${myconf} --disable-mmx"
- econf --sysconfdir=/etc/X11/gdk-pixbuf ${myconf} || die
+ econf \
+ --sysconfdir=/etc/X11/gdk-pixbuf \
+ $(use_enable doc gtk-doc) \
+ ${myconf} \
+ || die
#build needs to be able to
#connect to an X display.
@@ -64,5 +61,5 @@ src_install() {
chmod a+rx ${D}/usr/$(get_libdir)/gdk-pixbuf/loaders
chmod a+r ${D}/usr/$(get_libdir)/gdk-pixbuf/loaders/*
- dodoc AUTHORS COPYING* ChangeLog INSTALL README NEWS TODO
+ dodoc AUTHORS ChangeLog INSTALL README NEWS TODO
}