summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-16 08:52:23 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-16 08:52:23 +0000
commitcece8e998810e55c011f6bf8c7e327cc986fabf6 (patch)
treefb03307fc40c541e6bd2bcd82bd75309c1221993 /media-gfx
parentVersion bump. (Manifest recommit) (diff)
downloadgentoo-2-cece8e998810e55c011f6bf8c7e327cc986fabf6.tar.gz
gentoo-2-cece8e998810e55c011f6bf8c7e327cc986fabf6.tar.bz2
gentoo-2-cece8e998810e55c011f6bf8c7e327cc986fabf6.zip
dont access $CC !
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/duhdraw/duhdraw-2.8.12.ebuild13
-rw-r--r--media-gfx/fbv/fbv-0.99.ebuild26
-rw-r--r--media-gfx/w3mimgfb/w3mimgfb-0.8.ebuild11
-rw-r--r--media-gfx/w3mimgfb/w3mimgfb-0.9.1.ebuild11
4 files changed, 29 insertions, 32 deletions
diff --git a/media-gfx/duhdraw/duhdraw-2.8.12.ebuild b/media-gfx/duhdraw/duhdraw-2.8.12.ebuild
index e533a3e8bc22..17e40de949ec 100644
--- a/media-gfx/duhdraw/duhdraw-2.8.12.ebuild
+++ b/media-gfx/duhdraw/duhdraw-2.8.12.ebuild
@@ -1,22 +1,25 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/duhdraw/duhdraw-2.8.12.ebuild,v 1.2 2003/07/12 16:44:48 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/duhdraw/duhdraw-2.8.12.ebuild,v 1.3 2004/05/16 08:49:12 vapier Exp $
+
+inherit gcc
DESCRIPTION="ASCII art editor"
HOMEPAGE="http://www.wwco.com/~wls/opensource/duhdraw.php"
SRC_URI="http://www.wwco.com/~wls/opensource/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
IUSE=""
+
DEPEND="sys-libs/ncurses"
-S=${WORKDIR}/${P}
src_compile() {
- emake CC="${CC} -s ${CFLAGS}" || die
+ emake CC="$(gcc-getCC) -s ${CFLAGS}" || die
}
src_install() {
- dobin ansi ansitoc duhdraw
+ dobin ansi ansitoc duhdraw || die
dodoc CREDITS HISTORY TODO READ.ME
}
diff --git a/media-gfx/fbv/fbv-0.99.ebuild b/media-gfx/fbv/fbv-0.99.ebuild
index dba3d242b4bd..4731678ada9e 100644
--- a/media-gfx/fbv/fbv-0.99.ebuild
+++ b/media-gfx/fbv/fbv-0.99.ebuild
@@ -1,42 +1,34 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/fbv/fbv-0.99.ebuild,v 1.1 2003/08/25 13:43:46 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/fbv/fbv-0.99.ebuild,v 1.2 2004/05/16 08:49:12 vapier Exp $
-IUSE="png gif jpeg"
+inherit gcc
-DESCRIPTION="fbv is a simple program to view pictures on a linux framebuffer device"
+DESCRIPTION="simple program to view pictures on a linux framebuffer device"
HOMEPAGE="http://s-tech.elsat.net.pl/fbv/"
SRC_URI="http://s-tech.elsat.net.pl/fbv//${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86"
+IUSE="png gif jpeg"
DEPEND="gif? ( media-libs/libungif )
jpeg? ( media-libs/jpeg )
png? ( media-libs/libpng )"
src_compile() {
-
local myconf
use png || myconf="${myconf} --without-libpng"
use gif || myconf="${myconf} --without-libungif"
use jpeg || myconf="${myconf} --without-libjpeg"
-
- ./configure \
- --prefix=/usr \
- --bindir=/usr/bin \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} || die
- emake CC="${CC} ${CFLAGS}" || die
+ econf ${myconf} || die
+ emake CC="$(gcc-getCC) ${CFLAGS}" || die
}
src_install() {
-
- dobin fbv
+ dobin fbv || die
doman fbv.1
-
dodoc ChangeLog README TODO VERSION
}
diff --git a/media-gfx/w3mimgfb/w3mimgfb-0.8.ebuild b/media-gfx/w3mimgfb/w3mimgfb-0.8.ebuild
index 8662699b68e1..edfcb127977e 100644
--- a/media-gfx/w3mimgfb/w3mimgfb-0.8.ebuild
+++ b/media-gfx/w3mimgfb/w3mimgfb-0.8.ebuild
@@ -1,22 +1,23 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/w3mimgfb/w3mimgfb-0.8.ebuild,v 1.4 2004/04/26 09:35:50 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/w3mimgfb/w3mimgfb-0.8.ebuild,v 1.5 2004/05/16 08:49:12 vapier Exp $
-IUSE=""
+inherit gcc
DESCRIPTION="Image viewer for w3m under frame buffer environment"
-SRC_URI="http://homepage3.nifty.com/slokar/fb/${P}.tar.gz"
HOMEPAGE="http://homepage3.nifty.com/slokar/fb/w3mimg.html"
+SRC_URI="http://homepage3.nifty.com/slokar/fb/${P}.tar.gz"
-SLOT="0"
LICENSE="w3m BSD"
+SLOT="0"
KEYWORDS="x86"
+IUSE=""
DEPEND=">=media-libs/stimg-0.1.0
virtual/textbrowser"
src_compile() {
- emake CC="${CC}" CFLAGS="${CFLAGS}" || die "emake failed"
+ emake CC="$(gcc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
}
src_install() {
diff --git a/media-gfx/w3mimgfb/w3mimgfb-0.9.1.ebuild b/media-gfx/w3mimgfb/w3mimgfb-0.9.1.ebuild
index a725bc63936c..4b8f61a716ca 100644
--- a/media-gfx/w3mimgfb/w3mimgfb-0.9.1.ebuild
+++ b/media-gfx/w3mimgfb/w3mimgfb-0.9.1.ebuild
@@ -1,22 +1,23 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/w3mimgfb/w3mimgfb-0.9.1.ebuild,v 1.3 2004/04/26 09:35:50 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/w3mimgfb/w3mimgfb-0.9.1.ebuild,v 1.4 2004/05/16 08:49:12 vapier Exp $
-IUSE=""
+inherit gcc
DESCRIPTION="Image viewer for w3m under frame buffer environment"
-SRC_URI="http://homepage3.nifty.com/slokar/fb/${P}.tar.gz"
HOMEPAGE="http://homepage3.nifty.com/slokar/fb/w3mimg.html"
+SRC_URI="http://homepage3.nifty.com/slokar/fb/${P}.tar.gz"
-SLOT="0"
LICENSE="w3m BSD"
+SLOT="0"
KEYWORDS="x86 ~ppc"
+IUSE=""
DEPEND=">=media-libs/stimg-0.1.0
virtual/textbrowser"
src_compile() {
- emake CC="${CC}" CFLAGS="${CFLAGS}" || die "emake failed"
+ emake CC="$(gcc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
}
src_install() {