summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Dack <tad@gentoo.org>2003-01-18 14:55:48 +0000
committerTroy Dack <tad@gentoo.org>2003-01-18 14:55:48 +0000
commitc9a328d0f3cb42dce3acc464b8e96d22c0b78530 (patch)
tree9b7764cdf3bea4650342d2d73c4c7278007ff301 /media-gfx
parentAdded mips to keywords (diff)
downloadgentoo-2-c9a328d0f3cb42dce3acc464b8e96d22c0b78530.tar.gz
gentoo-2-c9a328d0f3cb42dce3acc464b8e96d22c0b78530.tar.bz2
gentoo-2-c9a328d0f3cb42dce3acc464b8e96d22c0b78530.zip
Version bump. Console text colour can now be changed.
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/bootsplash/ChangeLog8
-rw-r--r--media-gfx/bootsplash/bootsplash-0.4.ebuild116
-rw-r--r--media-gfx/bootsplash/files/digest-bootsplash-0.41
3 files changed, 124 insertions, 1 deletions
diff --git a/media-gfx/bootsplash/ChangeLog b/media-gfx/bootsplash/ChangeLog
index ea6171db7ff3..aff81f1cb6be 100644
--- a/media-gfx/bootsplash/ChangeLog
+++ b/media-gfx/bootsplash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/bootsplash
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/ChangeLog,v 1.2 2003/01/17 02:49:00 tad Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/ChangeLog,v 1.3 2003/01/18 14:54:19 tad Exp $
+
+*bootsplash-0.4-r0 (19 JAN 2003)
+
+ 19 JAN 2003; Troy Dack <tad@gentoo.org> bootsplash-0.4.ebuild:
+ Version bump. bootsplash-config removed, deprecated. Console
+ text colour can now be changed.
*bootsplash-0.3-r0 (17 JAN 2003)
diff --git a/media-gfx/bootsplash/bootsplash-0.4.ebuild b/media-gfx/bootsplash/bootsplash-0.4.ebuild
new file mode 100644
index 000000000000..159793d860e6
--- /dev/null
+++ b/media-gfx/bootsplash/bootsplash-0.4.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/bootsplash-0.4.ebuild,v 1.1 2003/01/18 14:55:48 tad Exp $
+
+DESCRIPTION="Graphical backgrounds for frame buffer consoles"
+
+HOMEPAGE="http://linux.tkdack.com"
+
+SRC_URI="http://gentoo.tkdack.com/downloads/gentoo/bootsplash-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=""
+
+RDEPEND=""
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ # compile splashutil
+ cd ${S}/splashutil
+ make || die
+
+ # fix version in local.{start,stop}
+ mv ${S}/local.start ${S}/local.start.orig
+ sed -e s/PV/$PV/ ${S}/local.start.orig > ${S}/local.start || die
+
+ mv ${S}/local.stop ${S}/local.stop.orig
+ sed -e s/PV/$PV/ ${S}/local.stop.orig > ${S}/local.stop || die
+
+ rm ${S}/local.*.orig
+}
+
+src_install() {
+
+ exeinto /usr/bin
+ doexe ${S}/splashutil/splash
+
+ insinto /usr/share/${P}
+ doins ${S}/*.jpg
+ doins ${S}/*.cfg
+
+ # link default config
+ dosym ./gentoo-boot-1280x1024.jpg /usr/share/${P}/bootsplash.jpg
+ dosym ./gentoo-boot-1280x1024.cfg /usr/share/${P}/bootsplash.cfg
+
+ doins ${S}/boot_splash_complete.2.4.19-vanilla.patch
+ doins ${S}/grub.conf.sample
+
+ insinto /etc/conf.d
+ doins ${S}/local.start
+ doins ${S}/local.stop
+
+ dodoc README
+ dodoc COPYING
+ dodoc CREDITS
+
+ # generate initial initrd file
+ ${S}/splashutil/splash -s -f ${D}/usr/share/${P}/bootsplash.cfg > ${D}/usr/share/${P}/initrd
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/media-gfx/${P}/${P}.ebuild config\""
+ einfo "to have your kernel sources in /usr/src/linux patched with the"
+ einfo "Framebuffer Bootsplash patches"
+ einfo
+ echo ""
+ ewarn "If you have already patched the kernel then you only need to copy"
+ ewarn "the initrd from /usr/share/${P}/initrd to /boot"
+ ewarn
+ echo ""
+ einfo
+ einfo "Please \"merge\" any changed files in /etc/conf.d"
+ einfo
+}
+
+pkg_config() {
+ ewarn
+ ewarn "Patching the kernel in /usr/src/linux ..."
+ ewarn
+ cd ${ROOT}/usr/src/linux
+ cat ${ROOT}/usr/share/${P}/boot_splash_complete.2.4.19-vanilla.patch | patch -p1 || die
+ ewarn
+ ewarn " ... complete."
+ einfo
+ einfo "Your kernel has been patched, rebuild with the following options"
+ einfo "enabled (do not build them as modules!):"
+ einfo " Block Devices ->"
+ einfo " [*] RAM disk support"
+ einfo " [*] Loopback device support"
+ einfo " [*] Initial RAM disk (initrd) support"
+ einfo
+ einfo " Console Drivers ->"
+ einfo " [*] Video mode selection support"
+ einfo " Frame-buffer support ->"
+ einfo " [*] Support for frame buffer devices"
+ einfo " [*] VESA VGA graphics console"
+ einfo " [*] Use splash screen instead of boot logo"
+ einfo
+ einfo "Copy /usr/share/${P}/initrd to /boot"
+ einfo
+ einfo "Look at \"/usr/share/${P}/grub.conf.sample\" for an example"
+ einfo "grub.conf file with the appropriate changes to enable the"
+ einfo "framebuffer boot screens"
+ einfo
+ einfo "Ensure you make the appropriate changes to your grub.conf"
+ einfo
+}
+
diff --git a/media-gfx/bootsplash/files/digest-bootsplash-0.4 b/media-gfx/bootsplash/files/digest-bootsplash-0.4
new file mode 100644
index 000000000000..7316453465be
--- /dev/null
+++ b/media-gfx/bootsplash/files/digest-bootsplash-0.4
@@ -0,0 +1 @@
+MD5 a75a1f419418eacb90b23087ba88bcbe bootsplash-0.4.tar.bz2 374065