summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-09-05 08:35:28 +0000
committerJustin Lecher <jlec@gentoo.org>2011-09-05 08:35:28 +0000
commit9ba24ae7b2a23b90300842d9f48a13122c7776bb (patch)
tree364840aacb6f051cba48ac2f2eb6b7a0e880d558 /media-gfx
parentinitial commit of office-ext.eclass that will allow us to package {libre,open... (diff)
downloadgentoo-2-9ba24ae7b2a23b90300842d9f48a13122c7776bb.tar.gz
gentoo-2-9ba24ae7b2a23b90300842d9f48a13122c7776bb.tar.bz2
gentoo-2-9ba24ae7b2a23b90300842d9f48a13122c7776bb.zip
Non-maintainer Version Bump, #381765; thanks Christoph Brill for the patch
(Portage version: 2.2.0_alpha53/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/shotwell/ChangeLog8
-rw-r--r--media-gfx/shotwell/files/0.11.0-ldflags.patch25
-rw-r--r--media-gfx/shotwell/shotwell-0.11.0.ebuild67
3 files changed, 99 insertions, 1 deletions
diff --git a/media-gfx/shotwell/ChangeLog b/media-gfx/shotwell/ChangeLog
index 890c60471aef..6115e4d6c51a 100644
--- a/media-gfx/shotwell/ChangeLog
+++ b/media-gfx/shotwell/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/shotwell
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/ChangeLog,v 1.21 2011/07/09 21:39:58 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/ChangeLog,v 1.22 2011/09/05 08:35:28 jlec Exp $
+
+*shotwell-0.11.0 (05 Sep 2011)
+
+ 05 Sep 2011; Justin Lecher <jlec@gentoo.org> +files/0.11.0-ldflags.patch,
+ +shotwell-0.11.0.ebuild:
+ Non-maintainer Version Bump, #381765; thanks Christoph Brill for the patch
09 Jul 2011; Christoph Mende <angelos@gentoo.org> -shotwell-0.10.ebuild,
shotwell-0.10.1.ebuild, +files/shotwell-0.10.1-libraw-config.patch:
diff --git a/media-gfx/shotwell/files/0.11.0-ldflags.patch b/media-gfx/shotwell/files/0.11.0-ldflags.patch
new file mode 100644
index 000000000000..c10cd8b978dc
--- /dev/null
+++ b/media-gfx/shotwell/files/0.11.0-ldflags.patch
@@ -0,0 +1,25 @@
+ Makefile | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index a3c0122..34f074d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -676,7 +676,7 @@ $(EXPANDED_OBJ_FILES): %.o: %.c $(CONFIG_IN) Makefile
+ $(CC) -c $(VALA_CFLAGS) `$(LIBRAW_CONFIG) --cflags` $(CFLAGS) -o $@ $<
+
+ $(PROGRAM): $(EXPANDED_OBJ_FILES) $(RESOURCES) $(LANG_STAMP) $(THUMBNAILER_BIN)
+- $(CC) $(EXPANDED_OBJ_FILES) $(CFLAGS) $(RESOURCES) $(VALA_LDFLAGS) `$(LIBRAW_CONFIG) --libs` $(EXPORT_FLAGS) -o $@
++ $(CC) $(EXPANDED_OBJ_FILES) $(CFLAGS) $(LDFLAGS) $(RESOURCES) $(VALA_LDFLAGS) `$(LIBRAW_CONFIG) --libs` $(EXPORT_FLAGS) -o $@
+ glib-compile-schemas misc
+
+ $(THUMBNAILER_BIN): $(EXPANDED_THUMBNAILER_SRC_FILES)
+@@ -705,7 +705,7 @@ docs:
+ glade: lib$(PROGRAM).so
+
+ lib$(PROGRAM).so: $(EXPANDED_OBJ_FILES) $(RESOURCES) $(LANG_STAMP)
+- $(CC) $(EXPANDED_OBJ_FILES) $(CFLAGS) $(RESOURCES) $(VALA_LDFLAGS) `$(LIBRAW_CONFIG) --libs` $(EXPORT_FLAGS) -shared -o $@
++ $(CC) $(EXPANDED_OBJ_FILES) $(CFLAGS) $(LDFLAGS) $(RESOURCES) $(VALA_LDFLAGS) `$(LIBRAW_CONFIG) --libs` $(EXPORT_FLAGS) -shared -o $@
+
+ .PHONY: pkgcheck
+ pkgcheck:
diff --git a/media-gfx/shotwell/shotwell-0.11.0.ebuild b/media-gfx/shotwell/shotwell-0.11.0.ebuild
new file mode 100644
index 000000000000..20b2da98df96
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.11.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/shotwell-0.11.0.ebuild,v 1.1 2011/09/05 08:35:28 jlec Exp $
+
+EAPI=4
+GCONF_DEBUG="no"
+inherit gnome2 versionator eutils multilib toolchain-funcs
+
+MY_PV=$(get_version_component_range 1-2)
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="http://www.yorba.org/shotwell/"
+SRC_URI="http://www.yorba.org/download/${PN}/${MY_PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-db/sqlite-3.5.9:3
+ >=dev-libs/dbus-glib-0.80
+ >=dev-libs/json-glib-0.7.6
+ >=dev-libs/libgee-0.5.0
+ >=dev-libs/libunique-1:1
+ >=dev-libs/libxml2-2.6.32:2
+ >=gnome-base/gconf-2.22.0:2
+ >=media-libs/gexiv2-0.2.0
+ media-libs/gstreamer:0.10
+ media-libs/lcms:2
+ >=media-libs/libexif-0.6.16
+ >=media-libs/libgphoto2-2.4.2
+ >=media-libs/libraw-0.9.0
+ >=net-libs/libsoup-2.26.0:2.4
+ >=net-libs/webkit-gtk-1.1.5:2
+ || ( >=sys-fs/udev-171[gudev] >=sys-fs/udev-145[extras] )
+ >=x11-libs/gtk+-2.18.0:2"
+DEPEND="${RDEPEND}
+ >=dev-lang/vala-0.11.7:0.12"
+
+DOCS=( AUTHORS MAINTAINERS NEWS README THANKS )
+
+pkg_setup() {
+ tc-export CC
+ G2CONF="${G2CONF}
+ --disable-schemas-install
+ --disable-desktop-update
+ --disable-icon-update
+ --lib=$(get_libdir)"
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-ldflags.patch
+# \
+# "${FILESDIR}"/${P}-libraw-config.patch
+ gnome2_src_prepare
+
+ sed -e 's/valac/valac-0.12/' -i plugins/Makefile.plugin.mk || die
+ sed -e 's/valac/valac-0.12/' -i Makefile || die
+}
+
+src_install() {
+# # This is needed so that gnome2_gconf_savelist() works correctly.
+# insinto /etc/gconf/schemas
+# doins misc/shotwell.schemas || die "install gconf schema failed"
+ gnome2_src_install
+}