summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2004-09-06 13:24:03 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2004-09-06 13:24:03 +0000
commit942c26760116f4bf7198721c4cfe17f81169510a (patch)
tree3089b793a8fe4c7bdfd502ab9549d1625439a3a8 /media-gfx
parentrevbump 1.5.2 - clses bug #62142 (Manifest recommit) (diff)
downloadgentoo-2-942c26760116f4bf7198721c4cfe17f81169510a.tar.gz
gentoo-2-942c26760116f4bf7198721c4cfe17f81169510a.tar.bz2
gentoo-2-942c26760116f4bf7198721c4cfe17f81169510a.zip
Version bump. Closing bugs #62309 and #62229
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/imagemagick/ChangeLog8
-rw-r--r--media-gfx/imagemagick/files/digest-imagemagick-6.0.7.11
-rw-r--r--media-gfx/imagemagick/imagemagick-6.0.7.1.ebuild82
3 files changed, 90 insertions, 1 deletions
diff --git a/media-gfx/imagemagick/ChangeLog b/media-gfx/imagemagick/ChangeLog
index 024269cbe6d7..1032dd6344fa 100644
--- a/media-gfx/imagemagick/ChangeLog
+++ b/media-gfx/imagemagick/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/imagemagick
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/ChangeLog,v 1.67 2004/08/30 08:01:40 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/ChangeLog,v 1.68 2004/09/06 13:24:03 sekretarz Exp $
+
+*imagemagick-6.0.7.1 (06 Sep 2004)
+
+ 06 Sep 2004; Karol Wojtaszek <sekretarz@gentoo.org>
+ +imagemagick-6.0.7.1.ebuild:
+ Version bump. Closing bugs #62309 and #62229
30 Aug 2004; Karol Wojtaszek <sekretarz@gentoo.org>
imagemagick-6.0.5.2.ebuild:
diff --git a/media-gfx/imagemagick/files/digest-imagemagick-6.0.7.1 b/media-gfx/imagemagick/files/digest-imagemagick-6.0.7.1
new file mode 100644
index 000000000000..2eb6b05ce28e
--- /dev/null
+++ b/media-gfx/imagemagick/files/digest-imagemagick-6.0.7.1
@@ -0,0 +1 @@
+MD5 6c9f5bd9afa95b747480040abd456784 ImageMagick-6.0.7-1.tar.bz2 5752309
diff --git a/media-gfx/imagemagick/imagemagick-6.0.7.1.ebuild b/media-gfx/imagemagick/imagemagick-6.0.7.1.ebuild
new file mode 100644
index 000000000000..81441c833434
--- /dev/null
+++ b/media-gfx/imagemagick/imagemagick-6.0.7.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/imagemagick-6.0.7.1.ebuild,v 1.1 2004/09/06 13:24:03 sekretarz Exp $
+
+inherit libtool flag-o-matic eutils
+
+MY_PN=ImageMagick
+MY_P=${MY_PN}-${PV%.*}
+MY_P2=${MY_PN}-${PV%.*}-${PV#*.*.*.}
+
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A collection of tools and libraries for many image formats"
+HOMEPAGE="http://www.imagemagick.org/"
+SRC_URI="http://www.imagemagick.net/download/${MY_P2}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~mips ~ppc64"
+
+IUSE="X cups jpeg lcms mpeg png truetype tiff xml2 wmf jbig perl graphviz"
+
+DEPEND=">=sys-apps/sed-4
+ app-arch/bzip2
+ sys-libs/zlib
+ X? ( virtual/x11
+ >=app-text/dgs-0.5.9.1 )
+ cups? ( virtual/ghostscript )
+ jpeg? ( >=media-libs/jpeg-6b )
+ lcms? ( >=media-libs/lcms-1.06 )
+ mpeg? ( media-video/mpeg2vidcodec )
+ png? ( media-libs/libpng )
+ tiff? ( >=media-libs/tiff-3.5.5 )
+ xml2? ( >=dev-libs/libxml2-2.4.10 )
+ truetype? ( =media-libs/freetype-2* )
+ wmf? ( media-libs/libwmf )
+ jbig? ( media-libs/jbigkit )
+ perl? ( dev-lang/perl )
+ graphviz? ( media-gfx/graphviz )"
+
+src_compile() {
+
+ local myconf=""
+ use X || myconf="${myconf} --with-x=no"
+ use cups || myconf="${myconf} --with-gslib"
+ use jpeg || myconf="${myconf} --without-jpeg --without-jp2"
+ use lcms || myconf="${myconf} --without-lcms"
+ use mpeg || myconf="${myconf} --without-mpeg2"
+ use tiff || myconf="${myconf} --without-tiff"
+ use xml2 || myconf="${myconf} --without-xml"
+ use truetype || myconf="${myconf} --without-ttf"
+ use wmf || myconf="${myconf} --without-wmf"
+ use jbig || myconf="${myconf} --without-jbig"
+ use perl || myconf="${myconf} --without-perl"
+ use graphviz || myconf="${myconf} --without-dot"
+
+ # Netscape is still used ? More people should have Mozilla
+ sed -i 's:netscape:mozilla:g' configure
+
+ econf \
+ --enable-shared \
+ --enable-lzw \
+ --with-fpx \
+ --without-hdf \
+ --with-threads \
+ --with-bzlib \
+ --without-dot \
+ --with-modles \
+ ${myconf} || die
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ make DESTDIR=${D} install
+ mydoc="*.txt"
+
+ rm -f ${D}/usr/share/ImageMagick/*.txt
+
+ dosed "s:-I/usr/include ::" /usr/bin/Magick-config
+ dosed "s:-I/usr/include ::" /usr/bin/Magick++-config
+
+}