summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2006-07-15 13:01:02 +0000
committerMichael Januszewski <spock@gentoo.org>2006-07-15 13:01:02 +0000
commit813eb779ac1ba2c3f96300ea2074f64a8e828c81 (patch)
tree28140a4b6dc2c1deefce304932d4dc3bf8a4d810 /media-gfx/splashutils
parentPatch contained absolute path to /var/tmp/portage/blas-atlas-3.7.11 and there... (diff)
downloadgentoo-2-813eb779ac1ba2c3f96300ea2074f64a8e828c81.tar.gz
gentoo-2-813eb779ac1ba2c3f96300ea2074f64a8e828c81.tar.bz2
gentoo-2-813eb779ac1ba2c3f96300ea2074f64a8e828c81.zip
Added a fix for bug #140470.
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'media-gfx/splashutils')
-rw-r--r--media-gfx/splashutils/ChangeLog6
-rw-r--r--media-gfx/splashutils/files/splashutils-1.3-fdset.patch20
-rw-r--r--media-gfx/splashutils/splashutils-1.3-r1.ebuild4
3 files changed, 28 insertions, 2 deletions
diff --git a/media-gfx/splashutils/ChangeLog b/media-gfx/splashutils/ChangeLog
index 68da833feb3e..4c00d681d585 100644
--- a/media-gfx/splashutils/ChangeLog
+++ b/media-gfx/splashutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/splashutils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.59 2006/07/15 10:07:04 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.60 2006/07/15 13:01:02 spock Exp $
+
+ 15 Jul 2006; Michał Januszewski <spock@gentoo.org>
+ +files/splashutils-1.3-fdset.patch, splashutils-1.3-r1.ebuild:
+ Added a fix for bug #140470.
*splashutils-1.3-r1 (15 Jul 2006)
diff --git a/media-gfx/splashutils/files/splashutils-1.3-fdset.patch b/media-gfx/splashutils/files/splashutils-1.3-fdset.patch
new file mode 100644
index 000000000000..38d636521f63
--- /dev/null
+++ b/media-gfx/splashutils/files/splashutils-1.3-fdset.patch
@@ -0,0 +1,20 @@
+diff --git a/core/render.c b/core/render.c
+index 290ea97..47319a8 100644
+--- a/core/render.c
++++ b/core/render.c
+@@ -9,8 +9,15 @@
+ *
+ */
+
++/*
++ * HACK WARNING:
++ * This is necessary to get FD_SET and FD_ZERO on platforms other than x86.
++ */
++
+ #ifdef TARGET_KERNEL
++#define __KERNEL__
+ #include <linux/posix_types.h>
++#undef __KERNEL__
+ #endif
+
+ #include <stdio.h>
diff --git a/media-gfx/splashutils/splashutils-1.3-r1.ebuild b/media-gfx/splashutils/splashutils-1.3-r1.ebuild
index 69efbdce62dd..902ca0660cad 100644
--- a/media-gfx/splashutils/splashutils-1.3-r1.ebuild
+++ b/media-gfx/splashutils/splashutils-1.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.3-r1.ebuild,v 1.1 2006/07/15 10:07:04 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.3-r1.ebuild,v 1.2 2006/07/15 13:01:02 spock Exp $
inherit eutils multilib toolchain-funcs
@@ -64,6 +64,8 @@ src_unpack() {
rm ${S}/libs/zlib-${V_ZLIB}/Makefile
cd ${S}
+ epatch ${FILESDIR}/splashutils-1.3-fdset.patch
+
# Check whether the kernel tree has been patched with fbsplash.
if [[ ! -e ${ROOT}/usr/lib/klibc/include/linux/console_splash.h ]]; then
ewarn "The kernel tree against which dev-libs/klibc was built was not patched"