summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-26 00:33:21 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-26 00:33:21 +0000
commitbc3089eb63e630d1cad0c5c8add232c8e14c93d3 (patch)
tree77b6faa66f43b57aed0c8e03ee57c86afbf05446 /media-gfx/sodipodi
parentdont use old WANT_AUTOCONF #35111 (diff)
downloadgentoo-2-bc3089eb63e630d1cad0c5c8add232c8e14c93d3.tar.gz
gentoo-2-bc3089eb63e630d1cad0c5c8add232c8e14c93d3.tar.bz2
gentoo-2-bc3089eb63e630d1cad0c5c8add232c8e14c93d3.zip
dont use old WANT_AUTOCONF #35111
Diffstat (limited to 'media-gfx/sodipodi')
-rw-r--r--media-gfx/sodipodi/sodipodi-0.28.ebuild38
-rw-r--r--media-gfx/sodipodi/sodipodi-0.32.ebuild6
-rw-r--r--media-gfx/sodipodi/sodipodi-0.33.ebuild6
3 files changed, 19 insertions, 31 deletions
diff --git a/media-gfx/sodipodi/sodipodi-0.28.ebuild b/media-gfx/sodipodi/sodipodi-0.28.ebuild
index b865b048d018..9103c33a5348 100644
--- a/media-gfx/sodipodi/sodipodi-0.28.ebuild
+++ b/media-gfx/sodipodi/sodipodi-0.28.ebuild
@@ -1,13 +1,15 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sodipodi/sodipodi-0.28.ebuild,v 1.9 2003/09/11 01:18:39 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sodipodi/sodipodi-0.28.ebuild,v 1.10 2004/01/26 00:30:10 vapier Exp $
+
+inherit flag-o-matic
DESCRIPTION="Vector illustration application for GNOME"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="http://sodipodi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc"
IUSE="xml2 nls bonobo wmf"
@@ -24,34 +26,20 @@ src_unpack() {
unpack ${A}
cd ${S}
- export WANT_AUTOCONF_2_5=1
+ export WANT_AUTOCONF=2.5
autoconf --force
}
src_compile() {
- local myconf
-
- use bonobo \
- && myconf="${myconf} --with-bonobo" \
- || myconf="${myconf} --without-bonobo"
-
- use xml2 \
- && myconf="${myconf} --with-gnome-xml2" \
- || myconf="${myconf} --without-gnome-xml2"
-
- use wmf \
- && myconf="${myconf} --with-libwmf" \
- || myconf="${myconf} --without-libwmf"
-
- use nls || myconf="${myconf} --disable-nls"
-
- CFLAGS="${CFLAGS} `gnome-config --cflags gdk_pixbuf`"
-
+ append-flags `gnome-config --cflags gdk_pixbuf`
econf \
--enable-gnome \
--enable-gnome-print \
- ${myconf} || die
-
+ `use_with bonobo` \
+ `use_with xml2 gnome-xml2` \
+ `use_with wmf libwmf` \
+ `use_enable nls` \
+ || die
emake || die
}
diff --git a/media-gfx/sodipodi/sodipodi-0.32.ebuild b/media-gfx/sodipodi/sodipodi-0.32.ebuild
index 9f3565862492..1c8a3f8e4dc2 100644
--- a/media-gfx/sodipodi/sodipodi-0.32.ebuild
+++ b/media-gfx/sodipodi/sodipodi-0.32.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sodipodi/sodipodi-0.32.ebuild,v 1.3 2003/11/13 02:19:23 todd Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sodipodi/sodipodi-0.32.ebuild,v 1.4 2004/01/26 00:30:10 vapier Exp $
inherit gnome2
@@ -30,4 +30,4 @@ DEPEND="${RDEPEND}
G2CONF="${G2CONF} `use_enable mmx` `use_with gnome gnome-print`"
G2CONF="${G2CONF} --with-xft --with-popt"
-DOCS="AUTHORS COPYING ChangeLog HACKING NEWS README TODO"
+DOCS="AUTHORS ChangeLog HACKING NEWS README TODO"
diff --git a/media-gfx/sodipodi/sodipodi-0.33.ebuild b/media-gfx/sodipodi/sodipodi-0.33.ebuild
index 0b44bf0760a8..373915ec93b0 100644
--- a/media-gfx/sodipodi/sodipodi-0.33.ebuild
+++ b/media-gfx/sodipodi/sodipodi-0.33.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sodipodi/sodipodi-0.33.ebuild,v 1.2 2003/12/24 19:24:18 bazik Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sodipodi/sodipodi-0.33.ebuild,v 1.3 2004/01/26 00:30:10 vapier Exp $
inherit gnome2
@@ -34,4 +34,4 @@ G2CONF="${G2CONF} --with-xft --with-popt"
# disable experimental features for now
G2CONF="${G2CONF} --without-mlview --without-kde"
-DOCS="AUTHORS COPYING ChangeLog HACKING NEWS README TODO"
+DOCS="AUTHORS ChangeLog HACKING NEWS README TODO"