summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-09-18 07:07:12 +0000
committerChris White <chriswhite@gentoo.org>2005-09-18 07:07:12 +0000
commitf019b8c1cacbb5fd160e71780c1b474e0631abdf (patch)
tree90c2a521ed0ed7b79ee74771faabce7944ab91ce /media-gfx/skencil/skencil-0.6.17.ebuild
parentStable on ppc64 (bug #106279) (diff)
downloadgentoo-2-f019b8c1cacbb5fd160e71780c1b474e0631abdf.tar.gz
gentoo-2-f019b8c1cacbb5fd160e71780c1b474e0631abdf.tar.bz2
gentoo-2-f019b8c1cacbb5fd160e71780c1b474e0631abdf.zip
Version bump for bug #103217 by spyderous. This adds a USE flag support check, as well as making the nls DEPEND/RDEPEND Gentoo/BSD friendly for when they want to mark it.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'media-gfx/skencil/skencil-0.6.17.ebuild')
-rw-r--r--media-gfx/skencil/skencil-0.6.17.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-gfx/skencil/skencil-0.6.17.ebuild b/media-gfx/skencil/skencil-0.6.17.ebuild
new file mode 100644
index 000000000000..d04ca66443d7
--- /dev/null
+++ b/media-gfx/skencil/skencil-0.6.17.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/skencil/skencil-0.6.17.ebuild,v 1.1 2005/09/18 07:07:12 chriswhite Exp $
+
+inherit python
+
+IUSE="nls"
+S=${WORKDIR}/${P/_/}
+DESCRIPTION="Interactive X11 vector drawing program"
+SRC_URI="mirror://sourceforge/sketch/${P}.tar.gz"
+HOMEPAGE="http://www.skencil.org/"
+DEPEND=">=dev-python/imaging-1.1.2-r1
+ dev-python/reportlab
+ dev-lang/tk
+ nls? ( sys-devel/gettext )"
+RDEPEND="!elibc_glibc? ( nls? ( sys-devel/gettext ) )"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+pkg_setup() {
+ python_tkinter_exists
+}
+
+src_compile() {
+ use nls && useopts="${useopts} --with-nls"
+ ./setup.py configure ${useopts} || die "setup.py configure failed"
+ ./setup.py build || die "setup.py build failed"
+}
+
+src_install () {
+ ./setup.py install --prefix=/usr --dest-dir=${D}
+ assert "setup.py install failed"
+
+ newdoc Pax/README README.pax
+ newdoc Filter/README README.filter
+ dodoc Examples Doc Misc
+ dodoc README INSTALL BUGS CREDITS TODO PROJECTS FAQ NEWS
+}