summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-04-23 18:53:08 +0000
committerSamuli Suominen <drac@gentoo.org>2008-04-23 18:53:08 +0000
commite1c9fe18d08bc4e523b2381ec10475025c05a655 (patch)
treea6926450ca4867f21996fe130a5d4be9d44f6be2 /media-gfx/pngtools
parentFix typo (diff)
downloadgentoo-2-e1c9fe18d08bc4e523b2381ec10475025c05a655.tar.gz
gentoo-2-e1c9fe18d08bc4e523b2381ec10475025c05a655.tar.bz2
gentoo-2-e1c9fe18d08bc4e523b2381ec10475025c05a655.zip
Keyword ~amd64. Fix implicit declarations; math.h, string.h, stdlib.h. Use toolchain-funcs to export CC.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'media-gfx/pngtools')
-rw-r--r--media-gfx/pngtools/ChangeLog9
-rw-r--r--media-gfx/pngtools/files/pngtools-0.3-implicit-declarations.patch40
-rw-r--r--media-gfx/pngtools/pngtools-0.3.ebuild33
3 files changed, 72 insertions, 10 deletions
diff --git a/media-gfx/pngtools/ChangeLog b/media-gfx/pngtools/ChangeLog
index 2b94262cbd16..4301e36344c4 100644
--- a/media-gfx/pngtools/ChangeLog
+++ b/media-gfx/pngtools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/pngtools
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngtools/ChangeLog,v 1.2 2006/06/05 22:23:17 robbat2 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngtools/ChangeLog,v 1.3 2008/04/23 18:53:07 drac Exp $
+
+ 23 Apr 2008; Samuli Suominen <drac@gentoo.org>
+ +files/pngtools-0.3-implicit-declarations.patch, pngtools-0.3.ebuild:
+ Keyword ~amd64. Fix implicit declarations; math.h, string.h, stdlib.h. Use
+ toolchain-funcs to export CC.
05 Jun 2006; Robin H. Johnson <robbat2@gentoo.org> metadata.xml,
pngtools-0.3.ebuild:
diff --git a/media-gfx/pngtools/files/pngtools-0.3-implicit-declarations.patch b/media-gfx/pngtools/files/pngtools-0.3-implicit-declarations.patch
new file mode 100644
index 000000000000..682bcc8c29d3
--- /dev/null
+++ b/media-gfx/pngtools/files/pngtools-0.3-implicit-declarations.patch
@@ -0,0 +1,40 @@
+diff -ur pngtools.orig/inflateraster.c pngtools/inflateraster.c
+--- pngtools.orig/inflateraster.c 2005-04-08 04:23:34.000000000 +0300
++++ pngtools/inflateraster.c 2008-04-23 20:38:05.000000000 +0300
+@@ -1,5 +1,6 @@
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <math.h>
+
+ // Inflate a raster to a given pixel sample size
+ char *inflateraster(char *input, unsigned long width, unsigned long height,
+diff -ur pngtools.orig/pngchunkdesc.c pngtools/pngchunkdesc.c
+--- pngtools.orig/pngchunkdesc.c 2005-04-08 04:23:34.000000000 +0300
++++ pngtools/pngchunkdesc.c 2008-04-23 20:44:38.000000000 +0300
+@@ -20,6 +20,7 @@
+ ******************************************************************************/
+
+ #include <stdio.h>
++#include <string.h>
+
+ char *meanings[4][2] = {
+ {"Critical", "Ancillary"},
+diff -ur pngtools.orig/pngchunks.c pngtools/pngchunks.c
+--- pngtools.orig/pngchunks.c 2005-04-08 04:23:35.000000000 +0300
++++ pngtools/pngchunks.c 2008-04-23 20:38:29.000000000 +0300
+@@ -1,6 +1,7 @@
+ // List the chunks which appear in a given PNG image
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <unistd.h>
+ #include <sys/mman.h>
+ #include <sys/types.h>
+diff -ur pngtools.orig/pngcp.c pngtools/pngcp.c
+--- pngtools.orig/pngcp.c 2005-04-08 04:23:35.000000000 +0300
++++ pngtools/pngcp.c 2008-04-23 20:38:13.000000000 +0300
+@@ -1,3 +1,4 @@
++#include <stdlib.h>
+ #include <unistd.h>
+ #include <stdio.h>
+ #include <math.h>
diff --git a/media-gfx/pngtools/pngtools-0.3.ebuild b/media-gfx/pngtools/pngtools-0.3.ebuild
index 284354471aae..b2f6c5dcd7ab 100644
--- a/media-gfx/pngtools/pngtools-0.3.ebuild
+++ b/media-gfx/pngtools/pngtools-0.3.ebuild
@@ -1,23 +1,40 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngtools/pngtools-0.3.ebuild,v 1.3 2007/07/12 04:08:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngtools/pngtools-0.3.ebuild,v 1.4 2008/04/23 18:53:07 drac Exp $
-MY_PV="${PV/./_}"
+inherit eutils toolchain-funcs
+
+MY_PV=${PV/./_}
DESCRIPTION="A series of tools for the PNG image format"
-HOMEPAGE="http://www.stillhq.com/pngtools/"
+HOMEPAGE="http://www.stillhq.com/pngtools"
SRC_URI="http://www.stillhq.com/pngtools/source/pngtools_${MY_PV}.tgz"
-S="${WORKDIR}/${PN}"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
DEPEND=">=media-libs/libpng-1.2.8-r1
virtual/libc"
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-implicit-declarations.patch
+}
+
+src_compile() {
+ tc-export CC
+ econf
+ emake || die "emake failed."
+}
+
src_install() {
- emake -j1 install DESTDIR="${D}" || die "emake install failed"
- dodoc ABOUT AUTHORS ChangeLog NEWS README chunks.txt *.png
+ emake -j1 install DESTDIR="${D}" || die "emake install failed."
+ dodoc ABOUT AUTHORS ChangeLog NEWS README chunks.txt
+ insinto /usr/share/doc/${PF}/examples
+ doins *.png
}