summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2005-08-08 14:56:56 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2005-08-08 14:56:56 +0000
commit306cdc0de34d447b0441c60596a97f4ac239fb17 (patch)
tree3230180176a3b6d617d5075889113893b855408d /media-gfx/opendx-samples
parentStable on ppc64 (diff)
downloadgentoo-2-306cdc0de34d447b0441c60596a97f4ac239fb17.tar.gz
gentoo-2-306cdc0de34d447b0441c60596a97f4ac239fb17.tar.bz2
gentoo-2-306cdc0de34d447b0441c60596a97f4ac239fb17.zip
See bug #54047
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-gfx/opendx-samples')
-rw-r--r--media-gfx/opendx-samples/ChangeLog10
-rw-r--r--media-gfx/opendx-samples/Manifest4
-rw-r--r--media-gfx/opendx-samples/files/digest-opendx-samples-4.3.21
-rw-r--r--media-gfx/opendx-samples/metadata.xml5
-rw-r--r--media-gfx/opendx-samples/opendx-samples-4.3.2.ebuild45
5 files changed, 65 insertions, 0 deletions
diff --git a/media-gfx/opendx-samples/ChangeLog b/media-gfx/opendx-samples/ChangeLog
new file mode 100644
index 000000000000..10dcaee70be3
--- /dev/null
+++ b/media-gfx/opendx-samples/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-gfx/opendx-samples
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/opendx-samples/ChangeLog,v 1.1 2005/08/08 14:56:56 phosphan Exp $
+
+*opendx-samples-4.3.2 (08 Aug 2005)
+
+ 08 Aug 2005; Patrick Kursawe <phosphan@gentoo.org>
+ +opendx-samples-4.3.2.ebuild:
+ Initial import, mainly provided in bug #22217 and demanded again in #54047.
+
diff --git a/media-gfx/opendx-samples/Manifest b/media-gfx/opendx-samples/Manifest
new file mode 100644
index 000000000000..acc3ba3410a1
--- /dev/null
+++ b/media-gfx/opendx-samples/Manifest
@@ -0,0 +1,4 @@
+MD5 1aef4ee079071b45c6d510562cf85eb1 opendx-samples-4.3.2.ebuild 1081
+MD5 17040b844455b83c9bd118c62ffc80a9 ChangeLog 326
+MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 79e9088507c29d4854546506167d851c files/digest-opendx-samples-4.3.2 68
diff --git a/media-gfx/opendx-samples/files/digest-opendx-samples-4.3.2 b/media-gfx/opendx-samples/files/digest-opendx-samples-4.3.2
new file mode 100644
index 000000000000..a5249e9df622
--- /dev/null
+++ b/media-gfx/opendx-samples/files/digest-opendx-samples-4.3.2
@@ -0,0 +1 @@
+MD5 940eece74fc2bf001a8017f9df18daac dxsamples-4.3.2.tar.gz 7708621
diff --git a/media-gfx/opendx-samples/metadata.xml b/media-gfx/opendx-samples/metadata.xml
new file mode 100644
index 000000000000..b229aec85b8f
--- /dev/null
+++ b/media-gfx/opendx-samples/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+</pkgmetadata>
diff --git a/media-gfx/opendx-samples/opendx-samples-4.3.2.ebuild b/media-gfx/opendx-samples/opendx-samples-4.3.2.ebuild
new file mode 100644
index 000000000000..2fafff508d8d
--- /dev/null
+++ b/media-gfx/opendx-samples/opendx-samples-4.3.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/opendx-samples/opendx-samples-4.3.2.ebuild,v 1.1 2005/08/08 14:56:56 phosphan Exp $
+
+S="${WORKDIR}/dxsamples-${PV}"
+
+DESCRIPTION="Samples for IBM Data Explorer"
+HOMEPAGE="http://www.opendx.org/"
+SRC_URI="http://opendx.npaci.edu/source/dxsamples-${PV}.tar.gz"
+LICENSE="IPL-1"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="=media-gfx/opendx-${PV}*"
+
+# this einstall do not define datadir, because
+# it will cause problems since datadir is redefined
+# across Makefiles
+my_einstall() {
+ if [ -f ./[mM]akefile -o -f ./GNUmakefile ] ; then
+ if [ ! -z "${PORTAGE_DEBUG}" ]; then
+ make -n prefix=${D}/usr \
+ infodir=${D}/usr/share/info \
+ localstatedir=${D}/var/lib \
+ mandir=${D}/usr/share/man \
+ sysconfdir=${D}/etc \
+ "$@" install
+ fi
+ make prefix=${D}/usr \
+ infodir=${D}/usr/share/info \
+ localstatedir=${D}/var/lib \
+ mandir=${D}/usr/share/man \
+ sysconfdir=${D}/etc \
+ "$@" install || die "einstall failed"
+ else
+ die "no Makefile found"
+ fi
+}
+
+src_install() {
+ my_einstall || die
+}
+