summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-05-24 22:55:44 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-05-24 22:55:44 +0000
commitc263314388ad9fa96ac7285e5db419cb006fb325 (patch)
tree3ab39df37dcdd6ddda856eb77f01551ec6832754 /media-gfx/gnuplot
parentbump version (diff)
downloadgentoo-2-c263314388ad9fa96ac7285e5db419cb006fb325.tar.gz
gentoo-2-c263314388ad9fa96ac7285e5db419cb006fb325.tar.bz2
gentoo-2-c263314388ad9fa96ac7285e5db419cb006fb325.zip
(#86008) Add pdflib-6-compat.patch to fix compilation against >=pdflib-6. PDF_open_fp suddenly disappeared, so switch to PDF_open_file.
Diffstat (limited to 'media-gfx/gnuplot')
-rw-r--r--media-gfx/gnuplot/ChangeLog7
-rw-r--r--media-gfx/gnuplot/files/pdflib-6-compat.patch14
-rw-r--r--media-gfx/gnuplot/gnuplot-4.0-r1.ebuild3
3 files changed, 22 insertions, 2 deletions
diff --git a/media-gfx/gnuplot/ChangeLog b/media-gfx/gnuplot/ChangeLog
index 5004fc2bd9ff..b61434147675 100644
--- a/media-gfx/gnuplot/ChangeLog
+++ b/media-gfx/gnuplot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/gnuplot
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/ChangeLog,v 1.42 2005/03/30 16:29:30 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/ChangeLog,v 1.43 2005/05/24 22:55:44 spyderous Exp $
+
+ 24 May 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +files/pdflib-6-compat.patch, gnuplot-4.0-r1.ebuild:
+ (#86008) Add pdflib-6-compat.patch to fix compilation against >=pdflib-6.
+ PDF_open_fp suddenly disappeared, so switch to PDF_open_file.
30 Mar 2005; Michael Hanselmann <hansmi@gentoo.org> gnuplot-4.0-r1.ebuild:
Stable on ppc.
diff --git a/media-gfx/gnuplot/files/pdflib-6-compat.patch b/media-gfx/gnuplot/files/pdflib-6-compat.patch
new file mode 100644
index 000000000000..3a25292d93d6
--- /dev/null
+++ b/media-gfx/gnuplot/files/pdflib-6-compat.patch
@@ -0,0 +1,14 @@
+diff -urN gnuplot-4.0.0.orig/term/pdf.trm gnuplot-4.0.0/term/pdf.trm
+--- gnuplot-4.0.0.orig/term/pdf.trm 2004-04-10 08:55:17.000000000 -0700
++++ gnuplot-4.0.0/term/pdf.trm 2005-05-24 15:33:52.000000000 -0700
+@@ -343,7 +343,9 @@
+ myPDF = PDF_new();
+
+ /*open new PDF file */
+- if (PDF_open_fp(myPDF, gpoutfile) == -1)
++ /* HBB FIXME 20040708: PDF_open_file is deprecated, will have to
++ * be re-done again soon. */
++ if (PDF_open_file(myPDF, outstr) == -1)
+ int_error(NO_CARET, "Error:cannot open PDF file .\n");
+
+ #ifdef PDF_DONT_COMPRESS
diff --git a/media-gfx/gnuplot/gnuplot-4.0-r1.ebuild b/media-gfx/gnuplot/gnuplot-4.0-r1.ebuild
index e138a53ba7c6..c4f1978a05d7 100644
--- a/media-gfx/gnuplot/gnuplot-4.0-r1.ebuild
+++ b/media-gfx/gnuplot/gnuplot-4.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/gnuplot-4.0-r1.ebuild,v 1.14 2005/03/30 16:29:30 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/gnuplot-4.0-r1.ebuild,v 1.15 2005/05/24 22:55:44 spyderous Exp $
inherit eutils elisp-common
@@ -36,6 +36,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/header-order.patch
+ epatch ${FILESDIR}/pdflib-6-compat.patch
}
src_compile() {