summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-10-09 11:11:56 +0000
committerPeter Volkov <pva@gentoo.org>2009-10-09 11:11:56 +0000
commit6cb038b2511e9369a409e29c2ae1088de65c2187 (patch)
tree6d0c862e7182834f68c9d9136aa3baa07d7c45dc /media-gfx/fondu
parent[profiles] Drop KDE 4.3.2 masks (diff)
downloadgentoo-2-6cb038b2511e9369a409e29c2ae1088de65c2187.tar.gz
gentoo-2-6cb038b2511e9369a409e29c2ae1088de65c2187.tar.bz2
gentoo-2-6cb038b2511e9369a409e29c2ae1088de65c2187.zip
Version bump. Respect CFLAGS, LDFLAGS, bug #240796, thank Diego E. 'Flameeyes' Pettenò for report. ~amd64 keyworded.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/fondu')
-rw-r--r--media-gfx/fondu/ChangeLog11
-rw-r--r--media-gfx/fondu/files/fondu-20060102-build-fix.patch70
-rw-r--r--media-gfx/fondu/fondu-20060102.ebuild33
3 files changed, 112 insertions, 2 deletions
diff --git a/media-gfx/fondu/ChangeLog b/media-gfx/fondu/ChangeLog
index 7dcf855769df..ca90283b67de 100644
--- a/media-gfx/fondu/ChangeLog
+++ b/media-gfx/fondu/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/fondu
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/fondu/ChangeLog,v 1.5 2007/02/09 07:50:19 flameeyes Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/fondu/ChangeLog,v 1.6 2009/10/09 11:11:55 pva Exp $
+
+*fondu-20060102 (09 Oct 2009)
+
+ 09 Oct 2009; Peter Volkov <pva@gentoo.org> +fondu-20060102.ebuild,
+ +files/fondu-20060102-build-fix.patch:
+ Version bump. Respect CFLAGS, LDFLAGS, bug #240796, thank Diego E.
+ 'Flameeyes' Pettenò for report. ~amd64 keyworded.
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/media-gfx/fondu/files/fondu-20060102-build-fix.patch b/media-gfx/fondu/files/fondu-20060102-build-fix.patch
new file mode 100644
index 000000000000..d84d0b7bde4e
--- /dev/null
+++ b/media-gfx/fondu/files/fondu-20060102-build-fix.patch
@@ -0,0 +1,70 @@
+Fixes:
+x86_64-pc-linux-gnu-gcc -O2 -c -o fondu.o fondu.c
+fondu.c: In function 'BuildFondList':
+fondu.c:515: error: called object 'strlen' is not a function
+
+x86_64-pc-linux-gnu-gcc -O2 -c -o frommacbinary.o frommacbinary.c
+frommacbinary.c: In function 'Usage':
+frommacbinary.c:58: warning: too few arguments for format
+
+Upstream: https://sourceforge.net/tracker/?func=detail&aid=2875547&group_id=39411&atid=425133
+Author: Peter Volkov <pva@gentoo.org>
+
+=== modified file 'fondu.c'
+--- fondu.c 2009-10-09 07:24:15 +0000
++++ fondu.c 2009-10-09 07:25:49 +0000
+@@ -473,7 +473,7 @@
+ }
+ if ( styleoff!=0 ) {
+ unsigned char stringoffsets[48];
+- int strcnt, strlen, format;
++ int strcnt, strlength, format;
+ char **strings, *pt;
+ fseek(f,styleoff,SEEK_SET);
+ /* class = */ getushort(f);
+@@ -484,11 +484,11 @@
+ strcnt = getushort(f);
+ strings = malloc(strcnt*sizeof(char *));
+ for ( j=0; j<strcnt; ++j ) {
+- strlen = getc(f);
+- strings[j] = malloc(strlen+2);
+- strings[j][0] = strlen;
+- strings[j][strlen+1] = '\0';
+- for ( k=0; k<strlen; ++k )
++ strlength = getc(f);
++ strings[j] = malloc(strlength+2);
++ strings[j][0] = strlength;
++ strings[j][strlength+1] = '\0';
++ for ( k=0; k<strlength; ++k )
+ strings[j][k+1] = getc(f);
+ }
+ for ( j=0; j<48; ++j ) {
+@@ -498,11 +498,11 @@
+ if ( k!=-1 || stringoffsets[j]==0 )
+ continue; /* this style doesn't exist */
+ format = stringoffsets[j]-1;
+- strlen = strings[0][0];
++ strlength = strings[0][0];
+ if ( format!=0 && format!=-1 )
+ for ( k=0; k<strings[format][0]; ++k )
+- strlen += strings[ strings[format][k+1]-1 ][0];
+- pt = cur->psnames[j] = malloc(strlen+1);
++ strlength += strings[ strings[format][k+1]-1 ][0];
++ pt = cur->psnames[j] = malloc(strlength+1);
+ strcpy(pt,strings[ 0 ]+1);
+ pt += strings[ 0 ][0];
+ if ( format!=0 && format!=-1 )
+
+=== modified file 'frommacbinary.c'
+--- frommacbinary.c 2009-10-09 07:24:15 +0000
++++ frommacbinary.c 2009-10-09 07:27:54 +0000
+@@ -55,7 +55,7 @@
+ /* frombin filenames */
+
+ static void Usage(char *prog) {
+- fprintf( stderr, "Usage: %s [-usage] [-help] [-version] filenames\n" );
++ fprintf( stderr, "Usage: frombin [-usage] [-help] [-version] filenames\n" );
+ fprintf( stderr, " -usage\t\tPrints this message\n" );
+ fprintf( stderr, " -help\t\tPrints this message\n" );
+ fprintf( stderr, " -version\t\tPrints the version of the program\n" );
+
diff --git a/media-gfx/fondu/fondu-20060102.ebuild b/media-gfx/fondu/fondu-20060102.ebuild
new file mode 100644
index 000000000000..aa8f36e20551
--- /dev/null
+++ b/media-gfx/fondu/fondu-20060102.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/fondu/fondu-20060102.ebuild,v 1.1 2009/10/09 11:11:55 pva Exp $
+
+EAPI="2"
+
+inherit eutils
+
+MY_PV=${PV:2:6}
+
+DESCRIPTION="Utilities for converting between and manipulating mac fonts and unix fonts"
+HOMEPAGE="http://fondu.sourceforge.net/"
+SRC_URI="http://fondu.sourceforge.net/${PN}_src-${MY_PV}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_prepare() {
+ sed -e 's:^CFLAGS =:CFLAGS +=:' \
+ -e 's:$(CFLAGS) -o:$(CFLAGS) $(LDFLAGS) -o:' \
+ -i Makefile.in || die "failed to sed"
+ epatch "${FILESDIR}/${P}-build-fix.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ doman *.1
+ dodoc README
+}