summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-02-15 02:25:35 +0000
committerTim Harder <radhermit@gentoo.org>2013-02-15 02:25:35 +0000
commitfa725780490ec2094ada22b8851531b725295e53 (patch)
treee3e9769acdbd885f67a0dbc55d316dcd555fcd11 /media-gfx/feh
parentBeta channel bump. (diff)
downloadgentoo-2-fa725780490ec2094ada22b8851531b725295e53.tar.gz
gentoo-2-fa725780490ec2094ada22b8851531b725295e53.tar.bz2
gentoo-2-fa725780490ec2094ada22b8851531b725295e53.zip
Version bump.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-gfx/feh')
-rw-r--r--media-gfx/feh/ChangeLog7
-rw-r--r--media-gfx/feh/feh-2.9.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/media-gfx/feh/ChangeLog b/media-gfx/feh/ChangeLog
index 18a1036c8c16..a5d149a9e3dc 100644
--- a/media-gfx/feh/ChangeLog
+++ b/media-gfx/feh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/feh
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/feh/ChangeLog,v 1.122 2013/02/14 22:04:53 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/feh/ChangeLog,v 1.123 2013/02/15 02:25:35 radhermit Exp $
+
+*feh-2.9 (15 Feb 2013)
+
+ 15 Feb 2013; Tim Harder <radhermit@gentoo.org> +feh-2.9.ebuild:
+ Version bump.
14 Feb 2013; Agostino Sarubbo <ago@gentoo.org> feh-2.8.ebuild:
Stable for ppc, wrt bug #457366
diff --git a/media-gfx/feh/feh-2.9.ebuild b/media-gfx/feh/feh-2.9.ebuild
new file mode 100644
index 000000000000..b6f762d47526
--- /dev/null
+++ b/media-gfx/feh/feh-2.9.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/feh/feh-2.9.ebuild,v 1.1 2013/02/15 02:25:35 radhermit Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A fast, lightweight imageviewer using imlib2"
+HOMEPAGE="http://feh.finalrewind.org/"
+SRC_URI="http://feh.finalrewind.org/${P}.tar.bz2"
+
+LICENSE="feh"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="debug curl exif test xinerama"
+
+COMMON_DEPEND=">=media-libs/giblib-1.2.4
+ media-libs/imlib2
+ >=media-libs/libpng-1.2:0
+ x11-libs/libX11
+ curl? ( net-misc/curl )
+ exif? ( media-libs/libexif )
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/jpeg"
+DEPEND="${COMMON_DEPEND}
+ x11-libs/libXt
+ x11-proto/xproto
+ test? (
+ >=dev-lang/perl-5.10
+ dev-perl/Test-Command
+ )"
+
+pkg_setup() {
+ use_feh() { usex $1 1 0; }
+
+ fehopts=(
+ DESTDIR="${D}"
+ PREFIX=/usr
+ doc_dir='${main_dir}'/share/doc/${PF}
+ example_dir='${main_dir}'/share/doc/${PF}/examples
+ curl=$(use_feh curl)
+ debug=$(use_feh debug)
+ xinerama=$(use_feh xinerama)
+ exif=$(use_feh exif)
+ )
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.6.2-debug-cflags.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake "${fehopts[@]}"
+}
+
+src_install() {
+ emake "${fehopts[@]}" install
+}