summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-08 22:28:14 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-08 22:28:14 +0000
commit8cf06bed5c67e9fb63ab54421d6eb128cb27ffde (patch)
tree52ce2cd86ddf6e956807b9ab75d65eb02ba11dcc /media-gfx/enblend
parentFixed cyclic dependency with app-text/poppler[utils]: (diff)
downloadgentoo-2-8cf06bed5c67e9fb63ab54421d6eb128cb27ffde.tar.gz
gentoo-2-8cf06bed5c67e9fb63ab54421d6eb128cb27ffde.tar.bz2
gentoo-2-8cf06bed5c67e9fb63ab54421d6eb128cb27ffde.zip
Fix building with libpng14.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/enblend')
-rw-r--r--media-gfx/enblend/ChangeLog8
-rw-r--r--media-gfx/enblend/enblend-4.0.ebuild8
-rw-r--r--media-gfx/enblend/files/enblend-4.0-libpng14.patch13
3 files changed, 25 insertions, 4 deletions
diff --git a/media-gfx/enblend/ChangeLog b/media-gfx/enblend/ChangeLog
index f27d78ccb3af..6c4c227d6e2f 100644
--- a/media-gfx/enblend/ChangeLog
+++ b/media-gfx/enblend/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/enblend
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/enblend/ChangeLog,v 1.36 2009/12/18 11:35:10 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/enblend/ChangeLog,v 1.37 2010/03/08 22:28:13 ssuominen Exp $
+
+ 08 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> enblend-4.0.ebuild,
+ +files/enblend-4.0-libpng14.patch:
+ Fix building with libpng14.
*enblend-4.0 (18 Dec 2009)
diff --git a/media-gfx/enblend/enblend-4.0.ebuild b/media-gfx/enblend/enblend-4.0.ebuild
index 81ab867e56f0..a061e7387e45 100644
--- a/media-gfx/enblend/enblend-4.0.ebuild
+++ b/media-gfx/enblend/enblend-4.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/enblend/enblend-4.0.ebuild,v 1.1 2009/12/18 11:35:10 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/enblend/enblend-4.0.ebuild,v 1.2 2010/03/08 22:28:13 ssuominen Exp $
EAPI=2
@@ -42,6 +42,10 @@ pkg_setup() {
fi
}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng14.patch
+}
+
src_configure() {
local myconf=""
if use image-cache && use openmp; then
diff --git a/media-gfx/enblend/files/enblend-4.0-libpng14.patch b/media-gfx/enblend/files/enblend-4.0-libpng14.patch
new file mode 100644
index 000000000000..2fe3846f0aaa
--- /dev/null
+++ b/media-gfx/enblend/files/enblend-4.0-libpng14.patch
@@ -0,0 +1,13 @@
+--- src/vigra_impex/png.cxx
++++ src/vigra_impex/png.cxx
+@@ -274,8 +274,8 @@
+ // expand gray values to at least one byte size
+ if ( color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8 ) {
+ if (setjmp(png->jmpbuf))
+- vigra_postcondition( false,png_error_message.insert(0, "error in png_set_gray_1_2_4_to_8(): ").c_str());
+- png_set_gray_1_2_4_to_8(png);
++ vigra_postcondition( false,png_error_message.insert(0, "error in png_set_expand_gray_1_2_4_to_8(): ").c_str());
++ png_set_expand_gray_1_2_4_to_8(png);
+ bit_depth = 8;
+ }
+