summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2013-05-18 14:15:33 +0000
committerJason A. Donenfeld <zx2c4@gentoo.org>2013-05-18 14:15:33 +0000
commit3eb007fbc93a7723532bc1e5f5ff4e6f9510603a (patch)
tree47432801c269633be740ac9bbbc1cd69a0c2b364 /mail-mta
parentPlace blockers in proper place (diff)
downloadgentoo-2-3eb007fbc93a7723532bc1e5f5ff4e6f9510603a.tar.gz
gentoo-2-3eb007fbc93a7723532bc1e5f5ff4e6f9510603a.tar.bz2
gentoo-2-3eb007fbc93a7723532bc1e5f5ff4e6f9510603a.zip
Basic QA on source folder.
(Portage version: 2.2.0_alpha175/cvs/Linux x86_64, signed Manifest commit with key A5DE03AE)
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/opensmtpd/ChangeLog6
-rw-r--r--mail-mta/opensmtpd/opensmtpd-5.3.1.201305171950_p1.ebuild13
-rw-r--r--mail-mta/opensmtpd/opensmtpd-5.3.1_p1.ebuild13
3 files changed, 21 insertions, 11 deletions
diff --git a/mail-mta/opensmtpd/ChangeLog b/mail-mta/opensmtpd/ChangeLog
index 2074e032d4fa..6f23c8e4fa89 100644
--- a/mail-mta/opensmtpd/ChangeLog
+++ b/mail-mta/opensmtpd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-mta/opensmtpd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/ChangeLog,v 1.8 2013/05/18 14:07:11 zx2c4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/ChangeLog,v 1.9 2013/05/18 14:15:33 zx2c4 Exp $
+
+ 18 May 2013; Jason A. Donenfeld <zx2c4@gentoo.org>
+ opensmtpd-5.3.1.201305171950_p1.ebuild, opensmtpd-5.3.1_p1.ebuild:
+ Basic QA on source folder.
*opensmtpd-5.3.1.201305171950_p1 (18 May 2013)
diff --git a/mail-mta/opensmtpd/opensmtpd-5.3.1.201305171950_p1.ebuild b/mail-mta/opensmtpd/opensmtpd-5.3.1.201305171950_p1.ebuild
index cb718ad8a1c7..8eac0284412a 100644
--- a/mail-mta/opensmtpd/opensmtpd-5.3.1.201305171950_p1.ebuild
+++ b/mail-mta/opensmtpd/opensmtpd-5.3.1.201305171950_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/opensmtpd-5.3.1.201305171950_p1.ebuild,v 1.1 2013/05/18 14:07:11 zx2c4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/opensmtpd-5.3.1.201305171950_p1.ebuild,v 1.2 2013/05/18 14:15:33 zx2c4 Exp $
EAPI=5
@@ -8,9 +8,12 @@ inherit multilib user flag-o-matic eutils pam toolchain-funcs autotools versiona
DESCRIPTION="Lightweight but featured SMTP daemon from OpenBSD"
HOMEPAGE="http://www.opensmtpd.org/"
-MY_P="${P}"
-[ $(get_last_version_component_index) -eq 4 ] && MY_P="${PN}-$(get_version_component_range 4-)"
-SRC_URI="http://www.opensmtpd.org/archives/${MY_P/_}.tar.gz"
+MY_DP="${P}"
+if [ $(get_last_version_component_index) -eq 4 ]; then
+ MY_DP="${PN}-$(get_version_component_range 4-)"
+ MY_P="${PN}-${PV/.$(get_version_component_range 4)}"
+fi
+SRC_URI="http://www.opensmtpd.org/archives/${MY_DP/_}.tar.gz"
LICENSE="ISC BSD BSD-1 BSD-2 BSD-4"
SLOT="0"
@@ -37,7 +40,7 @@ DEPEND="dev-libs/openssl
"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${P/_}
+S=${WORKDIR}/${MY_P/_}
src_prepare() {
epatch "${FILESDIR}"/build-warnings.patch
diff --git a/mail-mta/opensmtpd/opensmtpd-5.3.1_p1.ebuild b/mail-mta/opensmtpd/opensmtpd-5.3.1_p1.ebuild
index 3287cdf50f56..4cd050cb0bcb 100644
--- a/mail-mta/opensmtpd/opensmtpd-5.3.1_p1.ebuild
+++ b/mail-mta/opensmtpd/opensmtpd-5.3.1_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/opensmtpd-5.3.1_p1.ebuild,v 1.2 2013/05/18 14:07:11 zx2c4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/opensmtpd-5.3.1_p1.ebuild,v 1.3 2013/05/18 14:15:33 zx2c4 Exp $
EAPI=5
@@ -8,9 +8,12 @@ inherit multilib user flag-o-matic eutils pam toolchain-funcs autotools versiona
DESCRIPTION="Lightweight but featured SMTP daemon from OpenBSD"
HOMEPAGE="http://www.opensmtpd.org/"
-MY_P="${P}"
-[ $(get_last_version_component_index) -eq 4 ] && MY_P="${PN}-$(get_version_component_range 4-)"
-SRC_URI="http://www.opensmtpd.org/archives/${MY_P/_}.tar.gz"
+MY_DP="${P}"
+if [ $(get_last_version_component_index) -eq 4 ]; then
+ MY_DP="${PN}-$(get_version_component_range 4-)"
+ MY_P="${PN}-${PV/.$(get_version_component_range 4)}"
+fi
+SRC_URI="http://www.opensmtpd.org/archives/${MY_DP/_}.tar.gz"
LICENSE="ISC BSD BSD-1 BSD-2 BSD-4"
SLOT="0"
@@ -37,7 +40,7 @@ DEPEND="dev-libs/openssl
"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${P/_}
+S=${WORKDIR}/${MY_P/_}
src_prepare() {
epatch "${FILESDIR}"/build-warnings.patch