summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-19 13:49:42 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-19 13:49:42 +0000
commit7b8043b68cc91692ef0ba9300bfb7b578cc92faf (patch)
tree3b413e41eef7f0eaaf662d0b95e0f039c61f0e98 /mail-mta/ssmtp
parentParallel compilation fix, 352119 (diff)
downloadgentoo-2-7b8043b68cc91692ef0ba9300bfb7b578cc92faf.tar.gz
gentoo-2-7b8043b68cc91692ef0ba9300bfb7b578cc92faf.tar.bz2
gentoo-2-7b8043b68cc91692ef0ba9300bfb7b578cc92faf.zip
Version bump; move patches to tarball; simplify ebuild. The md5sum (misnamed) and maxsysuid USE flags are gone (enabled by default); package builds with parallel make; automake is not used (faster src_prepare); add optional support for GnuTLS for those not wanting to use OpenSSL.
(Portage version: 2.2.0_alpha17/cvs/Linux x86_64)
Diffstat (limited to 'mail-mta/ssmtp')
-rw-r--r--mail-mta/ssmtp/ChangeLog11
-rw-r--r--mail-mta/ssmtp/files/ssmtp-2.61-bug127592.patch15
-rw-r--r--mail-mta/ssmtp/ssmtp-2.64.ebuild93
3 files changed, 103 insertions, 16 deletions
diff --git a/mail-mta/ssmtp/ChangeLog b/mail-mta/ssmtp/ChangeLog
index 18fe7c31c5f2..51dc4aac68bb 100644
--- a/mail-mta/ssmtp/ChangeLog
+++ b/mail-mta/ssmtp/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for mail-mta/ssmtp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/ssmtp/ChangeLog,v 1.105 2011/01/18 12:32:04 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/ssmtp/ChangeLog,v 1.106 2011/01/19 13:49:42 flameeyes Exp $
+
+*ssmtp-2.64 (19 Jan 2011)
+
+ 19 Jan 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ -files/ssmtp-2.61-bug127592.patch, +ssmtp-2.64.ebuild:
+ Version bump; move patches to tarball; simplify ebuild. The md5sum (misnamed)
+ and maxsysuid USE flags are gone (enabled by default); package builds with
+ parallel make; automake is not used (faster src_prepare); add optional
+ support for GnuTLS for those not wanting to use OpenSSL.
18 Jan 2011; Diego E. Pettenò <flameeyes@gentoo.org> -ssmtp-2.62-r6.ebuild,
-ssmtp-2.62-r7.ebuild, -files/CVE-2008-3962.patch, -files/mailer.conf:
diff --git a/mail-mta/ssmtp/files/ssmtp-2.61-bug127592.patch b/mail-mta/ssmtp/files/ssmtp-2.61-bug127592.patch
deleted file mode 100644
index 5d4a4229f26a..000000000000
--- a/mail-mta/ssmtp/files/ssmtp-2.61-bug127592.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -u ssmtp-2.61.orig/ssmtp.c ssmtp-2.61/ssmtp.c
---- ssmtp-2.61.orig/ssmtp.c 2004-07-22 23:58:48.000000000 -0600
-+++ ssmtp-2.61/ssmtp.c 2006-05-04 22:56:35.000000000 -0600
-@@ -480,6 +480,11 @@
- die("from_format() -- snprintf() failed");
- }
- }
-+ else {
-+ if(snprintf(buf, BUF_SZ, "%s", str) == -1) {
-+ die("from_format() -- snprintf() failed");
-+ }
-+ }
- }
-
- #if 0
diff --git a/mail-mta/ssmtp/ssmtp-2.64.ebuild b/mail-mta/ssmtp/ssmtp-2.64.ebuild
new file mode 100644
index 000000000000..ed09fcbe91e9
--- /dev/null
+++ b/mail-mta/ssmtp/ssmtp-2.64.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/ssmtp/ssmtp-2.64.ebuild,v 1.1 2011/01/19 13:49:42 flameeyes Exp $
+
+EAPI="3"
+
+PATCHES=1
+
+WANT_AUTOMAKE=none
+
+inherit eutils autotools
+
+DESCRIPTION="Extremely simple MTA to get mail off the system to a Mailhub"
+HOMEPAGE="ftp://ftp.debian.org/debian/pool/main/s/ssmtp/"
+SRC_URI="mirror://debian/pool/main/s/ssmtp/${P/-/_}.orig.tar.bz2
+ http://dev.gentoo.org/~flameeyes/ssmtp/${P}-patches-${PATCHES}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="ipv6 ssl gnutls"
+
+DEPEND="ssl? (
+ !gnutls? ( dev-libs/openssl )
+ gnutls? ( net-libs/gnutls )
+ )"
+RDEPEND="${DEPEND}
+ net-mail/mailbase
+ !net-mail/mailwrapper
+ !virtual/mta"
+PROVIDE="virtual/mta"
+
+pkg_setup() {
+ enewgroup ssmtp
+}
+
+src_prepare() {
+ EPATCH_SUFFIX="patch" EPATCH_SOURCE="${WORKDIR}/patches" \
+ epatch
+
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir="${EPREFIX}"/etc/ssmtp \
+ $(use_enable ssl) $(use_with gnutls) \
+ $(use_enable ipv6 inet6) \
+ --enable-md5auth
+}
+
+src_compile() {
+ emake etcdir="${EPREFIX}"/etc || die
+}
+
+src_install() {
+ dosbin ssmtp || die
+
+ doman ssmtp.8 ssmtp.conf.5 || die
+ dodoc INSTALL README TLS CHANGELOG_OLD || die
+ newdoc ssmtp.lsm DESC || die
+
+ insinto /etc/ssmtp
+ doins ssmtp.conf revaliases || die
+
+ local conffile="${ED}etc/ssmtp/ssmtp.conf"
+
+ # Sorry about the weird indentation, I couldn't figure out a cleverer way
+ # to do this without having horribly >80 char lines.
+ sed -i -e "s:^hostname=:\n# Gentoo bug #47562\\
+# Commenting the following line will force ssmtp to figure\\
+# out the hostname itself.\n\\
+# hostname=:" \
+ "${conffile}" || die "sed failed"
+
+ # Comment rewriteDomain (bug #243364)
+ sed -i -e "s:^rewriteDomain=:#rewriteDomain=:" "${conffile}"
+
+ # Set restrictive perms on ssmtp.conf as per #187841, #239197
+ # Protect the ssmtp configfile from being readable by regular users as it
+ # may contain login/password data to auth against a the mailhub used.
+ fowners root:ssmtp /etc/ssmtp/ssmtp.conf
+ fperms 640 /etc/ssmtp/ssmtp.conf
+
+ fowners root:ssmtp /usr/sbin/ssmtp
+ fperms 2711 /usr/sbin/ssmtp
+
+ dosym ../sbin/ssmtp /usr/lib/sendmail || die
+ dosym ../sbin/ssmtp /usr/bin/sendmail || die
+ dosym ssmtp /usr/sbin/sendmail || die
+ dosym ../sbin/ssmtp /usr/bin/mailq || die
+ dosym ../sbin/ssmtp /usr/bin/newaliases || die
+}