summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2009-01-22 22:29:46 +0000
committerMark Loeser <halcy0n@gentoo.org>2009-01-22 22:29:46 +0000
commit3439fe1dc225febc6a1e6009b907e69bc779852a (patch)
treeb8d9c31a00e8a93cfe2b3a333e7b2749c69538be /mail-filter
parenttransition to the non-no* use flags in libsdl (diff)
downloadgentoo-2-3439fe1dc225febc6a1e6009b907e69bc779852a.tar.gz
gentoo-2-3439fe1dc225febc6a1e6009b907e69bc779852a.tar.bz2
gentoo-2-3439fe1dc225febc6a1e6009b907e69bc779852a.zip
Patch to fix compilation with gcc-4.3 by Yaroslav Gorbunov <yagorbunov AT mail DOT ru>; bug #251151
(Portage version: 2.2_rc22/cvs/Linux 2.6.28 i686)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/mapson/ChangeLog9
-rw-r--r--mail-filter/mapson/files/mapson-3.0-gcc43.patch46
-rw-r--r--mail-filter/mapson/mapson-3.0.ebuild19
3 files changed, 67 insertions, 7 deletions
diff --git a/mail-filter/mapson/ChangeLog b/mail-filter/mapson/ChangeLog
index b256c1cfd5c3..bf3626fb8ad7 100644
--- a/mail-filter/mapson/ChangeLog
+++ b/mail-filter/mapson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/mapson
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/mapson/ChangeLog,v 1.5 2007/02/08 13:19:33 flameeyes Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/mapson/ChangeLog,v 1.6 2009/01/22 22:29:45 halcy0n Exp $
+
+ 22 Jan 2009; Mark Loeser <halcy0n@gentoo.org>
+ +files/mapson-3.0-gcc43.patch, mapson-3.0.ebuild:
+ Patch to fix compilation with gcc-4.3 by Yaroslav Gorbunov <yagorbunov AT
+ mail DOT ru>; bug #251151
08 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/mail-filter/mapson/files/mapson-3.0-gcc43.patch b/mail-filter/mapson/files/mapson-3.0-gcc43.patch
new file mode 100644
index 000000000000..f5f544bfa58a
--- /dev/null
+++ b/mail-filter/mapson/files/mapson-3.0-gcc43.patch
@@ -0,0 +1,46 @@
+diff -Nurpa mapson-3.0.orig/extract-addresses.cc mapson-3.0/extract-addresses.cc
+--- mapson-3.0.orig/extract-addresses.cc 2008-12-17 03:59:36.000000000 +0300
++++ mapson-3.0/extract-addresses.cc 2008-12-17 04:02:19.000000000 +0300
+@@ -12,6 +12,7 @@
+ #include "extract-addresses.hh"
+ #include "log.hh"
+ #include "config.hh"
++#include <cstring>
+
+ using namespace std;
+
+diff -Nurpa mapson-3.0.orig/libvarexp/search-and-replace.cc mapson-3.0/libvarexp/search-and-replace.cc
+--- mapson-3.0.orig/libvarexp/search-and-replace.cc 2008-12-17 03:59:36.000000000 +0300
++++ mapson-3.0/libvarexp/search-and-replace.cc 2008-12-17 04:00:16.000000000 +0300
+@@ -1,6 +1,7 @@
+ #include <sys/types.h>
+ #include <regex.h>
+ #include "internal.hh"
++#include <cstring>
+
+ namespace varexp
+ {
+diff -Nurpa mapson-3.0.orig/RegExp/RegExp.hh mapson-3.0/RegExp/RegExp.hh
+--- mapson-3.0.orig/RegExp/RegExp.hh 2008-12-17 03:59:36.000000000 +0300
++++ mapson-3.0/RegExp/RegExp.hh 2008-12-17 04:02:46.000000000 +0300
+@@ -8,7 +8,7 @@
+
+ #include <stdexcept>
+ #include <vector>
+-#include <string>
++#include <cstring>
+ #include <memory>
+ #include <sys/types.h>
+ #include <regex.h>
+diff -Nurpa mapson-3.0.orig/system-error/system-error.hh mapson-3.0/system-error/system-error.hh
+--- mapson-3.0.orig/system-error/system-error.hh 2008-12-17 03:59:36.000000000 +0300
++++ mapson-3.0/system-error/system-error.hh 2008-12-17 04:01:28.000000000 +0300
+@@ -9,7 +9,7 @@
+ // ISO C++ headers.
+ #include <stdexcept>
+ #include <cerrno>
+-#include <string>
++#include <cstring>
+
+ struct system_error : public std::runtime_error
+ {
diff --git a/mail-filter/mapson/mapson-3.0.ebuild b/mail-filter/mapson/mapson-3.0.ebuild
index bc63dc124b55..103f1f9bd924 100644
--- a/mail-filter/mapson/mapson-3.0.ebuild
+++ b/mail-filter/mapson/mapson-3.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/mapson/mapson-3.0.ebuild,v 1.5 2005/06/05 11:59:08 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/mapson/mapson-3.0.ebuild,v 1.6 2009/01/22 22:29:45 halcy0n Exp $
+
+inherit eutils
DESCRIPTION="A challenge/response-based white-list spam filter"
HOMEPAGE="http://mapson.sourceforge.net/"
@@ -13,6 +15,13 @@ IUSE="debug"
DEPEND="virtual/libc
virtual/mta"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
src_compile() {
./configure \
--build=${CHOST} \
@@ -26,13 +35,13 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
- cd ${D}/etc/mapson
+ cd "${D}"/etc/mapson
dodoc sample-config
mv sample-config mapson.config
- cd ${D}/usr/share/mapson
+ cd "${D}"/usr/share/mapson
dodoc sample-challenge-template
mv sample-challenge-template challenge-template
dohtml mapson.html