summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-01-21 22:47:34 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-01-21 22:47:34 +0000
commite1969f1034e4602c363519c263481774030f32c2 (patch)
tree00302f6c0cae470f6854ed9019d66be64e295199 /mail-filter/spamdyke
parentx86 stable, bug #206784 (diff)
downloadgentoo-2-e1969f1034e4602c363519c263481774030f32c2.tar.gz
gentoo-2-e1969f1034e4602c363519c263481774030f32c2.tar.bz2
gentoo-2-e1969f1034e4602c363519c263481774030f32c2.zip
Version bump to 3.1.4
(Portage version: 2.1.3.19)
Diffstat (limited to 'mail-filter/spamdyke')
-rw-r--r--mail-filter/spamdyke/ChangeLog7
-rw-r--r--mail-filter/spamdyke/files/digest-spamdyke-3.1.43
-rw-r--r--mail-filter/spamdyke/spamdyke-3.1.4.ebuild68
3 files changed, 77 insertions, 1 deletions
diff --git a/mail-filter/spamdyke/ChangeLog b/mail-filter/spamdyke/ChangeLog
index aaf381f6af42..6638491aecc2 100644
--- a/mail-filter/spamdyke/ChangeLog
+++ b/mail-filter/spamdyke/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/spamdyke
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamdyke/ChangeLog,v 1.1 2008/01/08 23:06:36 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamdyke/ChangeLog,v 1.2 2008/01/21 22:47:33 tupone Exp $
+
+*spamdyke-3.1.4 (21 Jan 2008)
+
+ 21 Jan 2008; Tupone Alfredo <tupone@gentoo.org> +spamdyke-3.1.4.ebuild:
+ Version bump to 3.1.4
*spamdyke-3.1.3 (08 Jan 2008)
diff --git a/mail-filter/spamdyke/files/digest-spamdyke-3.1.4 b/mail-filter/spamdyke/files/digest-spamdyke-3.1.4
new file mode 100644
index 000000000000..210ca368f52b
--- /dev/null
+++ b/mail-filter/spamdyke/files/digest-spamdyke-3.1.4
@@ -0,0 +1,3 @@
+MD5 e3a071618ed68fcc4f5c19ca25409453 spamdyke-3.1.4.tgz 259616
+RMD160 ad764fe7ed1a18e3fe05cb43850fa021c4a22ca5 spamdyke-3.1.4.tgz 259616
+SHA256 9e6718784118328fbea25668473d3d8d9daf9bb075a16ece40a567c996911bce spamdyke-3.1.4.tgz 259616
diff --git a/mail-filter/spamdyke/spamdyke-3.1.4.ebuild b/mail-filter/spamdyke/spamdyke-3.1.4.ebuild
new file mode 100644
index 000000000000..0928a18e3e72
--- /dev/null
+++ b/mail-filter/spamdyke/spamdyke-3.1.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamdyke/spamdyke-3.1.4.ebuild,v 1.1 2008/01/21 22:47:33 tupone Exp $
+
+EAPI="1"
+
+DESCRIPTION="A drop-in connection-time spam filter for qmail"
+HOMEPAGE="http://www.spamdyke.org/"
+SRC_URI="http://www.spamdyke.org/releases/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+tls"
+
+DEPEND="tls? ( dev-libs/openssl )"
+
+S=${WORKDIR}/${P}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ echo "# Configuration option for ${PN}" > ${PN}.conf
+ if use tls; then
+ echo "tls-certificate-file=/var/qmail/control/clientcert.pem" \
+ >> ${PN}.conf
+ fi
+ echo "graylist-dir=/var/tmp/${PN}/graylist" >> ${PN}.conf
+ echo "never-graylist-rdns-dir=/etc/${PN}/never-graylist" >> ${PN}.conf
+ echo "reject-empty-rdns" >> ${PN}.conf
+ echo "reject-unresolvable-rdns" >> ${PN}.conf
+}
+
+src_compile() {
+ econf --with-debug \
+ $(use_enable tls) || die "econf failed"
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+ cd ../utils
+ econf || die "econf failed in utils"
+ emake CFLAGS="${CFLAGS}" || die "emake in utils died"
+}
+
+src_install() {
+ dobin ${PN} || die "Installing ${PN} binary failed"
+ insinto /etc/${PN}
+ doins ${PN}.conf || die "Installing ${PN} configuration file failed"
+ keepdir /var/tmp/${PN}/graylist/$(../utils/domain2path -d localhost)
+ fowners -R qmaild /var/tmp/${PN}
+ insinto /etc/${PN}/never-graylist/$(../utils/domain2path -d localhost)
+ touch localhost
+ doins localhost
+ cd ../utils
+ dobin domain2path || die "Installing domain2path binary failed"
+ cd ../documentation
+ dodoc {Changelog,INSTALL,UPGRADING}.txt
+ dohtml FAQ.html \
+ README.html \
+ README_ip_file_format.html \
+ README_rdns_directory_format.html \
+ README_rdns_file_format.html
+}
+
+pkg_postinst() {
+ elog "In /var/qmail/control/conf-smtpd insert the line:"
+ elog "QMAIL_SMTP_PRE=\"${QMAIL_SMTP_PRE} spamdyke -f /etc/${PN}/${PN}.conf\""
+ elog "Run spamdyke with the '-h' flag to see the available options and"
+ elog "update /etc/spamdyke.conf accordingly"
+}