summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2007-08-29 20:36:31 +0000
committerPatrick McLean <chutzpah@gentoo.org>2007-08-29 20:36:31 +0000
commit36dcf18dde237ba48badcc6812310388a3c84483 (patch)
tree42f8b4f4cee6713fb5c71b33d089d5559e8c59f4 /mail-filter/spamassassin-botnet
parentgames-board/glchess unmasked. It will stay on the tree (diff)
downloadgentoo-2-36dcf18dde237ba48badcc6812310388a3c84483.tar.gz
gentoo-2-36dcf18dde237ba48badcc6812310388a3c84483.tar.bz2
gentoo-2-36dcf18dde237ba48badcc6812310388a3c84483.zip
Version bump.
(Portage version: 2.1.3.7)
Diffstat (limited to 'mail-filter/spamassassin-botnet')
-rw-r--r--mail-filter/spamassassin-botnet/ChangeLog8
-rw-r--r--mail-filter/spamassassin-botnet/files/digest-spamassassin-botnet-0.83
-rw-r--r--mail-filter/spamassassin-botnet/spamassassin-botnet-0.8.ebuild49
3 files changed, 59 insertions, 1 deletions
diff --git a/mail-filter/spamassassin-botnet/ChangeLog b/mail-filter/spamassassin-botnet/ChangeLog
index 8e8794f735c6..7d0a942f7ef0 100644
--- a/mail-filter/spamassassin-botnet/ChangeLog
+++ b/mail-filter/spamassassin-botnet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-filter/spamassassin-botnet
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamassassin-botnet/ChangeLog,v 1.2 2007/02/24 18:22:01 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamassassin-botnet/ChangeLog,v 1.3 2007/08/29 20:36:30 chutzpah Exp $
+
+*spamassassin-botnet-0.8 (29 Aug 2007)
+
+ 29 Aug 2007; Patrick McLean <chutzpah@gentoo.org>
+ +spamassassin-botnet-0.8.ebuild:
+ Version bump.
24 Feb 2007; Raúl Porcel <armin76@gentoo.org>
spamassassin-botnet-0.7.ebuild:
diff --git a/mail-filter/spamassassin-botnet/files/digest-spamassassin-botnet-0.8 b/mail-filter/spamassassin-botnet/files/digest-spamassassin-botnet-0.8
new file mode 100644
index 000000000000..c54929c14e94
--- /dev/null
+++ b/mail-filter/spamassassin-botnet/files/digest-spamassassin-botnet-0.8
@@ -0,0 +1,3 @@
+MD5 1bf1b358e7b1802c2ac15ca6bb084621 Botnet-0.8.tar 81920
+RMD160 3136bf28f347b02ca7a64c5954783b8969effd3c Botnet-0.8.tar 81920
+SHA256 f07cef396302e07cdbbdd2289d4433cde661973eeae5095d94dbff361b414c0b Botnet-0.8.tar 81920
diff --git a/mail-filter/spamassassin-botnet/spamassassin-botnet-0.8.ebuild b/mail-filter/spamassassin-botnet/spamassassin-botnet-0.8.ebuild
new file mode 100644
index 000000000000..54a6ff295779
--- /dev/null
+++ b/mail-filter/spamassassin-botnet/spamassassin-botnet-0.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamassassin-botnet/spamassassin-botnet-0.8.ebuild,v 1.1 2007/08/29 20:36:30 chutzpah Exp $
+
+inherit perl-module
+
+MY_PN="${PN/b/B}"
+MY_PN="${MY_PN/spamassassin-/}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="SpamAssassin plugin that attempts to detect messages sent by a botnet"
+HOMEPAGE="http://people.ucsc.edu/~jrudd/spamassassin/"
+SRC_URI="http://people.ucsc.edu/~jrudd/spamassassin/${MY_P}.tar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ >=mail-filter/spamassassin-3.0.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_compile() {
+ # make sure it doesn't try to look for the .pm in the same dir as the .cf
+ sed -rie 's/^(loadplugin.+)[ ]+Botnet.pm/\1/' Botnet.cf
+}
+
+src_install() {
+ perlinfo
+
+ local plugin_dir=${VENDOR_LIB}/Mail/SpamAssassin/Plugin
+
+ insinto ${plugin_dir}
+ doins ${MY_PN}.pm
+
+ insinto /etc/mail/spamassassin/
+ doins ${MY_PN}.cf
+
+ dodoc ${MY_PN}{{.{api,credits,variants},}.txt,.pl}
+}
+
+pkg_postinst() {
+ echo
+ elog "You need to restart spamassassin (as root) before this plugin will work:"
+ elog "/etc/init.d/spamd restart"
+ echo
+}