summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2008-03-28 18:27:55 +0000
committerAndrej Kacian <ticho@gentoo.org>2008-03-28 18:27:55 +0000
commitf93344950fa615392590e94468d9cab33f248c01 (patch)
tree6132eba62aa5455e742b4e58fc1d3ef572ead178 /mail-filter/policyd-weight
parentadd ~amd64 (diff)
downloadgentoo-2-f93344950fa615392590e94468d9cab33f248c01.tar.gz
gentoo-2-f93344950fa615392590e94468d9cab33f248c01.tar.bz2
gentoo-2-f93344950fa615392590e94468d9cab33f248c01.zip
Version bump.
(Portage version: 2.1.4.4)
Diffstat (limited to 'mail-filter/policyd-weight')
-rw-r--r--mail-filter/policyd-weight/ChangeLog8
-rw-r--r--mail-filter/policyd-weight/policyd-weight-0.1.14.17.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/mail-filter/policyd-weight/ChangeLog b/mail-filter/policyd-weight/ChangeLog
index ce06dac41bb8..8a1f9671917e 100644
--- a/mail-filter/policyd-weight/ChangeLog
+++ b/mail-filter/policyd-weight/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-filter/policyd-weight
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/policyd-weight/ChangeLog,v 1.10 2008/03/27 09:14:15 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/policyd-weight/ChangeLog,v 1.11 2008/03/28 18:27:55 ticho Exp $
+
+*policyd-weight-0.1.14.17 (28 Mar 2008)
+
+ 28 Mar 2008; Andrej Kacian <ticho@gentoo.org>
+ +policyd-weight-0.1.14.17.ebuild:
+ Version bump.
*policyd-weight-0.1.14.15 (27 Mar 2008)
diff --git a/mail-filter/policyd-weight/policyd-weight-0.1.14.17.ebuild b/mail-filter/policyd-weight/policyd-weight-0.1.14.17.ebuild
new file mode 100644
index 000000000000..bbca95f6450d
--- /dev/null
+++ b/mail-filter/policyd-weight/policyd-weight-0.1.14.17.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/policyd-weight/policyd-weight-0.1.14.17.ebuild,v 1.1 2008/03/28 18:27:55 ticho Exp $
+
+inherit eutils
+
+DESCRIPTION="Weighted Policy daemon for Postfix"
+HOMEPAGE="http://www.policyd-weight.org/"
+SRC_URI="http://www.policyd-weight.org/old/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="perl-core/Sys-Syslog
+ dev-perl/Net-DNS
+ >=mail-mta/postfix-2.1"
+
+pkg_setup() {
+ enewgroup 'polw'
+ enewuser 'polw' -1 -1 -1 'polw'
+}
+
+src_install() {
+ exeinto /usr/lib/postfix
+ doexe policyd-weight
+ fowners root:wheel /usr/lib/postfix/policyd-weight
+
+ doman man/man5/*.5 man/man8/*.8
+ dodoc *.txt
+
+ insinto /etc
+ newins policyd-weight.conf.sample policyd-weight.conf
+
+ newinitd "${FILESDIR}/${PN}.init.d" "${PN}"
+}
+
+pkg_postinst() {
+ elog "To use policyd-weight with postfix, update your /etc/postfix/main.cf file by adding"
+ elog " check_policy_service inet:127.0.0.1:12525"
+ elog "to your smtpd_recipient_restrictions."
+ elog
+ elog "Also remember to start policyd-weight at boot:"
+ elog " rc-update add policyd-weight default"
+ echo
+ ewarn "Please note:"
+ ewarn "If you are getting legitimate e-mails from verizon.net, it is advised to"
+ ewarn "whitelist the domain in postfix. Because of the way they send their"
+ ewarn "emails, they are often listed in RBLs."
+ echo
+}