summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2006-07-28 21:04:50 +0000
committerBryan Østergaard <kloeri@gentoo.org>2006-07-28 21:04:50 +0000
commitef912cf4421b3bb5850c611f46ab5c1408228740 (patch)
tree44bb01e6b952833bb444994c72b87771dcd5c406 /mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.5.ebuild
parentMake headers___fix use a word match which should work better. (diff)
downloadgentoo-2-ef912cf4421b3bb5850c611f46ab5c1408228740.tar.gz
gentoo-2-ef912cf4421b3bb5850c611f46ab5c1408228740.tar.bz2
gentoo-2-ef912cf4421b3bb5850c611f46ab5c1408228740.zip
Version bump, bug 141842.
(Portage version: 2.1.1_pre3-r5)
Diffstat (limited to 'mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.5.ebuild')
-rw-r--r--mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.5.ebuild184
1 files changed, 184 insertions, 0 deletions
diff --git a/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.5.ebuild b/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.5.ebuild
new file mode 100644
index 000000000000..1b448b637081
--- /dev/null
+++ b/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.5.ebuild
@@ -0,0 +1,184 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.5.ebuild,v 1.1 2006/07/28 21:04:50 kloeri Exp $
+
+unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
+inherit flag-o-matic toolchain-funcs eutils mozconfig-2 mozilla-launcher makeedit multilib autotools
+
+PVER="0.1"
+
+DESCRIPTION="Thunderbird Mail Client"
+HOMEPAGE="http://www.mozilla.org/projects/thunderbird/"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${PV}/source/thunderbird-${PV}-source.tar.bz2
+ mirror://gentoo/${P}-patches-${PVER}.tar.bz2"
+
+KEYWORDS="~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+IUSE="ldap crypt"
+
+RDEPEND=">=www-client/mozilla-launcher-1.39
+ >=dev-libs/nss-3.10
+ >=dev-libs/nspr-4.6.1
+ ~sys-devel/autoconf-2.13"
+
+PDEPEND="crypt? ( x11-plugins/enigmail ) "
+
+S=${WORKDIR}/mozilla
+
+# Needed by src_compile() and src_install().
+# Would do in pkg_setup but that loses the export attribute, they
+# become pure shell variables.
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+export MOZ_CO_PROJECT=mail
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die "cd failed"
+
+ # Apply our patches
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ epatch ${WORKDIR}/patch
+
+ # Fix a compilation issue using the 32-bit userland with 64-bit kernel on
+ # PowerPC, because with that configuration, it detects a ppc64 system.
+ # -- hansmi, 2005-11-13
+ if use ppc && [[ "${PROFILE_ARCH}" == ppc64 ]]; then
+ sed -i -e "s#OS_TEST=\`uname -m\`\$#OS_TEST=${ARCH}#" \
+ ${S}/configure
+ sed -i -e "s#OS_TEST :=.*uname -m.*\$#OS_TEST:=${ARCH}#" \
+ ${S}/security/coreconf/arch.mk
+ fi
+
+ WANT_AUTOCONF="2.1" \
+ eautoreconf || die "failed running autoreconf"
+}
+
+src_compile() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
+
+ ####################################
+ #
+ # mozconfig, CFLAGS and CXXFLAGS setup
+ #
+ ####################################
+
+ mozconfig_init
+ mozconfig_config
+
+ # tb-specific settings
+ mozconfig_use_enable ldap
+ mozconfig_use_enable ldap ldap-experimental
+ mozconfig_annotate '' --enable-extensions=default
+ mozconfig_annotate '' --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME}
+ mozconfig_annotate '' --with-user-appdir=.thunderbird
+ mozconfig_annotate '' --with-system-nspr
+ mozconfig_annotate '' --with-system-nss
+ mozconfig_annotate '' --enable-official-branding
+
+ # Finalize and report settings
+ mozconfig_final
+
+ # hardened GCC uses -fstack-protector-all by default, which breaks us
+ gcc-specs-ssp && append-flags -fno-stack-protector-all
+ replace-flags -fstack-protector-all -fstack-protector
+
+ ####################################
+ #
+ # Configure and build
+ #
+ ####################################
+ append-flags -freorder-blocks -fno-reorder-functions
+
+ # Export CPU_ARCH_TEST as it is not exported by default.
+ case $(tc-arch) in
+ amd64) [[ ${ABI} == "x86" ]] && CPU_ARCH_TEST="x86" || CPU_ARCH_TEST="x86_64" ;;
+ ia64) CPU_ARCH_TEST="ia64" ;;
+ ppc) CPU_ARCH_TEST="ppc" ;;
+ *) CPU_ARCH_TEST=$(tc-arch) ;;
+ esac
+
+ export CPU_ARCH_TEST
+
+ CPPFLAGS="${CPPFLAGS}" \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
+ econf || die
+
+ # This removes extraneous CFLAGS from the Makefiles to reduce RAM
+ # requirements while compiling
+ edit_makefiles
+
+ emake || die
+}
+
+pkg_preinst() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
+
+ echo ""
+ einfo "Removing old installs though some really ugly code. It potentially"
+ einfo "eliminates any problems during the install, however suggestions to"
+ einfo "replace this are highly welcome. Send comments and suggestions to"
+ einfo "mozilla@gentoo.org"
+ rm -rf ${ROOT}${MOZILLA_FIVE_HOME}
+ echo ""
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
+
+ # Most of the installation happens here
+ dodir ${MOZILLA_FIVE_HOME}
+ cp -RL "${S}/dist/bin/"* "${D}${MOZILLA_FIVE_HOME}" || die "Copy of files failed"
+
+ # Create directory structure to support portage-installed extensions.
+ # See update_chrome() in mozilla-launcher
+ keepdir ${MOZILLA_FIVE_HOME}/chrome.d
+ keepdir ${MOZILLA_FIVE_HOME}/extensions.d
+ cp ${D}${MOZILLA_FIVE_HOME}/chrome/installed-chrome.txt \
+ ${D}${MOZILLA_FIVE_HOME}/chrome.d/0_base-chrome.txt
+
+ # Create /usr/bin/thunderbird
+ install_mozilla_launcher_stub thunderbird ${MOZILLA_FIVE_HOME}
+
+ # Install icon and .desktop for menu entry
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/icon/thunderbird-icon.png
+
+ # Fix bug 54179: Install .desktop file into /usr/share/applications
+ # instead of /usr/share/gnome/apps/Internet (18 Jun 2004 agriffis)
+ insinto /usr/share/applications
+ doins ${FILESDIR}/icon/mozillathunderbird.desktop
+
+ ####################################
+ #
+ # Install files necessary for applications to build against firefox
+ #
+ ####################################
+
+ ewarn "Installing includes and idl files..."
+ dodir ${MOZILLA_FIVE_HOME}/idl ${MOZILLA_FIVE_HOME}/include
+ cd ${S}/dist
+ cp -LfR include/* ${D}${MOZILLA_FIVE_HOME}/include || die "failed to copy"
+ cp -LfR idl/* ${D}${MOZILLA_FIVE_HOME}/idl || die "failed to copy"
+
+ # Dirty hack to get some applications using this header running
+ dosym ${MOZILLA_FIVE_HOME}/include/necko/nsIURI.h \
+ /usr/$(get_libdir)/${MOZILLA_FIVE_HOME##*/}/include/nsIURI.h
+}
+
+pkg_postinst() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
+
+ # This should be called in the postinst and postrm of all the
+ # mozilla, mozilla-bin, firefox, firefox-bin, thunderbird and
+ # thunderbird-bin ebuilds.
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
+
+ update_mozilla_launcher_symlinks
+}