summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-08-01 22:04:14 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-08-01 22:04:14 +0000
commit1169317d5ae72b21146c726832b934458f388abd (patch)
treec7d3bd402e5eb68430aa33e5d2562194699b3c92 /mail-client/cone
parentMake libmcpp more flexible. Stable on amd64 wrt bug #328609 (diff)
downloadgentoo-2-1169317d5ae72b21146c726832b934458f388abd.tar.gz
gentoo-2-1169317d5ae72b21146c726832b934458f388abd.tar.bz2
gentoo-2-1169317d5ae72b21146c726832b934458f388abd.zip
Bump to EAPI 2 and fix build w/ GCC 4.5 (bug #321659).
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'mail-client/cone')
-rw-r--r--mail-client/cone/ChangeLog8
-rw-r--r--mail-client/cone/cone-0.79.ebuild10
-rw-r--r--mail-client/cone/files/cone-0.79-gcc45.patch13
3 files changed, 27 insertions, 4 deletions
diff --git a/mail-client/cone/ChangeLog b/mail-client/cone/ChangeLog
index e1c838d15d50..aa41dcdb9700 100644
--- a/mail-client/cone/ChangeLog
+++ b/mail-client/cone/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-client/cone
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/cone/ChangeLog,v 1.22 2009/07/11 11:47:54 tove Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/cone/ChangeLog,v 1.23 2010/08/01 22:04:13 dirtyepic Exp $
+
+ 01 Aug 2010; Ryan Hill <dirtyepic@gentoo.org> cone-0.79.ebuild,
+ +files/cone-0.79-gcc45.patch:
+ Bump to EAPI 2 and fix build w/ GCC 4.5 (bug #321659).
11 Jul 2009; Torsten Veller <tove@gentoo.org> -cone-0.64.ebuild,
-files/cone-dotsignature.patch:
diff --git a/mail-client/cone/cone-0.79.ebuild b/mail-client/cone/cone-0.79.ebuild
index 8cd032ec29f8..e1ebae33e98f 100644
--- a/mail-client/cone/cone-0.79.ebuild
+++ b/mail-client/cone/cone-0.79.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/cone/cone-0.79.ebuild,v 1.1 2009/07/11 11:44:01 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/cone/cone-0.79.ebuild,v 1.2 2010/08/01 22:04:13 dirtyepic Exp $
+
+EAPI="2"
inherit eutils
@@ -21,6 +23,10 @@ RDEPEND=">=dev-libs/openssl-0.9.6
DEPEND="${RDEPEND}
dev-lang/perl"
+src_prepare() {
+ epatch "${FILESDIR}"/cone-0.79-gcc45.patch
+}
+
src_install() {
emake install DESTDIR="${D}" || die
DESTDIR="${D}" emake install-configure || die
diff --git a/mail-client/cone/files/cone-0.79-gcc45.patch b/mail-client/cone/files/cone-0.79-gcc45.patch
new file mode 100644
index 000000000000..50f09b05bee0
--- /dev/null
+++ b/mail-client/cone/files/cone-0.79-gcc45.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/321659
+
+--- a/libmail/headers.C
++++ b/libmail/headers.C
+@@ -86,7 +86,7 @@ string mail::Header::encoded::encode(string text, string charset, string lang)
+ if (lang.size() > 0)
+ charset += "*" + lang;
+
+- return mail::rfc2047::encode::encode(text, charset);
++ return mail::rfc2047::encode(text, charset);
+ }
+
+ mail::Header::encoded::encoded(string name,