summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-08-05 09:42:49 +0000
committerBen de Groot <yngwin@gentoo.org>2009-08-05 09:42:49 +0000
commitd411a4cc2d8d6b8d709205276ada7ff6e90c5926 (patch)
tree7241278a0fd23507f06b805b495547ae54ec666a /lxde-base
parentUnmask native-cctools without package.unmask, bug #280433, it looks like it d... (diff)
downloadgentoo-2-d411a4cc2d8d6b8d709205276ada7ff6e90c5926.tar.gz
gentoo-2-d411a4cc2d8d6b8d709205276ada7ff6e90c5926.tar.bz2
gentoo-2-d411a4cc2d8d6b8d709205276ada7ff6e90c5926.zip
Version bump
(Portage version: 2.2_rc35/cvs/Linux x86_64)
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxpanel/ChangeLog7
-rw-r--r--lxde-base/lxpanel/lxpanel-0.5.2.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/lxde-base/lxpanel/ChangeLog b/lxde-base/lxpanel/ChangeLog
index 62a6cd9ebe89..d020217adc87 100644
--- a/lxde-base/lxpanel/ChangeLog
+++ b/lxde-base/lxpanel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for lxde-base/lxpanel
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/ChangeLog,v 1.6 2009/08/04 18:56:42 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/ChangeLog,v 1.7 2009/08/05 09:42:49 yngwin Exp $
+
+*lxpanel-0.5.2 (05 Aug 2009)
+
+ 05 Aug 2009; Ben de Groot <yngwin@gentoo.org> +lxpanel-0.5.2.ebuild:
+ Version bump
*lxpanel-0.5.1 (04 Aug 2009)
diff --git a/lxde-base/lxpanel/lxpanel-0.5.2.ebuild b/lxde-base/lxpanel/lxpanel-0.5.2.ebuild
new file mode 100644
index 000000000000..b5a028c07711
--- /dev/null
+++ b/lxde-base/lxpanel/lxpanel-0.5.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/lxpanel-0.5.2.ebuild,v 1.1 2009/08/05 09:42:49 yngwin Exp $
+
+EAPI="2"
+inherit eutils autotools
+
+DESCRIPTION="Lightweight X11 desktop panel for LXDE"
+HOMEPAGE="http://lxde.sf.net/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="+X +alsa"
+RESTRICT="test" # bug 249598
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libXmu
+ x11-libs/libXpm
+ lxde-base/lxmenu-data
+ lxde-base/menu-cache
+ alsa? ( media-libs/alsa-lib )
+ X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.5.1-sandbox.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable alsa) \
+ $(use_with X x) \
+ --with-plugins=all
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README || die "dodoc failed"
+}