summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-06-15 18:35:14 +0000
committerMichael Palimaka <kensington@gentoo.org>2015-06-15 18:35:14 +0000
commit2d1c788f76931abc4ee8e8e0bc452767337abfa4 (patch)
treee9d1ed35c8e4f46168e251027feaa048dcc1a955 /kde-frameworks/knotifications
parentUpdating remote-id in metadata.xml (diff)
downloadgentoo-2-2d1c788f76931abc4ee8e8e0bc452767337abfa4.tar.gz
gentoo-2-2d1c788f76931abc4ee8e8e0bc452767337abfa4.tar.bz2
gentoo-2-2d1c788f76931abc4ee8e8e0bc452767337abfa4.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'kde-frameworks/knotifications')
-rw-r--r--kde-frameworks/knotifications/ChangeLog8
-rw-r--r--kde-frameworks/knotifications/knotifications-5.11.0.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/kde-frameworks/knotifications/ChangeLog b/kde-frameworks/knotifications/ChangeLog
index 20ff2fb54b7f..077c079557b0 100644
--- a/kde-frameworks/knotifications/ChangeLog
+++ b/kde-frameworks/knotifications/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-frameworks/knotifications
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/knotifications/ChangeLog,v 1.14 2015/05/23 01:33:52 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/knotifications/ChangeLog,v 1.15 2015/06/15 18:35:13 kensington Exp $
+
+*knotifications-5.11.0 (15 Jun 2015)
+
+ 15 Jun 2015; Michael Palimaka <kensington@gentoo.org>
+ +knotifications-5.11.0.ebuild:
+ Version bump.
23 May 2015; Manuel Rüger <mrueg@gentoo.org> -knotifications-5.9.0.ebuild:
Remove old.
diff --git a/kde-frameworks/knotifications/knotifications-5.11.0.ebuild b/kde-frameworks/knotifications/knotifications-5.11.0.ebuild
new file mode 100644
index 000000000000..5c3b537c8996
--- /dev/null
+++ b/kde-frameworks/knotifications/knotifications-5.11.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/knotifications/knotifications-5.11.0.ebuild,v 1.1 2015/06/15 18:35:13 kensington Exp $
+
+EAPI=5
+
+KDE_TEST="false"
+inherit kde5
+
+DESCRIPTION="Framework for notifying the user of an event, including feedback and persistant events"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus X nls"
+
+RDEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwindowsystem)
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ media-libs/phonon[qt5]
+ dbus? ( dev-libs/libdbusmenu-qt[qt5] )
+ X? (
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+"
+DEPEND="${RDEPEND}
+ nls? ( dev-qt/linguist-tools:5 )
+ X? ( x11-proto/xproto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X X11)
+ $(cmake-utils_use_find_package dbus DBusMenuQt5)
+ )
+
+ kde5_src_configure
+}