summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-05-14 15:49:37 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-05-14 15:49:37 +0000
commit589ec2020da6d44ac460b5dd8b0361939ca3632e (patch)
treeb932cfe96389193c78cd8169daca5596af6a32c8 /kde-base
parentFix documentation directory, bug 364857 (diff)
downloadgentoo-2-589ec2020da6d44ac460b5dd8b0361939ca3632e.tar.gz
gentoo-2-589ec2020da6d44ac460b5dd8b0361939ca3632e.tar.bz2
gentoo-2-589ec2020da6d44ac460b5dd8b0361939ca3632e.zip
Remember desktop names on logout, bug 366963
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kwin/ChangeLog8
-rw-r--r--kde-base/kwin/files/kwin-4.6.3-desktopnames.patch38
-rw-r--r--kde-base/kwin/kwin-4.6.3-r1.ebuild73
3 files changed, 118 insertions, 1 deletions
diff --git a/kde-base/kwin/ChangeLog b/kde-base/kwin/ChangeLog
index 766d71872a76..553c042f45d0 100644
--- a/kde-base/kwin/ChangeLog
+++ b/kde-base/kwin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kwin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.222 2011/05/09 23:17:20 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.223 2011/05/14 15:49:37 dilfridge Exp $
+
+*kwin-4.6.3-r1 (14 May 2011)
+
+ 14 May 2011; Andreas K. Huettel <dilfridge@gentoo.org> +kwin-4.6.3-r1.ebuild,
+ +files/kwin-4.6.3-desktopnames.patch:
+ Remember desktop names on logout, bug 366963
09 May 2011; Markos Chandras <hwoarang@gentoo.org> kwin-4.6.2.ebuild:
Stable on amd64 wrt bug #354033
diff --git a/kde-base/kwin/files/kwin-4.6.3-desktopnames.patch b/kde-base/kwin/files/kwin-4.6.3-desktopnames.patch
new file mode 100644
index 000000000000..ec2b3642ac50
--- /dev/null
+++ b/kde-base/kwin/files/kwin-4.6.3-desktopnames.patch
@@ -0,0 +1,38 @@
+commit a2d4c3ebdf7137f3543c88245f0bfd3dba308ebf
+Author: Thomas Lübking <thomas.luebking@gmail.com>
+Date: Sun May 8 16:27:31 2011 +0200
+
+ Don't store virtual desktop settings while loading them
+
+ BUG: 272666
+ FIXED-IN: 4.6.4
+
+diff --git a/kwin/workspace.cpp b/kwin/workspace.cpp
+index 3033e65..f5df9d9 100644
+--- a/kwin/workspace.cpp
++++ b/kwin/workspace.cpp
+@@ -1229,8 +1229,10 @@ void Workspace::slotReinitCompositing()
+ }
+ }
+
++static bool _loading_desktop_settings = false;
+ void Workspace::loadDesktopSettings()
+ {
++ _loading_desktop_settings = true;
+ KSharedConfig::Ptr c = KGlobal::config();
+ QString groupname;
+ if( screen_number == 0 )
+@@ -1246,10 +1248,13 @@ void Workspace::loadDesktopSettings()
+ rootInfo->setDesktopName( i, s.toUtf8().data() );
+ desktop_focus_chain[i-1] = i;
+ }
++ _loading_desktop_settings = false;
+ }
+
+ void Workspace::saveDesktopSettings()
+ {
++ if (_loading_desktop_settings)
++ return;
+ KSharedConfig::Ptr c = KGlobal::config();
+ QString groupname;
+ if (screen_number == 0)
diff --git a/kde-base/kwin/kwin-4.6.3-r1.ebuild b/kde-base/kwin/kwin-4.6.3-r1.ebuild
new file mode 100644
index 000000000000..415d7725a5c0
--- /dev/null
+++ b/kde-base/kwin/kwin-4.6.3-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.6.3-r1.ebuild,v 1.1 2011/05/14 15:49:37 dilfridge Exp $
+
+EAPI=4
+
+KMNAME="kdebase-workspace"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE window manager"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug xcomposite xinerama"
+
+# NOTE disabled for now: captury? ( media-libs/libcaptury )
+COMMONDEPEND="
+ $(add_kdebase_dep kephal)
+ $(add_kdebase_dep libkworkspace)
+ $(add_kdebase_dep liboxygenstyle)
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ >=x11-libs/libXrandr-1.2.1
+ x11-libs/libXrender
+ opengl? ( virtual/opengl )
+ xcomposite? ( x11-libs/libXcomposite )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/damageproto
+ x11-proto/fixesproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ xcomposite? ( x11-proto/compositeproto )
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}
+ x11-apps/scripts
+"
+
+KMEXTRACTONLY="
+ ksmserver/
+ libs/kephal/
+ libs/oxygen/
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.4.2-xinerama_cmake_automagic.patch"
+ "${FILESDIR}/${PN}-fix-opengl.patch"
+ "${FILESDIR}/${PN}-4.6.3-desktopnames.patch"
+)
+
+src_prepare() {
+# NOTE uncomment when enabled again by upstream
+# if ! use captury; then
+# sed -e 's:^PKGCONFIG..libcaptury:#DONOTFIND &:' \
+# -i kwin/effects/CMakeLists.txt || \
+# die "Making captury optional failed."
+# fi
+
+ kde4-meta_src_prepare
+}
+
+src_configure() {
+ # FIXME Remove when activity API moved away from libkworkspace
+ append-cppflags "-I${EKDEDIR}/include/kworkspace"
+
+ mycmakeargs=(
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with xinerama X11_Xinerama)
+ )
+
+ kde4-meta_src_configure
+}