summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-15 20:02:05 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-15 20:02:05 +0000
commit3e05dc58bd18e37f40f72c9a00f87616be323e48 (patch)
treeb3b97fcc9f94d40b262976ececde2d5ba02dc613 /kde-base
parentppc64 stable wrt #338616 (diff)
downloadgentoo-2-3e05dc58bd18e37f40f72c9a00f87616be323e48.tar.gz
gentoo-2-3e05dc58bd18e37f40f72c9a00f87616be323e48.tar.bz2
gentoo-2-3e05dc58bd18e37f40f72c9a00f87616be323e48.zip
Fix compatibility with >=dev-python/PyQt4-4.7.5 (bug #349453).
(Portage version: 2.2.0_alpha15_p2/cvs/Linux x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/pykde4/ChangeLog8
-rw-r--r--kde-base/pykde4/files/pykde4-4.4.5-PyQt4-4.7.5.patch32
-rw-r--r--kde-base/pykde4/pykde4-4.4.5-r1.ebuild90
3 files changed, 129 insertions, 1 deletions
diff --git a/kde-base/pykde4/ChangeLog b/kde-base/pykde4/ChangeLog
index c2aa6fabfac6..bc6bf7926bbc 100644
--- a/kde-base/pykde4/ChangeLog
+++ b/kde-base/pykde4/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/pykde4
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.96 2011/01/10 11:53:48 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.97 2011/01/15 20:02:04 arfrever Exp $
+
+*pykde4-4.4.5-r1 (15 Jan 2011)
+
+ 15 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pykde4-4.4.5-r1.ebuild, +files/pykde4-4.4.5-PyQt4-4.7.5.patch:
+ Fix compatibility with >=dev-python/PyQt4-4.7.5 (bug #349453).
*pykde4-4.5.5 (10 Jan 2011)
diff --git a/kde-base/pykde4/files/pykde4-4.4.5-PyQt4-4.7.5.patch b/kde-base/pykde4/files/pykde4-4.4.5-PyQt4-4.7.5.patch
new file mode 100644
index 000000000000..c0ccdc071a62
--- /dev/null
+++ b/kde-base/pykde4/files/pykde4-4.4.5-PyQt4-4.7.5.patch
@@ -0,0 +1,32 @@
+https://bugs.gentoo.org/show_bug.cgi?id=349453
+http://websvn.kde.org/?view=revision&revision=1209688
+
+--- python/pykde4/tools/pykdeuic4/pykdeuic4.py
++++ python/pykde4/tools/pykdeuic4/pykdeuic4.py
+@@ -39,7 +39,7 @@
+ def __init__(self,string):
+ original_i18n_string.__init__(self,string)
+ def __str__(self):
+- return "kdecore.i18n(\"%s\")" % (qtproxies.escape(self.string),)
++ return "kdecore.i18n(%s)" % (qtproxies.as_string(self.string),)
+ qtproxies.i18n_string = kde_i18n_string
+
+ def kdeFilter():
+@@ -71,7 +71,7 @@
+ indenter.indentwidth = indent
+ comp = compiler.UICompiler()
+ comp.factory._cwFilters.append(kdeFilter())
+- winfo = comp.compileUi(uifile, output)
++ winfo = comp.compileUi(uifile, output, None)
+
+ if exe:
+ output.write("""
+@@ -104,7 +104,7 @@
+ app = kdeui.KApplication()
+ mainWindow = MainWin(None, "main window")
+ mainWindow.show()
+- app.connect (app, QtCore.SIGNAL ("lastWindowClosed ()"), app.quit)
++ app.lastWindowClosed.connect(app.quit)
+ app.exec_ ()
+ """)
+
diff --git a/kde-base/pykde4/pykde4-4.4.5-r1.ebuild b/kde-base/pykde4/pykde4-4.4.5-r1.ebuild
new file mode 100644
index 000000000000..92805f4dc22a
--- /dev/null
+++ b/kde-base/pykde4/pykde4-4.4.5-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/pykde4-4.4.5-r1.ebuild,v 1.1 2011/01/15 20:02:05 arfrever Exp $
+
+EAPI="3"
+
+KMNAME="kdebindings"
+KMMODULE="python/pykde4"
+OPENGL_REQUIRED="always"
+PYTHON_USE_WITH="threads"
+RESTRICT_PYTHON_ABIS="2.4"
+inherit python kde4-meta
+
+DESCRIPTION="Python bindings for KDE4"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug doc examples semantic-desktop"
+
+# blocker added due to compatibility issues and error during compile time
+DEPEND="
+ !dev-python/pykde
+ $(add_kdebase_dep kdelibs 'opengl,semantic-desktop?')
+ semantic-desktop? ( $(add_kdebase_dep kdepimlibs 'semantic-desktop') )
+ aqua? ( >=dev-python/PyQt4-4.8[dbus,sql,svg,webkit,aqua] )
+ !aqua? ( >=dev-python/PyQt4-4.8[dbus,sql,svg,webkit,X] )
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python_pkg_setup
+ kde4-meta_pkg_setup
+}
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ if ! use examples; then
+ sed -e '/^ADD_SUBDIRECTORY(examples)/s/^/# DISABLED /' -i python/${PN}/CMakeLists.txt \
+ || die "Failed to disable examples"
+ fi
+
+ # See bug 328135
+ epatch "${FILESDIR}"/${PN}-4.4.92-build-fix-sip.patch
+
+ # See bug 322351
+ use arm && epatch "${FILESDIR}/${PN}-4.4.4-arm-sip.patch"
+
+ epatch "${FILESDIR}/${PN}-mapped-type-fix.patch"
+ has_version ">=dev-python/sip-4.12" && epatch "${FILESDIR}/${P}-sip-4.12.patch"
+ epatch "${FILESDIR}/${P}-PyQt4-4.7.5.patch"
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_QScintilla=OFF
+ -DWITH_PolkitQt=OFF
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop KdepimLibs)
+ )
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${S}/python/pykde4/docs/html/")
+
+ kde4-meta_src_install
+
+ python_convert_shebangs -r $(python_get_version) "${ED}"
+ python_clean_installation_image -q
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ python_mod_optimize PyKDE4 PyQt4
+
+ if use examples; then
+ echo
+ elog "PyKDE4 examples have been installed to"
+ elog "${EKDEDIR}/share/apps/${PN}/examples"
+ echo
+ fi
+}
+
+pkg_postrm() {
+ kde4-meta_pkg_postrm
+
+ python_mod_cleanup PyKDE4 PyQt4
+}