summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-08-01 22:17:38 +0000
committerJohannes Huber <johu@gentoo.org>2012-08-01 22:17:38 +0000
commit401c3e3183c60a1db08e8b751d4e9f8e7a3dc5b3 (patch)
treeacda1b1644e123ebe3d9623addcce4017adb629d /kde-base/superkaramba
parentversion bump for bug 424525, ebuild provided by Ortwin Glück (diff)
downloadgentoo-2-401c3e3183c60a1db08e8b751d4e9f8e7a3dc5b3.tar.gz
gentoo-2-401c3e3183c60a1db08e8b751d4e9f8e7a3dc5b3.tar.bz2
gentoo-2-401c3e3183c60a1db08e8b751d4e9f8e7a3dc5b3.zip
Version bump KDE SC 4.9.0
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/superkaramba')
-rw-r--r--kde-base/superkaramba/ChangeLog7
-rw-r--r--kde-base/superkaramba/superkaramba-4.9.0.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/kde-base/superkaramba/ChangeLog b/kde-base/superkaramba/ChangeLog
index b40a52f3d5ac..941f46837cd6 100644
--- a/kde-base/superkaramba/ChangeLog
+++ b/kde-base/superkaramba/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/superkaramba
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.203 2012/06/21 21:54:39 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.204 2012/08/01 22:17:15 johu Exp $
+
+*superkaramba-4.9.0 (01 Aug 2012)
+
+ 01 Aug 2012; Johannes Huber <johu@gentoo.org> +superkaramba-4.9.0.ebuild:
+ Version bump KDE SC 4.9.0
*superkaramba-4.8.4 (21 Jun 2012)
diff --git a/kde-base/superkaramba/superkaramba-4.9.0.ebuild b/kde-base/superkaramba/superkaramba-4.9.0.ebuild
new file mode 100644
index 000000000000..a3ad5d670bf3
--- /dev/null
+++ b/kde-base/superkaramba/superkaramba-4.9.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/superkaramba-4.9.0.ebuild,v 1.1 2012/08/01 22:17:15 johu Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2"
+KDE_SCM="git"
+inherit python kde4-base
+
+DESCRIPTION="A tool to create interactive applets for the KDE desktop."
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug python"
+
+DEPEND="
+ media-libs/qimageblitz
+ python? ( $(add_kdebase_dep pykde4) )
+"
+RDEPEND="${DEPEND}
+ python? ( $(add_kdebase_dep krosspython) )
+"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with python PythonLibs)
+ )
+
+ kde4-base_src_configure
+}