summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-05-24 11:38:12 +0000
committerJohannes Huber <johu@gentoo.org>2012-05-24 11:38:12 +0000
commite0f5e65186f3fc9ec726887970dea246abfebf48 (patch)
tree3824e79eeb509f469eeec724afb59871e7d27ca3 /kde-base/qtruby
parentTypo in comment (diff)
downloadgentoo-2-e0f5e65186f3fc9ec726887970dea246abfebf48.tar.gz
gentoo-2-e0f5e65186f3fc9ec726887970dea246abfebf48.tar.bz2
gentoo-2-e0f5e65186f3fc9ec726887970dea246abfebf48.zip
Remove KDE SC 4.8.1
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/qtruby')
-rw-r--r--kde-base/qtruby/ChangeLog5
-rw-r--r--kde-base/qtruby/qtruby-4.8.1.ebuild75
2 files changed, 4 insertions, 76 deletions
diff --git a/kde-base/qtruby/ChangeLog b/kde-base/qtruby/ChangeLog
index 00b50c5a8ad1..64d6b4107b5b 100644
--- a/kde-base/qtruby/ChangeLog
+++ b/kde-base/qtruby/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/qtruby
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.111 2012/05/24 10:14:14 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.112 2012/05/24 11:37:55 johu Exp $
+
+ 24 May 2012; Johannes Huber <johu@gentoo.org> -qtruby-4.8.1.ebuild:
+ Remove KDE SC 4.8.1
24 May 2012; Agostino Sarubbo <ago@gentoo.org> qtruby-4.8.3.ebuild:
Stable for x86, wrt bug #414605
diff --git a/kde-base/qtruby/qtruby-4.8.1.ebuild b/kde-base/qtruby/qtruby-4.8.1.ebuild
deleted file mode 100644
index 11d9837b7814..000000000000
--- a/kde-base/qtruby/qtruby-4.8.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/qtruby-4.8.1.ebuild,v 1.3 2012/04/18 18:42:29 maekke Exp $
-
-EAPI=4
-
-OPENGL_REQUIRED="always"
-DECLARATIVE_REQUIRED="optional"
-KDE_REQUIRED="never"
-KDE_SCM="git"
-USE_RUBY="ruby18"
-# No ruby19 for three reasons:
-# 1) it does not build (yet) - will likely be solved soon
-# 2) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
-# 3) the ebuild can only be installed for one ruby variant, otherwise the compiled
-# files with identical path+name will overwrite each other - difficult :(
-
-inherit kde4-base ruby-ng
-
-DESCRIPTION="Qt Ruby bindings"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="debug phonon qscintilla qwt webkit"
-
-DEPEND="
- $(add_kdebase_dep smokeqt 'declarative?,opengl,phonon?,qscintilla?,qwt?,webkit?')
-"
-
-RDEPEND="${DEPEND}
-"
-
-# Split from kdebindings-ruby in 4.7
-add_blocker kdebindings-ruby
-
-pkg_setup() {
- ruby-ng_pkg_setup
- kde4-base_pkg_setup
-}
-
-src_unpack() {
- local S="${WORKDIR}/${P}"
- kde4-base_src_unpack
-
- cd "${WORKDIR}"
- mkdir all
- mv ${P} all/ || die "Could not move sources"
-}
-
-all_ruby_prepare() {
- kde4-base_src_prepare
-}
-
-each_ruby_configure() {
- local CMAKE_USE_DIR=${S}
- mycmakeargs=(
- -DRUBY_LIBRARY=$(ruby_get_libruby)
- -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
- -DRUBY_EXECUTABLE=${RUBY}
- $(cmake-utils_use_disable declarative QtDeclarative)
- $(cmake-utils_use_with phonon)
- $(cmake-utils_use_with qscintilla QScintilla)
- $(cmake-utils_use_with qwt Qwt5)
- $(cmake-utils_use_disable webkit QtWebKit)
- )
- kde4-base_src_configure
-}
-
-each_ruby_compile() {
- local CMAKE_USE_DIR=${S}
- kde4-base_src_compile
-}
-
-each_ruby_install() {
- local CMAKE_USE_DIR=${S}
- kde4-base_src_install
-}