summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-05-07 00:16:06 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-05-07 00:16:06 +0000
commit883f7cdba85375943d1776370c10f1cf4fb5b498 (patch)
tree9b071a79f472d6b7f8a480be992beebac310d390 /kde-base/okular
parentVersion bump KDE 4.2.3 (diff)
downloadgentoo-2-883f7cdba85375943d1776370c10f1cf4fb5b498.tar.gz
gentoo-2-883f7cdba85375943d1776370c10f1cf4fb5b498.tar.bz2
gentoo-2-883f7cdba85375943d1776370c10f1cf4fb5b498.zip
Version bump KDE 4.2.3
(Portage version: 2.2_rc31/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/okular')
-rw-r--r--kde-base/okular/ChangeLog7
-rw-r--r--kde-base/okular/okular-4.2.3.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-base/okular/ChangeLog b/kde-base/okular/ChangeLog
index 57a2f8de6bf4..6166add56290 100644
--- a/kde-base/okular/ChangeLog
+++ b/kde-base/okular/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/okular
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.31 2009/04/17 07:56:58 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.32 2009/05/07 00:16:06 scarabeus Exp $
+
+*okular-4.2.3 (07 May 2009)
+
+ 07 May 2009; Tomas Chvatal <scarabeus@gentoo.org> +okular-4.2.3.ebuild:
+ Version bump
17 Apr 2009; Alexey Shvetsov <alexxy@gentoo.org> -okular-4.2.1.ebuild,
okular-4.2.2:
diff --git a/kde-base/okular/okular-4.2.3.ebuild b/kde-base/okular/okular-4.2.3.ebuild
new file mode 100644
index 000000000000..93000d3ed5d9
--- /dev/null
+++ b/kde-base/okular/okular-4.2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/okular-4.2.3.ebuild,v 1.1 2009/05/07 00:16:06 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="kdegraphics"
+inherit kde4-meta
+
+DESCRIPTION="Okular is an universal document viewer based on KPDF for KDE 4."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="chm crypt debug djvu doc ebook +jpeg +ps +pdf +tiff"
+
+DEPEND="
+ media-libs/freetype
+ chm? ( dev-libs/chmlib )
+ crypt? ( app-crypt/qca:2 )
+ djvu? ( app-text/djvu )
+ ebook? ( app-text/ebook-tools )
+ jpeg? ( media-libs/jpeg )
+ pdf? ( >=virtual/poppler-qt4-0.8.5 )
+ ps? ( app-text/libspectre )
+ tiff? ( media-libs/tiff )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with chm CHM)
+ $(cmake-utils_use_with crypt QCA2)
+ $(cmake-utils_use_with djvu DjVuLibre)
+ $(cmake-utils_use_with ebook EPub)
+ $(cmake-utils_use_with jpeg JPEG)
+ $(cmake-utils_use_with ps LibSpectre)
+ $(cmake-utils_use_with pdf PopplerQt4)
+ $(cmake-utils_use_with pdf Poppler)
+ $(cmake-utils_use_with tiff TIFF)"
+
+ kde4-meta_src_configure
+}