summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-05-06 20:18:53 +0000
committerJohannes Huber <johu@gentoo.org>2013-05-06 20:18:53 +0000
commit2371cce4f3cea5589c1c6d562a1fc6e5bdd25b51 (patch)
tree733e9e1acf77d4f47af78826e93c8cf4d670bf27 /kde-base/okular
parentFix LICENSE, bug 447390. (diff)
downloadgentoo-2-2371cce4f3cea5589c1c6d562a1fc6e5bdd25b51.tar.gz
gentoo-2-2371cce4f3cea5589c1c6d562a1fc6e5bdd25b51.tar.bz2
gentoo-2-2371cce4f3cea5589c1c6d562a1fc6e5bdd25b51.zip
Version bump KDE SC 4.10.3.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, RepoMan options: --include-arches="amd64", signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/okular')
-rw-r--r--kde-base/okular/ChangeLog7
-rw-r--r--kde-base/okular/okular-4.10.3.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/okular/ChangeLog b/kde-base/okular/ChangeLog
index ce45ab994b3c..b837a43c6353 100644
--- a/kde-base/okular/ChangeLog
+++ b/kde-base/okular/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/okular
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.187 2013/05/05 11:51:08 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.188 2013/05/06 20:18:18 johu Exp $
+
+*okular-4.10.3 (06 May 2013)
+
+ 06 May 2013; Johannes Huber <johu@gentoo.org> +okular-4.10.3.ebuild:
+ Version bump KDE SC 4.10.3
05 May 2013; Agostino Sarubbo <ago@gentoo.org> -okular-4.10.1.ebuild:
Remove old
diff --git a/kde-base/okular/okular-4.10.3.ebuild b/kde-base/okular/okular-4.10.3.ebuild
new file mode 100644
index 000000000000..a17975a011d6
--- /dev/null
+++ b/kde-base/okular/okular-4.10.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/okular-4.10.3.ebuild,v 1.1 2013/05/06 20:18:18 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="Okular is an universal document viewer based on KPDF for KDE 4."
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="chm crypt debug djvu ebook +jpeg +postscript +pdf +tiff"
+
+DEPEND="
+ media-libs/freetype
+ media-libs/qimageblitz
+ sys-libs/zlib
+ chm? ( dev-libs/chmlib )
+ crypt? ( app-crypt/qca:2 )
+ djvu? ( app-text/djvu )
+ ebook? ( app-text/ebook-tools )
+ jpeg? ( virtual/jpeg:0 )
+ pdf? ( >=app-text/poppler-0.20[qt4,-exceptions(-)] )
+ postscript? ( app-text/libspectre )
+ tiff? ( media-libs/tiff )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with chm)
+ $(cmake-utils_use_with crypt QCA2)
+ $(cmake-utils_use_with djvu DjVuLibre)
+ $(cmake-utils_use_with ebook EPub)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with postscript LibSpectre)
+ $(cmake-utils_use_with pdf PopplerQt4)
+ $(cmake-utils_use_with pdf Poppler)
+ $(cmake-utils_use_with tiff)
+ )
+
+ kde4-base_src_configure
+}