summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-02-03 15:50:03 +0000
committerJohannes Huber <johu@gentoo.org>2012-02-03 15:50:03 +0000
commit1110d6a3bcac805de12fafb87e6a717c341cc2a7 (patch)
treec466a7fbfa7bcfe320a6088363e92c7ca2cbad90 /kde-base/libkworkspace
parentRemove old ebuilds now that stabling has been completed. Closes bug #401077 b... (diff)
downloadgentoo-2-1110d6a3bcac805de12fafb87e6a717c341cc2a7.tar.gz
gentoo-2-1110d6a3bcac805de12fafb87e6a717c341cc2a7.tar.bz2
gentoo-2-1110d6a3bcac805de12fafb87e6a717c341cc2a7.zip
Add upstream patch by Michael Palimaka <kde@scribeofthenile.com>, to make pam support optional in kde modules kde-base/kdm and kde-base/kcheckpass wrt bug #398333.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/libkworkspace')
-rw-r--r--kde-base/libkworkspace/ChangeLog12
-rw-r--r--kde-base/libkworkspace/files/libkworkspace-4.8.0-pam-optional.patch18
-rw-r--r--kde-base/libkworkspace/libkworkspace-4.7.4-r2.ebuild37
-rw-r--r--kde-base/libkworkspace/libkworkspace-4.8.0-r1.ebuild (renamed from kde-base/libkworkspace/libkworkspace-4.8.0.ebuild)6
4 files changed, 71 insertions, 2 deletions
diff --git a/kde-base/libkworkspace/ChangeLog b/kde-base/libkworkspace/ChangeLog
index c71fc539ad1e..7b395b4ef7b4 100644
--- a/kde-base/libkworkspace/ChangeLog
+++ b/kde-base/libkworkspace/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for kde-base/libkworkspace
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/libkworkspace/ChangeLog,v 1.120 2012/01/25 18:17:04 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkworkspace/ChangeLog,v 1.121 2012/02/03 15:50:03 johu Exp $
+
+*libkworkspace-4.8.0-r1 (03 Feb 2012)
+*libkworkspace-4.7.4-r2 (03 Feb 2012)
+
+ 03 Feb 2012; Johannes Huber <johu@gentoo.org>
+ +files/libkworkspace-4.8.0-pam-optional.patch, +libkworkspace-4.7.4-r2.ebuild,
+ +libkworkspace-4.8.0-r1.ebuild, -libkworkspace-4.8.0.ebuild:
+ Add upstream patch by Michael Palimaka <kde@scribeofthenile.com>, to make pam
+ support optional in kde modules kde-base/kdm and kde-base/kcheckpass wrt bug
+ #398333.
*libkworkspace-4.8.0 (25 Jan 2012)
diff --git a/kde-base/libkworkspace/files/libkworkspace-4.8.0-pam-optional.patch b/kde-base/libkworkspace/files/libkworkspace-4.8.0-pam-optional.patch
new file mode 100644
index 000000000000..cfd71edc3cb9
--- /dev/null
+++ b/kde-base/libkworkspace/files/libkworkspace-4.8.0-pam-optional.patch
@@ -0,0 +1,18 @@
+commit 619f589f523448fd5b47f3c59ec2994642312585
+Author: Theo Chatzimichos <tampakrap@gentoo.org>
+Date: Fri Feb 3 15:51:10 2012 +0100
+
+ Fix optional PAM support, patch by Michael Palimaka <kde@scribeofthenile.com>
+
+ REVIEW:103818
+
+diff --git a/cmake/modules/UnixAuth.cmake b/cmake/modules/UnixAuth.cmake
+index 904f0cb..0347251 100644
+--- a/cmake/modules/UnixAuth.cmake
++++ b/cmake/modules/UnixAuth.cmake
+@@ -1,4 +1,4 @@
+-find_package(PAM)
++macro_optional_find_package(PAM)
+
+ include(CheckFunctionExists)
+ include(CheckLibraryExists)
diff --git a/kde-base/libkworkspace/libkworkspace-4.7.4-r2.ebuild b/kde-base/libkworkspace/libkworkspace-4.7.4-r2.ebuild
new file mode 100644
index 000000000000..b81588a09580
--- /dev/null
+++ b/kde-base/libkworkspace/libkworkspace-4.7.4-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkworkspace/libkworkspace-4.7.4-r2.ebuild,v 1.1 2012/02/03 15:50:03 johu Exp $
+
+EAPI=4
+
+KMNAME="kde-workspace"
+KMMODULE="libs/kworkspace"
+inherit kde4-meta
+
+DESCRIPTION="A library for KDE desktop applications"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+KMEXTRACTONLY="
+ ksmserver/org.kde.KSMServerInterface.xml
+ kwin/org.kde.KWin.xml
+"
+
+KMSAVELIBS="true"
+
+DEPEND="
+ x11-libs/libxkbfile
+ x11-libs/libXcomposite
+"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.8.0-pam-optional.patch"
+)
+
+src_prepare() {
+ sed -i -e 's/install( FILES kdisplaymanager.h/install( FILES kdisplaymanager.h screenpreviewwidget.h/' \
+ libs/kworkspace/CMakeLists.txt || die "failed to provide screenpreviewwidget.h"
+
+ kde4-meta_src_prepare
+}
diff --git a/kde-base/libkworkspace/libkworkspace-4.8.0.ebuild b/kde-base/libkworkspace/libkworkspace-4.8.0-r1.ebuild
index 51b671644f35..1d22c1ce26bc 100644
--- a/kde-base/libkworkspace/libkworkspace-4.8.0.ebuild
+++ b/kde-base/libkworkspace/libkworkspace-4.8.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/libkworkspace/libkworkspace-4.8.0.ebuild,v 1.1 2012/01/25 18:17:04 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkworkspace/libkworkspace-4.8.0-r1.ebuild,v 1.1 2012/02/03 15:50:03 johu Exp $
EAPI=4
@@ -25,6 +25,10 @@ DEPEND="
"
RDEPEND=${DEPEND}
+PATCHES=(
+ "${FILESDIR}/${PN}-4.8.0-pam-optional.patch"
+)
+
src_prepare() {
sed -i -e 's/install( FILES kdisplaymanager.h/install( FILES kdisplaymanager.h screenpreviewwidget.h/' \
libs/kworkspace/CMakeLists.txt || die "failed to provide screenpreviewwidget.h"