summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-04-03 21:38:26 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-04-03 21:38:26 +0000
commit4fb838e7b2fcbfbfb686733132531602c9fdd769 (patch)
tree20c5f77dff601e6c3240fd0b97ee5a307e6480e0 /kde-base/kwin
parentVersion bump to KDE 4.0.3. This is still not intended for mainstream so DO NO... (diff)
downloadgentoo-2-4fb838e7b2fcbfbfb686733132531602c9fdd769.tar.gz
gentoo-2-4fb838e7b2fcbfbfb686733132531602c9fdd769.tar.bz2
gentoo-2-4fb838e7b2fcbfbfb686733132531602c9fdd769.zip
Version bump to KDE 4.0.3. This is still not intended for mainstream so DO NOT KEYWORD IT without talking to the KDE herd first.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/kwin')
-rw-r--r--kde-base/kwin/ChangeLog8
-rw-r--r--kde-base/kwin/kwin-4.0.3.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/kde-base/kwin/ChangeLog b/kde-base/kwin/ChangeLog
index 54a14a1e7054..696653bc0c52 100644
--- a/kde-base/kwin/ChangeLog
+++ b/kde-base/kwin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kwin
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.117 2008/03/21 16:33:29 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.118 2008/04/03 21:38:26 philantrop Exp $
+
+*kwin-4.0.3 (03 Apr 2008)
+
+ 03 Apr 2008; Wulf C. Krueger <philantrop@gentoo.org> +kwin-4.0.3.ebuild:
+ Version bump to KDE 4.0.3. This is still not intended for mainstream so DO
+ NOT KEYWORD IT without talking to the KDE herd first.
21 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org> -kwin-4.0.1.ebuild:
Old.
diff --git a/kde-base/kwin/kwin-4.0.3.ebuild b/kde-base/kwin/kwin-4.0.3.ebuild
new file mode 100644
index 000000000000..35633bf4c86c
--- /dev/null
+++ b/kde-base/kwin/kwin-4.0.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.0.3.ebuild,v 1.1 2008/04/03 21:38:26 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdebase-workspace
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE window manager"
+KEYWORDS="~amd64 ~x86"
+IUSE="captury opengl xcomposite xinerama"
+
+COMMONDEPEND="
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ >=x11-libs/libXrandr-1.2.1
+ x11-libs/libXrender
+ captury? ( media-libs/libcaptury )
+ opengl? ( virtual/opengl )
+ xcomposite? ( x11-libs/libXcomposite )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${COMMONDEPEND}
+ x11-proto/damageproto
+ x11-proto/renderproto
+ xcomposite? ( x11-proto/compositeproto )
+ xinerama? ( x11-proto/xineramaproto )"
+RDEPEND="${COMMONDEPEND}"
+
+src_compile() {
+ if ! use captury; then
+ sed -e 's:^PKGCONFIG..libcaptury:#DONOTFIND &:' \
+ -i "${S}"/kwin/effects/CMakeLists.txt || \
+ die "Making captury optional failed."
+ fi
+
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with xcomposite X11_Xcomposite)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+
+ kde4-meta_src_compile
+}