summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-05-01 13:49:37 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-05-01 13:49:37 +0000
commit425a68e69e85504669490ce11be29e1c658a1a08 (patch)
tree369e7b0dbdac7c9993a138e658b86d341d911162 /kde-base/kttsd
parentVersion bump. (diff)
downloadgentoo-2-425a68e69e85504669490ce11be29e1c658a1a08.tar.gz
gentoo-2-425a68e69e85504669490ce11be29e1c658a1a08.tar.bz2
gentoo-2-425a68e69e85504669490ce11be29e1c658a1a08.zip
Revised dependencies.
(Portage version: 2203-svn)
Diffstat (limited to 'kde-base/kttsd')
-rw-r--r--kde-base/kttsd/ChangeLog5
-rw-r--r--kde-base/kttsd/kttsd-3.5.2.ebuild25
2 files changed, 21 insertions, 9 deletions
diff --git a/kde-base/kttsd/ChangeLog b/kde-base/kttsd/ChangeLog
index db631f6f630b..7338eab7b0e2 100644
--- a/kde-base/kttsd/ChangeLog
+++ b/kde-base/kttsd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/kttsd
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/ChangeLog,v 1.42 2006/04/06 02:59:16 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/ChangeLog,v 1.43 2006/05/01 13:49:37 carlo Exp $
+
+ 01 May 2006; Carsten Lohrke <carlo@gentoo.org> kttsd-3.5.2.ebuild:
+ Revised dependencies.
06 Apr 2006; Diego Pettenò <flameeyes@gentoo.org> -kttsd-3.5.0.ebuild,
-kttsd-3.5.1.ebuild:
diff --git a/kde-base/kttsd/kttsd-3.5.2.ebuild b/kde-base/kttsd/kttsd-3.5.2.ebuild
index 4104ba8fbda2..bbcbc6b88ecf 100644
--- a/kde-base/kttsd/kttsd-3.5.2.ebuild
+++ b/kde-base/kttsd/kttsd-3.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/kttsd-3.5.2.ebuild,v 1.2 2006/03/28 04:59:50 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/kttsd-3.5.2.ebuild,v 1.3 2006/05/01 13:49:37 carlo Exp $
KMNAME=kdeaccessibility
MAXKDEVER=$PV
KM_DEPRANGE="$PV $MAXKDEVER"
@@ -8,12 +8,13 @@ inherit kde-meta
DESCRIPTION="KDE text-to-speech subsystem"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="alsa gstreamer"
-DEPEND="media-libs/akode
+IUSE="akode alsa gstreamer"
+DEPEND="akode? ( media-libs/akode )
alsa? ( media-libs/alsa-lib )
gstreamer? ( =media-libs/gstreamer-0.8*
=media-libs/gst-plugins-0.8* )
- $(deprange-dual $PV $MAXKDEVER kde-base/kcontrol)"
+ $(deprange-dual $PV $MAXKDEVER kde-base/kcontrol)
+ !arts? ( !alsa? ( !gstreamer? ( media-libs/akode ) ) )"
RDEPEND="${DEPEND}
|| ( app-accessibility/festival
@@ -21,12 +22,20 @@ RDEPEND="${DEPEND}
app-accessibility/flite
app-accessibility/freetts )"
-DEPEND="${DEPEND}
- dev-util/pkgconfig"
+pkg_setup() {
+ if ! use arts && ! use alsa && ! use gstreamer && ! use akode ; then
+ ewarn "No audio backend chosen. Defaulting to media-libs/akode."
+ fi
+}
src_compile() {
- local myconf="--with-akode
- $(use_with alsa) $(use_with gstreamer)"
+ local myconf="$(use_with alsa) $(use_with gstreamer)"
+
+ if ! use arts && ! use alsa && ! use gstreamer ; then
+ myconf="${myconf} --with-akokde"
+ else
+ myconf="${myconf} $(use_with akode)"
+ fi
kde-meta_src_compile
}