summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2014-01-10 04:22:20 +0000
committerChris Reffett <creffett@gentoo.org>2014-01-10 04:22:20 +0000
commit803efb3b1f3061a26772f670a2e44a59efbf3f3f (patch)
tree82f2adcff5045d9821efd3318efe2cacf46c43ea /kde-base/ksystemlog
parent0.7.5 bump (diff)
downloadgentoo-2-803efb3b1f3061a26772f670a2e44a59efbf3f3f.tar.gz
gentoo-2-803efb3b1f3061a26772f670a2e44a59efbf3f3f.tar.bz2
gentoo-2-803efb3b1f3061a26772f670a2e44a59efbf3f3f.zip
Bump KDE SC 4.11.5
(Portage version: 2.2.8/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/ksystemlog')
-rw-r--r--kde-base/ksystemlog/ChangeLog9
-rw-r--r--kde-base/ksystemlog/ksystemlog-4.11.5.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/kde-base/ksystemlog/ChangeLog b/kde-base/ksystemlog/ChangeLog
index c009e39966b4..1336b80e2cf3 100644
--- a/kde-base/ksystemlog/ChangeLog
+++ b/kde-base/ksystemlog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksystemlog
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.184 2013/12/18 19:57:56 johu Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.185 2014/01/10 04:21:39 creffett Exp $
+
+*ksystemlog-4.11.5 (10 Jan 2014)
+
+ 10 Jan 2014; Chris Reffett <creffett@gentoo.org> +ksystemlog-4.11.5.ebuild:
+ Bump KDE SC 4.11.5
*ksystemlog-4.12.0 (18 Dec 2013)
diff --git a/kde-base/ksystemlog/ksystemlog-4.11.5.ebuild b/kde-base/ksystemlog/ksystemlog-4.11.5.ebuild
new file mode 100644
index 000000000000..efc1bff30ded
--- /dev/null
+++ b/kde-base/ksystemlog/ksystemlog-4.11.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ksystemlog-4.11.5.ebuild,v 1.1 2014/01/10 04:21:39 creffett Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+VIRTUALX_REQUIRED=test
+inherit kde4-base
+
+DESCRIPTION="KDE system log viewer"
+HOMEPAGE="http://www.kde.org/applications/system/ksystemlog/"
+KEYWORDS=" ~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug test"
+
+RESTRICT=test
+# bug 378101
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}