summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-03-10 23:53:19 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-03-10 23:53:19 +0000
commit3ce9d5d9429510eca569a2e6eb06c977d8a722de (patch)
tree44002b8ae06a07c4bac74a2a5e1a9e74835c7a9c /kde-base/kstars
parentVersion bump to KDE 4.0.2. (diff)
downloadgentoo-2-3ce9d5d9429510eca569a2e6eb06c977d8a722de.tar.gz
gentoo-2-3ce9d5d9429510eca569a2e6eb06c977d8a722de.tar.bz2
gentoo-2-3ce9d5d9429510eca569a2e6eb06c977d8a722de.zip
Version bump to KDE 4.0.2.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/kstars')
-rw-r--r--kde-base/kstars/ChangeLog7
-rw-r--r--kde-base/kstars/kstars-4.0.2.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/kde-base/kstars/ChangeLog b/kde-base/kstars/ChangeLog
index 2ab9239f4b08..ad8c0366f413 100644
--- a/kde-base/kstars/ChangeLog
+++ b/kde-base/kstars/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kstars
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.88 2008/03/04 03:40:26 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.89 2008/03/10 23:53:19 philantrop Exp $
+
+*kstars-4.0.2 (10 Mar 2008)
+
+ 10 Mar 2008; Wulf C. Krueger <philantrop@gentoo.org> +kstars-4.0.2.ebuild:
+ Version bump to KDE 4.0.2
04 Mar 2008; Jeroen Roovers <jer@gentoo.org> kstars-3.5.8.ebuild,
kstars-3.5.9.ebuild, kstars-4.0.1.ebuild:
diff --git a/kde-base/kstars/kstars-4.0.2.ebuild b/kde-base/kstars/kstars-4.0.2.ebuild
new file mode 100644
index 000000000000..b2c73b13c295
--- /dev/null
+++ b/kde-base/kstars/kstars-4.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/kstars-4.0.2.ebuild,v 1.1 2008/03/10 23:53:19 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdeedu
+inherit kde4-meta
+
+DESCRIPTION="KDE Desktop Planetarium"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug fits htmlhandbook nova sbig usb"
+
+DEPEND=">=kde-base/libkdeedu-${PV}:${SLOT}
+ fits? ( sci-libs/cfitsio )
+ nova? ( >=sci-libs/libnova-0.12.1 )
+ sbig? ( sci-libs/indilib
+ usb? ( dev-libs/libusb ) )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ epatch "${FILESDIR}/${PN}-4.0.0-destdir.patch"
+
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with fits CFitsio)
+ $(cmake-utils_use_with nova Nova)
+ $(cmake-utils_use_with sbig SBIG)
+ $(cmake-utils_use_with usb USB)"
+
+ kde4-meta_src_compile
+
+ # FIXME Unhandled arguments - added sbig but not sure about use descriptions or flag names...
+ # WITH_SBIG - Switch which controls the detection of the proprietary and binary only SBIG CCD universal library. No ebuild for this package
+ # are available at the moment.
+ # ssh_tunnel -> INDI Server binds locally. Remote clients may only connect
+ # via SSH Tunneling.
+}