summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-09-06 01:16:41 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-09-06 01:16:41 +0000
commit74adbd9113fa479384eaa4e3e5ed81b9aca8ae96 (patch)
tree379813b22cccecb53b2a838ba51e4695df43c59b /kde-base/ksplash
parentAdd dep for brltty, see #326491 (diff)
downloadgentoo-2-74adbd9113fa479384eaa4e3e5ed81b9aca8ae96.tar.gz
gentoo-2-74adbd9113fa479384eaa4e3e5ed81b9aca8ae96.tar.bz2
gentoo-2-74adbd9113fa479384eaa4e3e5ed81b9aca8ae96.zip
Version bump KDE SC 4.5.1
(Portage version: 2.2_rc75/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog8
-rw-r--r--kde-base/ksplash/ksplash-4.5.1.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index 64a902a95019..bfc4c369569f 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.75 2010/08/10 13:20:35 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.76 2010/09/06 01:16:41 tampakrap Exp $
+
+*ksplash-4.5.1 (06 Sep 2010)
+
+ 06 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +ksplash-4.5.1.ebuild:
+ Version bump
10 Aug 2010; Tomáš Chvátal <scarabeus@gentoo.org>
-files/ksplash-4.3.5-libpng14.patch:
diff --git a/kde-base/ksplash/ksplash-4.5.1.ebuild b/kde-base/ksplash/ksplash-4.5.1.ebuild
new file mode 100644
index 000000000000..abfaee52f4a2
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.5.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.5.1.ebuild,v 1.1 2010/09/06 01:16:41 tampakrap Exp $
+
+EAPI="3"
+
+KMNAME="kdebase-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS=""
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+COMMONDEPEND="
+ media-libs/libpng
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-4.4.2-xinerama_cmake_automagic.patch" )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_has 3dnow X86_3DNOW)
+ $(cmake-utils_use_has altivec PPC_ALTIVEC)
+ $(cmake-utils_use_has mmx X86_MMX)
+ $(cmake-utils_use_has sse X86_SSE)
+ $(cmake-utils_use_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama X11_Xinerama)
+ )
+
+ kde4-meta_src_configure
+}