summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-06-15 00:00:01 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-06-15 00:00:01 +0000
commite436c54fdfce849ec540e5444275f536d424d264 (patch)
treee8fdd7a58745f35dbe2ba4e877cb9f1cb770789e /kde-base/kopete
parentfix mksh URL (diff)
downloadgentoo-2-e436c54fdfce849ec540e5444275f536d424d264.tar.gz
gentoo-2-e436c54fdfce849ec540e5444275f536d424d264.tar.bz2
gentoo-2-e436c54fdfce849ec540e5444275f536d424d264.zip
Fix for bug #136167.
(Portage version: 2.1)
Diffstat (limited to 'kde-base/kopete')
-rw-r--r--kde-base/kopete/ChangeLog7
-rw-r--r--kde-base/kopete/files/digest-kopete-3.5.3-r16
-rw-r--r--kde-base/kopete/kopete-3.5.3-r1.ebuild57
3 files changed, 69 insertions, 1 deletions
diff --git a/kde-base/kopete/ChangeLog b/kde-base/kopete/ChangeLog
index 76b3a1dcce41..b99872aec740 100644
--- a/kde-base/kopete/ChangeLog
+++ b/kde-base/kopete/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kopete
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.64 2006/06/01 19:26:17 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.65 2006/06/15 00:00:01 carlo Exp $
+
+*kopete-3.5.3-r1 (14 Jun 2006)
+
+ 14 Jun 2006; Carsten Lohrke <carlo@gentoo.org> +kopete-3.5.3-r1.ebuild:
+ Fix for bug #136167.
*kopete-3.5.3 (01 Jun 2006)
diff --git a/kde-base/kopete/files/digest-kopete-3.5.3-r1 b/kde-base/kopete/files/digest-kopete-3.5.3-r1
new file mode 100644
index 000000000000..0d9cb09f0130
--- /dev/null
+++ b/kde-base/kopete/files/digest-kopete-3.5.3-r1
@@ -0,0 +1,6 @@
+MD5 07d313f91154d3c2f4620b921277fdc8 kdenetwork-3.5-patchset-01.tar.bz2 2986
+RMD160 288113734e7767a7526f4b9311c1985ac8aa91bf kdenetwork-3.5-patchset-01.tar.bz2 2986
+SHA256 0bbde1adaa4e8fff02c1f1fd6ceb66ec9af14dd19ff64567ab0fd03926d7d05b kdenetwork-3.5-patchset-01.tar.bz2 2986
+MD5 119af91a048c34d9a917a1898f215554 kdenetwork-3.5.3.tar.bz2 7524718
+RMD160 0c57f39652946c577ad0d6ec7f4fc593fe38a0bc kdenetwork-3.5.3.tar.bz2 7524718
+SHA256 f0323e33226b30ca30bfee05a9b6da8a1de964c9593d134294f83a54db0f4f3c kdenetwork-3.5.3.tar.bz2 7524718
diff --git a/kde-base/kopete/kopete-3.5.3-r1.ebuild b/kde-base/kopete/kopete-3.5.3-r1.ebuild
new file mode 100644
index 000000000000..e1cf22142713
--- /dev/null
+++ b/kde-base/kopete/kopete-3.5.3-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-3.5.3-r1.ebuild,v 1.1 2006/06/15 00:00:01 carlo Exp $
+
+KMNAME=kdenetwork
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdenetwork-3.5-patchset-01.tar.bz2"
+
+DESCRIPTION="KDE multi-protocol IM client"
+HOMEPAGE="http://kopete.kde.org/"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="sametime ssl xmms"
+
+# The kernel_linux? ( ) conditional dependencies are for webcams, not supported
+# on other kernels AFAIK
+BOTH_DEPEND="dev-libs/libxslt
+ dev-libs/libxml2
+ net-dns/libidn
+ >=dev-libs/glib-2
+ app-crypt/qca
+ sametime? ( =net-libs/meanwhile-0.4* )
+ xmms? ( media-sound/xmms )
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ ) virtual/x11 )
+ kernel_linux? ( virtual/opengl )"
+
+RDEPEND="${BOTH_DEPEND}
+ ssl? ( app-crypt/qca-tls )"
+
+DEPEND="${BOTH_DEPEND}
+ kernel_linux? ( virtual/os-headers )
+ || ( (
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xproto
+ kernel_linux? ( x11-libs/libXv )
+ x11-proto/scrnsaverproto
+ ) virtual/x11 )"
+
+src_compile() {
+ # External libgadu support - doesn't work, kopete requires a specific development snapshot of libgadu.
+ # Maybe we can enable it in the future.
+ # The nowlistening plugin has xmms support.
+ local myconf="$(use_enable sametime sametime-plugin)
+ $(use_with xmms) --without-external-libgadu"
+
+ kde-meta_src_compile
+}